#opendaylight-armoury: Armoury weekly

Meeting started by adetalhouet at 18:16:08 UTC (full logs).

Meeting summary

  1. Roll Call (adetalhouet, 18:16:23)
    1. mmarsale (mmarsale, 18:16:41)
    2. grmontpetit (grmontpetit, 18:18:19)
    3. alagalah (alagalah, 18:18:23)
    4. anipbu (anipbu, 18:18:32)

  2. Agenda bashing (adetalhouet, 18:20:25)
    1. Action Items from last meeting (adetalhouet, 18:20:35)
    2. mmarsale did start the diagram sequence (adetalhouet, 18:20:49)
    3. https://git.opendaylight.org/gerrit/#/c/27263/ diagram sequence (adetalhouet, 18:21:00)
    4. there is also its associated ML (adetalhouet, 18:21:26)
    5. https://www.websequencediagrams.com/ (mmarsale, 18:21:33)
    6. mmarsale view on how NF/driver/workload: the catalog has files and images necessary for the NF, Workload manager should provide APIs to spawn the NFs and drivers are used to do the heavy lifting on spawning a VM, loading image and configuring it ... (adetalhouet, 18:30:13)
    7. https://github.com/marosmars/yanglib - this is a prototype of ODL based catalog for YANG schemas I implemented some time ago (mmarsale, 18:35:47)

  3. Release plan for M3 (adetalhouet, 18:51:38)
    1. https://wiki.opendaylight.org/view/Armoury/Beryllium_Release_Plan <-armoury release plan (anipbu, 18:54:32)
    2. 1. Define a global use case - as per as mmarsale started (adetalhouet, 18:55:37)
    3. 2. Create the APIs for the workload manager, the NF catalog and the Driver inventory (adetalhouet, 18:56:10)
    4. 3. Define an abstraction layer for the driver (adetalhouet, 18:57:41)
    5. 4. Complete one use case with SFC (adetalhouet, 18:58:12)
    6. ACTION: present the deliverables to the ML (adetalhouet, 19:05:09)

  4. cookies (adetalhouet, 19:05:34)


Meeting ended at 19:05:39 UTC (full logs).

Action items

  1. present the deliverables to the ML


People present (lines said)

  1. adetalhouet (82)
  2. alagalah (27)
  3. mmarsale (21)
  4. grmontpetit (14)
  5. anipbu (13)
  6. odl_meetbot (5)


Generated by MeetBot 0.1.4.