19:15:39 <adetalhouet> #startmeeting Armoury Weekly
19:15:39 <odl_meetbot> Meeting started Mon Nov  2 19:15:39 2015 UTC.  The chair is adetalhouet. Information about MeetBot at http://ci.openstack.org/meetbot.html.
19:15:39 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:15:39 <odl_meetbot> The meeting name has been set to 'armoury_weekly'
19:15:58 <adetalhouet> #topic Roll Call
19:16:05 <adetalhouet> hello folks
19:16:06 <anipbu> #info anipbu
19:16:10 <adetalhouet> please pound in
19:16:17 <gdavid> #info davidg
19:17:58 <adetalhouet> waiting a minute to see if edwarnicke and/or mmarsale will join. I'm under the impression Subh and Keith won't be there
19:18:28 <mmarsale> adetalhouet: Im in a different meeting, but will try to keep track here as well
19:18:31 <mmarsale> #info mmarsale
19:18:47 <adetalhouet> mmarsale: sure, thank you
19:18:57 <adetalhouet> #topic Agenda bashing
19:19:02 <adetalhouet> #link agenda https://wiki.opendaylight.org/view/Armoury#Agenda_for_next_meeting_.2811.2F02.29
19:19:24 <adetalhouet> #info On Going Tasks
19:19:47 <adetalhouet> we will talk about the workload manager
19:19:57 <adetalhouet> #info Open discussion
19:20:04 <adetalhouet> we will talk about jdk8 support
19:20:21 <adetalhouet> Do you want to add a topic?
19:20:44 <adetalhouet> #topic On going task
19:21:11 <adetalhouet> So about the workload manager, I see gdavid is there
19:21:18 <adetalhouet> is there anything you want to share?
19:21:39 <gdavid> We are now using the catalog
19:21:40 <adetalhouet> I know Subh is working on the rework of the model to make it async
19:21:55 <gdavid> And we added a status to the work manager
19:22:16 <adetalhouet> gdavid: ok perfect :)
19:23:09 <adetalhouet> what about the RPC implementation? do you know how far did Ariel and Subh go?
19:23:49 <gdavid> I dont think Ariel started it
19:24:52 <adetalhouet> Ok, I checked on trello also and I can't see any track of this, so I guess it's still pending
19:25:26 <adetalhouet> Is there anything you want to discuss ?
19:26:00 <gdavid> When are we planning to start the implementation?
19:27:05 <adetalhouet> gdavid: good question :)
19:27:25 <adetalhouet> We could start planing now, what do you wish to see implemented in a first place?
19:27:50 <adetalhouet> I know some work is going to be done regarding drivers (mostly tacker and docker)
19:28:06 <adetalhouet> We need to implement the whole NFCatalog
19:28:07 <gdavid> The workload manager and catalog
19:29:08 <adetalhouet> I agree those are very important
19:29:41 <adetalhouet> the thing is, we need to find folks to implement the various component of the project
19:29:48 <adetalhouet> I'm willing to work on the catalog
19:30:09 <adetalhouet> #action start implementing the catalog
19:30:35 <adetalhouet> I think Subh and Ariel and on the workload manager
19:30:50 <adetalhouet> but I don't know what they've done so far, and there are not here to discuss it :(
19:30:57 <adetalhouet> #undo
19:30:57 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x261c110>
19:31:06 <adetalhouet> #action adetalhouet to start implementing the catalog
19:32:38 <adetalhouet> gdavid: are you willing to get involve in the implementation of the workload manager and/or the catalog? :)
19:32:56 <gdavid> We can ask Subh and ariel to send a mail to the group regarding the workload manager implementation status
19:33:11 <adetalhouet> gdavid: could you send the mail?
19:33:26 <gdavid> I will join Ariel with that implementation
19:33:43 <gdavid> I will ask Ariel to send the mail with the updated status
19:33:59 <adetalhouet> #action gdavid to help on the workload manager implementation
19:34:33 <adetalhouet> #action gdavid to ask Ariel to send an update status mail regarding the workload manager implementation
19:35:02 <adetalhouet> shall we move on to the next topic?
19:35:16 <gdavid> I guess so
19:35:34 <adetalhouet> #topic JDK8 support
19:35:41 <anipbu> https://git.opendaylight.org/gerrit/#/c/29160/
19:35:43 <adetalhouet> anipbu: I believe you added this right?
19:35:50 <adetalhouet> #link https://git.opendaylight.org/gerrit/#/c/29160/
19:35:51 <anipbu> Yes, I added it
19:35:56 <anipbu> I wanted to ask the team
19:36:04 <anipbu> if we're okay with moving to jdk8 as default
19:36:15 <adetalhouet> Armoury is fully JDK8 compatible as there is really few implementation for now
19:36:25 <adetalhouet> so I think this is really fine
19:36:32 <anipbu> perfect, then I'll go ahead and push this to our cfg file
19:36:51 <adetalhouet> sound fabulous :) Thank you
19:37:01 <anipbu> Thanks, that's it from me
19:37:22 <adetalhouet> Ok well, now is the good time if you wish to discuss anything else?
19:38:22 <anipbu> Just to let the team know that I was at OpenStack and there was much interest in Armoury
19:38:51 <adetalhouet> I see alagalah joining,  is there anything you wish to discuss today?
19:38:55 <anipbu> Many were asking about OpenDaylight -> Armoury - > OpenStack (Magnum, Tacker)
19:39:04 <adetalhouet> anipbu: I'm really glad to here that :)
19:39:20 <adetalhouet> We really need to get more involve in the project and start getting things done
19:39:58 <adetalhouet> here/hear
19:41:14 <adetalhouet> Seems nothing more will be discuss today
19:41:19 <adetalhouet> #topic cookies
19:41:34 <adetalhouet> have a great day folks
19:41:47 <gdavid> Good night :)
19:41:53 <adetalhouet> #endmeeting