15:07:34 <colindixon> #startmeeting MD-SAL hackers
15:07:34 <odl_meetbot> Meeting started Mon Oct 20 15:07:34 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:07:34 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:07:34 <odl_meetbot> The meeting name has been set to 'md_sal_hackers'
15:07:40 <colindixon> #topic agenda bashing
15:07:47 <colindixon> #chair alagalah tbachman
15:07:47 <odl_meetbot> Current chairs: alagalah colindixon tbachman
15:09:22 <colindixon> #info two topics are brought up: (1) usability discussions for MD-SAL in general and (2) possibly trying to identify sub-projects of controller
15:09:32 <colindixon> #topic usability update
15:10:50 <tbachman> #info alagalah has started looking at the existing wiki links to help with the usability, and published his recommendations (see last week’s meeting minutes)
15:11:00 <colindixon> #info alagalah notes that this initiative started with the question of “how a newbie could get started with the MD-SAL, config subsystem, YANG, etc.”
15:11:31 <colindixon> #info goal is to have it be possible for somebody to get anything they need to know in six clicks on the wiki
15:11:48 <colindixon> (I really hope it’s less than 6 clicks, or that 3-4 of those clicks are really easy)
15:13:32 <tbachman> #info alagalah says we need to annotate the yang a bit better
15:14:02 <dfarrell07> Aside: Should add this to wiki/Meetings and the gcal if it's going to be a regular meeting (I can make the updates)
15:14:21 <dfarrell07> https://wiki.opendaylight.org/view/Meetings
15:14:29 <tbachman> dfarrell07: good point!
15:15:08 * dfarrell07 isn't on audio, fyi
15:15:11 <tbachman> #info tpatellis says that going through explaining the config system to alagalah revealed how difficult it is to explain the config system to new folks
15:15:11 <alagalah> colindixon: It was more an expression
15:15:17 <tbachman> dfarrell07: ?
15:15:26 <alagalah> tbachman: he is saying he isn't on the webex
15:15:28 <tbachman> ah
15:15:29 <tbachman> :)
15:15:30 <alagalah> I think
15:15:33 <dfarrell07> ^^yeah :)
15:16:33 <tbachman> #info tpatellis notes that this wasn’t discussed at the dev summit; we could try to document it, but it’s still difficult to consume
15:18:41 <tbachman> #info jmedved says that John Burns (?) should be helping with this process
15:19:20 <tbachman> #info colindixon notes that there’s no obvious entry point on the wiki on how to on-board with this stuff
15:19:48 <tbachman> #info colindixon also notes that there are several “eras” of the MD-SAL documentation, which makes this more confusing
15:20:22 <tbachman> #info colindixon recommends adding things like “this is out of date” to pages that are no longer relevant.
15:20:41 <tbachman> #info jmedved asks how we can remove content
15:20:42 <dfarrell07> Is this info correct? https://wiki.opendaylight.org/view/Meetings#MD-SAL_Hackers
15:21:01 <tbachman> #info colindixon says he hates to remove content — would prefer just indicating that the content is old
15:21:36 <tbachman> dfarrell07: here’s the link I used https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL#MD-SAL_Hackers_Weekly_Call
15:21:46 <dfarrell07> tbachman: Thanks! :)
15:21:50 <tbachman> np! :)
15:22:40 <tbachman> #info jmedved says we should make clear that the config system and MD-SAL are two different components
15:23:12 <tbachman> #info colindixon says we need to break up the MD-SAL documentation (i.e. two people working for two weeks isn’t sufficient)
15:24:35 <tbachman> #action alagalah says that he’ll take his recommmendations/links from last weeks, and stuff from tpatellis, and publish a list of concrete things that need to happen using bugzilla
15:24:54 <colindixon> thanks for scribing tbachman
15:25:37 <colindixon> you rock
15:25:37 <tbachman> colindixon: np! :)
15:25:39 <tbachman> #info jmedved notes that even with documentation, it’s still difficult to use, and asks what else we can do to improve the learning curve
15:26:12 <tbachman> #info alagalah says that there are a number of folks who have the “tribal knowledge”, who could investigate writing stuff up on their speciality.
15:27:08 <tbachman> #info jmedved says that rovarga_ ttkacik, and tpatellis are on the call, and wonders if we can assign each of them an action to come up with a set of recommendations for usability by next week
15:27:18 <alagalah> tbachman: Specifically it was around what are the gaps, not producing a writeup
15:27:27 <alagalah> tbachman: That is a MUCH larger task
15:27:27 <tbachman> alagalah: thx!
15:27:36 <tbachman> #undo
15:27:36 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x274a2d0>
15:27:45 <alagalah> tbachman: Are you going to ACTION it ?
15:28:17 <dfarrell07> I added this meeting to the wiki and gcal https://wiki.opendaylight.org/view/Meetings#MD-SAL_Hackers
15:28:22 <tbachman> #info jmedved says that rovarga_ ttkacik, and tpatellis are on the call, and wonders if we can assign each of them an action to identify the gaps we currently have for better usability by next week
15:28:28 <tbachman> alagalah: will do, once folks agree ;)
15:29:02 <tbachman> #info tpatellis says he can identify the pain points, but not yet solutions
15:29:18 <tbachman> #info alagalah will also provide his pain points
15:30:11 <alagalah> #action alagalah to come up with his list of adoption pain points by next meeting
15:30:25 <tbachman> alagalah: was going to do it in a single one :)
15:30:31 <alagalah> #action alagalah to take what he has done so far on the documentation front and break it into chunks
15:30:45 <alagalah> tbachman: Not sure how meetbot works in terms of multiple IDs in one Action verb
15:31:01 <tbachman> alagalah: good point
15:31:14 * tbachman will have to investigate that
15:31:54 * tbachman missed what it was that colindixon was going to do
15:33:47 <colindixon> #action colindixon to send e-mail noting his pain points: (1) it’s hard to figure out how to take the yang file for the config subsystem and translate it into an XML file, and (2) the config yang file is compiled in a different way than yangtools does
15:33:53 <tbachman> colindixon: thx!
15:33:55 <tbachman> tho are you chair?
15:34:04 <tbachman> ah
15:34:06 <tbachman> you started it :)
15:34:07 <colindixon> tbachman: I am the chair, you are too
15:34:07 <tbachman> lol
15:36:39 <tbachman> #info colindixon says that config subsystem probably causes the largest amount of difficulty, but is probably encoutered less often than RPCs and notifications, which may affect what we prioritize as far as documentation
15:37:46 <tbachman> #info uchau asks if the config subsystem is just a “recommended thing to use”, or if it’s really a requirement
15:38:50 <tbachman> #info colindixon says it would be hard for us to mandate using the config subsystem
15:39:48 <tbachman> #info colindixon says that the config subsystem enforces loading order within config subsystem components, but is a separate loading system than OSGI
15:43:31 <tbachman> #info jmedved says that for a system integrator, having a uniform way of managing the components is critical, and therefore we should adopt some conventions on how these things are done
15:45:10 <tbachman> #info rovarga_ says we could create a shim layer on top of the config system, reducing the use cases, to simplify the APIs and concepts, simplifying the user’s interaction with it
15:46:46 <tbachman> #action rovarga_ to write an email describing why the things in the config subsystem are the way they are
15:49:06 <tbachman> #info colindixon asks why the config subsystem is necessary to do clustering (will also go read last week’s meeting minutes, as this was covered there)
15:51:35 <tbachman> #info tpatellis says that the config subsystem could be used as a mechanism for bringing apps down and back up when critical pieces like the data store fail
15:52:26 <tbachman> #info rovarga_ says that trying to understand the dependency graph in something like OSGI is challenging if not impossible, whereas the config subsystem provides some constructs to understand this
15:54:35 <tbachman> #info alagalah says that we need to provide background on all the pieces for ODL (config subsystem, MD-SAL, karaf, etc.) — not just background and how to use them, but when and why.
15:55:14 <tbachman> #info colindixon says there are probably different categories of users that we want to target this towards (i.e. depends on knowledge and use case)
15:58:45 <tbachman> #info colindixon believes that whatever we select as the priority, it’s probably best to use an “all-hands-on-deck” approach in order to get good documentation
16:00:30 <tbachman> #info colindixon asks if folks can pick up an item on the list that alagalah publishes, and indicate that they’ve picked it up
16:00:35 <jmedved> #action keith send out a list of things to do; if people have cycles, pick up the item on the list a nd run with it
16:00:48 <jmedved> #action tom p: list painpoints
16:01:06 <alagalah> #action alagalah send out a list of things to do; if people have cycles, pick up the item on the list a nd run with it
16:01:07 <tbachman> #action alagalah to send out a list of things to do; if people have cycles, pick up the item on the list and run with it
16:01:10 <alagalah> lolz
16:01:12 <colindixon> I have to drop
16:01:13 <colindixon> sorry
16:01:16 <alagalah> Same here
16:01:19 <tbachman> #action tpatellis to provide a list of pain points
16:01:21 <jmedved> #action robert varga: email with background design info on configu subsystem
16:01:24 <alagalah> tbachman: and I have a meeting.
16:01:48 <jmedved> #action robert v: couple of imprvoement/simplification proposal -email
16:01:49 <tbachman> #action rovarga_ email with background design info on configu subsystem
16:02:07 <tbachman> #action couple of imprvoement/simplification proposal -email
16:02:40 <tbachman> #action jmedved to start background architecture wiki using keith’s documentation
16:03:47 <jmedved> #action jmedved start architecture section for config subsystem on wiki
16:04:02 <tbachman> #action jmedved start architecture section for config subsystem on wiki
16:04:20 <jmedved> #action uyen collect pain points from hp folks and send to keith
16:04:30 <tbachman> #action uchau collect pain points from hp folks and send to keith
16:04:34 <jmedved> #info all action items sent to keith, copied folks on the call
16:04:37 <tbachman> #endmeeting