#opendaylight-meeting Meeting

Meeting started by colindixon at 17:00:10 UTC (full logs).

Meeting summary

  1. overview and roll call (colindixon, 17:00:20)
    1. Andrew Grimberg for infrastructure support (tykeal, 17:00:36)
    2. https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1 is the document we're working from (colindixon, 17:00:54)
    3. Ed Warnicke for controller (edwarnicke, 17:00:55)
    4. michal_rehak for openflowplugin (michal_rehak, 17:01:03)
    5. Madhu for ovsdb (Madhu, 17:01:04)
    6. Abhijit Kumbhare openflowplugin (abhijitkumbhare, 17:01:10)
    7. Prasanna for openflowplugin\ (prasanna, 17:01:10)
    8. Chris Wright (cdub, 17:01:12)
    9. Anees / opendove (ashaikh, 17:01:32)
    10. Dana for bgpcep (dkutenic, 17:01:34)
    11. oflibMichal for openflowjava (oflibMichal1, 17:01:53)
    12. Robert for bgpcep (rovarga, 17:02:26)
    13. Konstantin for defense4all (Konstantin, 17:02:55)

  2. how to collect status from projects quickly (colindixon, 17:03:46)
    1. cdub suggests that we just have it filled in on the project-specific sheet of the progress tracking in the status column (colindixon, 17:04:09)
    2. we also have ttkacik_ and janmedved in attendance (colindixon, 17:04:29)

  3. documentation (colindixon, 17:04:59)
    1. Phil Robb here as well (phrobb, 17:05:37)
    2. https://lists.opendaylight.org/pipermail/discuss/2014-January/001067.html is the e-mail RobDolin sent to the discuss list containing the first draft of the user manual and developer guide (colindixon, 17:06:36)
    3. ACTION: RobDolin to post the user manual and developer guide templates to the wiki in the next 24 hours (colindixon, 17:09:17)
    4. ACTION: colindixon will link to the log level stuff and any others from the Hydrogen Release Work page (colindixon, 17:09:59)

  4. download page (colindixon, 17:11:24)
    1. shague said the general layout of the page has been worked out, the base edition artifacts have been worked out, and they're working on the other editions (colindixon, 17:12:18)

  5. log level recommendations (colindixon, 17:12:40)
    1. https://wiki.opendaylight.org/view/Draft_Syslog_Level_Settings (colindixon, 17:12:56)
    2. ryan moats (regexboi) posted the revised version with the logback levels (colindixon, 17:13:28)
    3. ACTION: phrobb or shague to provide a link for the progress on the download page and particular artifacts per edition (colindixon, 17:14:34)
    4. AGREED: change "bundle" to "module" in the log level recommendations (colindixon, 17:17:03)
    5. AGREED: expand the scope of trace to include items such as logging messages received and others (colindixon, 17:17:42)
    6. https://wiki.opendaylight.org/view/Draft_Syslog_Level_Settings page updated, anyone see issues? (edwarnicke, 17:18:31)
    7. Madhu and rovarga say that they think module start/stop should be DEBUG and not INFO, but this will be taken to the mailing list (colindixon, 17:21:00)

  6. system.out.println() (colindixon, 17:21:23)
    1. AGREED: individual projects can choose whether or not System.out.println is allowed in their Integration and unit tests, but in production running code it should not be used (colindixon, 17:24:51)
    2. AGREED: code that does not get run by launching the controller in the normal fashion can use system.out.println at the project's discretion, for example, to provide a CLI that runs outside the JVM (colindixon, 17:30:41)

  7. per-project issues (colindixon, 17:30:53)
    1. in the goal of saving time during these meetings, the bulk of the communication for completion of per-project tasks will take place offline via the sheets for individual projects (colindixon, 17:32:42)
    2. https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1 this spreadsheet has the sheets to fill in the info for (colindixon, 17:32:57)
    3. controller: All per project items in Global Code cleanup have a person signed up (thought its all edwarnicke right now, so the names may be updated) (edwarnicke, 17:33:11)
    4. Defense4all Jenkins job is done. No changes suggested. 2 WARN will be fixed till next submit. (Konstantin, 17:34:00)
    5. ACTION: colindixon to send an e-mail to discuss calling on people to update their sheets (colindixon, 17:34:04)
    6. ACTION: everyone please deal with their version synchronization as specified in the following link (colindixon, 17:35:40)
    7. https://wiki.opendaylight.org/view/Simultaneous_Release:Simultaneous_Release_Plan_2014:ReleaseRecommendations (colindixon, 17:35:56)
    8. versions status are tracked under : https://docs.google.com/spreadsheet/ccc?key=0Anypq0z_rOtOdE1YOUFSejQ0TGk0TkFhbVdEZ0d0VHc#gid=0 please edit it (Madhu, 17:36:09)

  8. end of meeting (colindixon, 17:39:49)
  9. report to TSC (colindixon, 17:40:42)
    1. we'd like to keep the report high-level, most things seem on track, documentation seems to be a few days behind, but is showing progress now (colindixon, 17:42:26)
    2. cross-project dependencies and versioning needs to be prioritized to be able to start testing ASAP (colindixon, 17:43:00)
    3. Madhu would like to ask projects to try to get to code freeze before 1/27 if possible (colindixon, 17:43:22)
    4. ACTION: colindixon to follow up with projects about release reviews and release notes to make sure those things don't fall behind (colindixon, 17:44:13)
    5. tsc report is now a tab in the main sheet (colindixon, 17:50:05)
    6. https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=15 is showing the TSC summary (edwarnicke, 17:50:09)

  10. mailing lists (colindixon, 17:50:19)
    1. some push to consolidate to fewer lists, but tabled to after hydrogen (colindixon, 17:50:34)


Meeting ended at 17:50:37 UTC (full logs).

Action items

  1. RobDolin to post the user manual and developer guide templates to the wiki in the next 24 hours
  2. colindixon will link to the log level stuff and any others from the Hydrogen Release Work page
  3. phrobb or shague to provide a link for the progress on the download page and particular artifacts per edition
  4. colindixon to send an e-mail to discuss calling on people to update their sheets
  5. everyone please deal with their version synchronization as specified in the following link
  6. colindixon to follow up with projects about release reviews and release notes to make sure those things don't fall behind


Action items, by person

  1. colindixon
    1. colindixon will link to the log level stuff and any others from the Hydrogen Release Work page
    2. colindixon to send an e-mail to discuss calling on people to update their sheets
    3. colindixon to follow up with projects about release reviews and release notes to make sure those things don't fall behind
  2. phrobb
    1. phrobb or shague to provide a link for the progress on the download page and particular artifacts per edition
  3. RobDolin
    1. RobDolin to post the user manual and developer guide templates to the wiki in the next 24 hours


People present (lines said)

  1. colindixon (120)
  2. edwarnicke (53)
  3. Madhu (48)
  4. cdub (15)
  5. Konstantin (9)
  6. rovarga (8)
  7. RobDolin (5)
  8. tykeal (4)
  9. networkstatic (4)
  10. michal_rehak (3)
  11. abhijitkumbhare (3)
  12. phrobb (2)
  13. odl_meetbot (2)
  14. prasanna (1)
  15. oflibMichal1 (1)
  16. ashaikh (1)
  17. dkutenic (1)


Generated by MeetBot 0.1.4.