17:00:10 <colindixon> #startmeeting
17:00:10 <odl_meetbot> Meeting started Thu Jan 16 17:00:10 2014 UTC.  The chair is colindixon. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:10 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:00:20 <colindixon> #topic overview and roll call
17:00:36 <tykeal> #info Andrew Grimberg for infrastructure support
17:00:54 <colindixon> #link https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1 is the document we're working from
17:00:55 <edwarnicke> #info Ed Warnicke for controller
17:01:03 <michal_rehak> #info michal_rehak for openflowplugin
17:01:04 <Madhu> #info Madhu for ovsdb
17:01:10 <abhijitkumbhare> #info Abhijit Kumbhare openflowplugin
17:01:10 <prasanna> #info Prasanna for openflowplugin\
17:01:12 <cdub> #info Chris Wright
17:01:32 <ashaikh> #info Anees / opendove
17:01:34 <dkutenic> #info Dana for bgpcep
17:01:44 <colindixon> today, we should do some following up with individual projects, I'm open to suggestions for how to best do that quickly
17:01:53 <oflibMichal1> #info oflibMichal for openflowjava
17:02:24 <colindixon> thoughts?
17:02:25 <edwarnicke> Quick walk through of their spreadsheets to see if they have folks assigned to tasks?
17:02:26 <rovarga> #info Robert for bgpcep
17:02:35 <cdub> colindixon: for quickly...perhaps asking to fill in ETA for per-project tasks
17:02:55 <Konstantin> #info Konstantin for defense4all
17:02:58 <cdub> and reviewing status for ETAs that are near (like day before?)
17:03:00 <colindixon> that's not a bad idea
17:03:06 <colindixon> where are those ETAs listed?
17:03:12 <cdub> it's DONE or ETA
17:03:14 <colindixon> or where should they be listed?
17:03:15 <cdub> for status
17:03:20 <colindixon> for each tab?
17:03:22 <colindixon> ok
17:03:24 <cdub> in per-project tab of workskeet
17:03:29 <colindixon> fair enough
17:03:29 <cdub> sheet even
17:03:46 <colindixon> #topic how to collect status from projects quickly
17:04:09 <colindixon> #info cdub suggests that we just have it filled in on the project-specific sheet of the progress tracking in the status column
17:04:29 <colindixon> #info we also have  ttkacik_ and janmedved in attendance
17:04:45 <RobDolin> Hey all, drafts for the user guide and developer guide templates were sent to discuss about 8 hours ago
17:04:59 <colindixon> #topic documentation
17:05:02 <colindixon> this is important
17:05:11 <colindixon> do you have the link? are the on the wiki?
17:05:16 * edwarnicke cheers RobDolin and team :)
17:05:37 <phrobb> #info Phil Robb here as well
17:06:08 <RobDolin> @ColinDixon - I plab to post on wiki after merging any feedback.
17:06:36 <colindixon> #link https://lists.opendaylight.org/pipermail/discuss/2014-January/001067.html is the e-mail RobDolin sent to the discuss list containing the first draft of the user manual and developer guide
17:06:55 <colindixon> do you have an ETA for that?
17:07:31 <RobDolin> Ah yes that link.  Thanks @ColinDixon
17:07:43 <colindixon> RobDolin: is there an ETA to post to the wiki?
17:08:07 <colindixon> or maybe we could just do that and allow others to put things in and/or you can do it later?
17:08:27 <edwarnicke> One other thing I noticed, we don't have the log levels linked in from the Hydrogen Release Work page... could we get that done (and pointers to other collateral)?
17:08:41 <RobDolin> @ColinDixon - ETA to wiki about 8-16 hours depending on volume of feedback / conflicting feedback.
17:08:56 <colindixon> sounds good
17:09:17 <colindixon> #action RobDolin to post the user manual and developer guide templates to the wiki in the next 24 hours
17:09:30 <colindixon> edwarnicke: I can do that
17:09:59 <colindixon> #action colindixon will link to the log level stuff and any others from the Hydrogen Release Work page
17:10:09 <colindixon> cool, great work RobDolin
17:10:13 <edwarnicke> RobDolin: Could you link those in here when you do: https://wiki.opendaylight.org/view/CrossProject:Hydrogen_Release_Work#Recommendations_and_Templates
17:10:30 <edwarnicke> colindixon: I already did: https://wiki.opendaylight.org/view/CrossProject:Hydrogen_Release_Work#Recommendations_and_Templates
17:10:42 <colindixon> cool
17:10:42 <edwarnicke> Realized I had the link and it might be easier to do it than to complain ;)
17:10:43 <colindixon> thanks
17:10:43 <RobDolin> @EdWarnicke - Sure
17:10:59 <colindixon> RobDolin: can you mark that progress on the spreadsheet?
17:11:08 <edwarnicke> RobDolin: Please feel free to split Recommendations and Templates into seperate sections if that makes sense to you
17:11:12 <colindixon> the fact that it should be posted by 1/17
17:11:24 <colindixon> #topic download page
17:11:29 <edwarnicke> Question: How do we want to handle our readout to the TSC?
17:11:34 <colindixon> I'm just going to paste what shague said earlier
17:11:50 <colindixon> shague: Hey guys, for the release status at 9:00aPST, I can't make it.
17:11:50 <colindixon> shague: I wanted to give status for item 30 in case it is covered today.
17:11:51 <colindixon> shague: General layout of download page is identified.
17:11:52 <colindixon> shague: Base edition artifacts have been identified and gathering information about the the other editions.
17:12:07 <edwarnicke> Awesome :)
17:12:18 <colindixon> #info shague said the general layout of the page has been worked out, the base edition artifacts have been worked out, and they're working on the other editions
17:12:28 <edwarnicke> Do we have a link to that so folks can review it?
17:12:40 <colindixon> #topic log level recommendations
17:12:56 <colindixon> #link https://wiki.opendaylight.org/view/Draft_Syslog_Level_Settings
17:13:28 <colindixon> #info ryan moats (regexboi) posted the revised version with the logback levels
17:13:41 <phrobb> edwarnicke:  No link yet.  The mock up was done on white board.  The LF web team is working on mock ups
17:14:00 <edwarnicke> Could we get a link to shague 's work on artifacts to be included?
17:14:12 <colindixon> I asked him for a link and he didn't respond
17:14:16 <colindixon> it would be nice if we could get one
17:14:34 <colindixon> #action phrobb or shague to provide a link for the progress on the download page and particular artifacts per edition
17:14:35 <edwarnicke> On the logging recommendations... could we change bundle to module?
17:14:50 <colindixon> I agree with that
17:14:53 <colindixon> any objections?
17:15:11 <rovarga> can we also add raw messages (for protocols) to trace?
17:15:17 <edwarnicke> (I can think of several examples of a bundle with multiple logical modules that 'start' and 'stop in it)
17:15:43 <edwarnicke> rovarga: You mean like messages received from the wire?
17:15:47 <colindixon> rovarga: can we just say "and others" or "etc."for trace?
17:15:54 <rovarga> edwarnicke: yes
17:16:17 <networkstatic> +1 rovarga netty log handler facility is nice.
17:16:29 <colindixon> any objections?
17:16:31 <edwarnicke> +1 adding messages to the trace category
17:16:45 <rovarga> colindixon: a few examples from different problem domains are helpful
17:17:03 <colindixon> #agreed change "bundle" to "module" in the log level recommendations
17:17:16 <edwarnicke> Any objection to me updating the log recommendation page to indicate the bit about messages and to change bundles to modules?
17:17:42 <colindixon> #agreed expand the scope of trace to include items such as logging messages received and others
17:17:50 <colindixon> sorry, I may have jumped the gun on those two
17:17:53 <colindixon> but I don't think so
17:18:25 <colindixon> ok
17:18:27 <Madhu> regarding INFO
17:18:31 <edwarnicke> #link https://wiki.opendaylight.org/view/Draft_Syslog_Level_Settings page updated, anyone see issues?
17:18:37 <Madhu> bundle start and stop INFO is a stretch
17:18:39 <Madhu> it is useful
17:18:50 <Madhu> but under a DEBUG
17:18:58 <edwarnicke> Madhu: The recommendations are not 'you must log this' but rather 'if you are logging this, use this level'
17:19:00 <Madhu> INFO is something that user really likes to know
17:19:08 <Madhu> I understand.
17:19:19 <Madhu> but it can quickly become a lot of INFO :)
17:19:56 <edwarnicke> Madhu: I would think that a functional module has finished starting or stopped is important user information (not always, but if you are going to log it, it's probably pretty important to the user)
17:19:57 <Madhu> anyways. thats a minor comment.
17:20:08 <rovarga> +1 for DEBUG, INFO should not be cluttered during normal operation
17:20:27 <colindixon> ok, can we hash this out on the mailing list?
17:20:32 <colindixon> if people care
17:20:40 <Madhu> sure.
17:21:00 <colindixon> #info Madhu and rovarga say that they think module start/stop should be DEBUG and not INFO, but this will be taken to the mailing list
17:21:02 <michal_rehak> but in case there is lot of INFO from particular bundle, we can limit that with log settings on that class
17:21:02 <colindixon> thanks
17:21:23 <colindixon> #topic system.out.println()
17:21:33 <colindixon> can we mark "Test to check for System.out.println" as DONE?
17:21:51 <colindixon> also can I get a report from the projects represented here about progress
17:22:14 <Madhu> there is 1 open question
17:22:22 <edwarnicke> Well... I've filed bugs...
17:22:29 <edwarnicke> And indicates the grep line to check
17:22:32 <edwarnicke> Does that count?
17:22:36 <Madhu> is system.out.println applicable for UT / IT code ?
17:22:54 <edwarnicke> Also, Gal Mainer from lispflowmapping correctly pointed out we should also look for System.err and printStackTrace
17:22:55 <Madhu> i would say... just leave UT / IT out of this
17:22:55 <colindixon> Madhu: I think the answer is that it's a project by project choice
17:23:08 <colindixon> does anyone disagree?
17:23:17 <Madhu> i agree on System.err and e.printstacktrace
17:23:30 <Madhu> and project by project by choice to UT/IT is a +1
17:23:37 <Konstantin> What about using System.out in the CLI part ?
17:23:55 <Madhu> Konstantin: good point. but it shud be ci.print
17:23:57 <Madhu> not system.out
17:23:59 <Madhu> :)
17:24:39 <edwarnicke> Madhu: I agree if you are talking the OSGI console, was that what you meant Konstantin ?
17:24:47 <Madhu> CommandInterpreter.println
17:24:51 <colindixon> #agreed individual projects can choose whether or not System.out.println is allowed in their Integration and unit tests, but in production running code it should not be used
17:25:12 <Konstantin> No, i'm speaking about CLI running in the command propmt.
17:25:14 <michal_rehak> sysout is enemy to cbench testing
17:25:30 <abhijitkumbhare> Openflowplugin - we have changed the System.out.println for the reason michal_rehak mentions
17:25:37 <Madhu> Konstantin: u mean the osgi> command prompt ?
17:25:39 <edwarnicke> Konstantin: meaning some other CLI that is not OSGI that you are providing?
17:26:05 <Konstantin> Yes, our cli speakong over REST with our server )))
17:26:13 <rovarga> edwarnicke: yes, bgpcep also has two standalone jars which are normal CLI java apps
17:26:21 <Konstantin> We ( defense4all ) are not bundle
17:26:41 <edwarnicke> Madhu, colindixon do you agree that a CLI that is *not* running within the controller process is something that should be at the discretion of the project on the System.out.println issue?
17:26:50 <colindixon> yeah I think I do
17:26:50 <rovarga> useful for manual validation, but not included in any of the distributions
17:26:51 <Madhu> yes.
17:26:56 <Konstantin> So, here we are ok with System.out ?
17:27:17 <edwarnicke> Konstantin: I know you guys are not a bundle running in the controller process, which is why I raised the issue the way I did :)
17:27:20 <Madhu> avoid system.out.println for debug logging anywhere :)
17:27:39 <colindixon> code that does not get run by run.sh can use system.out.println at the project's discretion
17:27:54 <colindixon> does that sound like the right wording?
17:28:34 <edwarnicke> colindixon: That sounds either right or very nearly right to me, thoughts from other folks?
17:28:48 <abhijitkumbhare> yes from me
17:28:51 <Madhu> run.sh might change ;)
17:28:57 <Madhu> so lets keep it abstract
17:28:58 <rovarga> works for us
17:29:03 <Madhu> and not specific to run.sh.
17:29:08 <colindixon> fair enough
17:29:27 <colindixon> code that does not get run by launching the controller in the normal fashion can use system.out.println at the project's discretion
17:29:34 <Konstantin> Yes, our start-up script is not "run.sh" )
17:29:58 <Madhu> ok . guess time to change the topic ?
17:30:34 <edwarnicke> I think first we need the #agreed
17:30:41 <colindixon> #agreed code that does not get run by launching the controller in the normal fashion can use system.out.println at the project's discretion, for example, to provide a CLI that runs outside the JVM
17:30:53 <colindixon> #topic per-project issues
17:31:06 <colindixon> I think I'm not going to spend another 30 minutes going through this here
17:31:21 <colindixon> instead I'm going to pound action everyone to fill out their spreadsheet
17:31:30 <cdub> yeah for delegation
17:31:40 <colindixon> and we can do some prep to follow up with people that haven't filled it out in subsequent meetings
17:31:45 <Madhu> request for project owners to get this completed : https://docs.google.com/spreadsheet/ccc?key=0Anypq0z_rOtOdE1YOUFSejQ0TGk0TkFhbVdEZ0d0VHc#gid=0
17:31:46 <edwarnicke> Could we get a quick rollcall of spreadsheet filled out here though
17:31:47 <colindixon> and I'll send an e-mail to that effect
17:31:55 <Madhu> the version convergence is critical for stable testing
17:32:01 <colindixon> sure I can do that
17:32:08 <edwarnicke> A simple #info for whether all items in a given section that should have started have a person on them from each project?
17:32:42 <colindixon> #info in the goal of saving time during these meetings, the bulk of the communication for completion of per-project tasks will take place offline via the sheets for individual projects
17:32:57 <colindixon> #link https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1 this spreadsheet has the sheets to fill in the info for
17:33:11 <edwarnicke> #info controller: All per project items in Global Code cleanup have a person signed up (thought its all edwarnicke right now, so the names may be updated)
17:33:19 <Madhu> edwarnicke: cleaned up the release recommendations page : https://wiki.opendaylight.org/view/Simultaneous_Release:Simultaneous_Release_Plan_2014:ReleaseRecommendations
17:33:28 <Madhu> please have a look / edit ?
17:34:00 <Konstantin> #info Defense4all Jenkins job is done. No changes suggested. 2 WARN will be fixed till next submit.
17:34:04 <colindixon> #action colindixon to send an e-mail to discuss calling on people to update their sheets
17:34:19 <Madhu> Konstantin: can u pls change the status ?
17:34:35 <colindixon> Madhu: did you want to call out anything specific w.r.t. versions?
17:34:50 <Madhu> yes. it is important that we have it done ASAP
17:34:55 <edwarnicke> Madhu: Linked in here: https://wiki.opendaylight.org/view/Simultaneous_Release:Simultaneous_Release_Plan_2014:ReleaseRecommendations
17:35:20 <Madhu> a lot is dependent on consistent versioning
17:35:29 <edwarnicke> Madhu: Which you had already done, removed my dupe ;)
17:35:38 <Madhu> edwarnicke: yes :)
17:35:40 <colindixon> #action everyone please deal with their version synchronization as specified in the following link
17:35:56 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Simultaneous_Release_Plan_2014:ReleaseRecommendations
17:36:09 <Madhu> #info versions status are tracked under : https://docs.google.com/spreadsheet/ccc?key=0Anypq0z_rOtOdE1YOUFSejQ0TGk0TkFhbVdEZ0d0VHc#gid=0 please edit it
17:36:17 <colindixon> thank you
17:36:56 <tykeal> folks please use #link instead of #info when adding a URL to the minutes
17:37:03 <Konstantin> Madhu: It's marked DONE, is not it ?
17:37:15 <tykeal> the two are virtually synonymous but #info doesn't hyperlink URLs
17:37:31 <Madhu> Konstantin: yes.
17:37:36 <Madhu> tykeal: ok
17:38:01 <colindixon> what was line 39 in the spreadsheet supposed to be
17:38:03 <colindixon> it's lost it's title
17:38:36 <edwarnicke> colindixon: "Write recommendation for cutting Release Branches and laying Release labels"
17:38:51 <colindixon> fixed
17:38:58 <colindixon> can we mark that as done?
17:39:02 <colindixon> I think we can, right?
17:39:18 <colindixon> if we can, I'm going to do a closing call for topics and then end the meeting
17:39:22 <Madhu> yes.
17:39:30 <Madhu> i will mark it done
17:39:36 <colindixon> thanks
17:39:40 <Madhu> editing this page gets challenging sometimes :)
17:39:43 <Madhu> its my FF maybe
17:39:49 <colindixon> #topic end of meeting
17:39:52 <colindixon> any final topics?
17:40:06 <edwarnicke> We need to decide what we are going to do to report out to the TSC
17:40:14 <colindixon> ah
17:40:20 <edwarnicke> Should be a short summary of state
17:40:42 <colindixon> #topic report to TSC
17:40:48 <colindixon> I think we can just keep it informal
17:40:55 <edwarnicke> I'd like to keep it high level
17:41:02 <edwarnicke> And that means probably a little thought
17:41:04 <colindixon> I think everything is actually on track except documentation
17:41:19 <colindixon> but I think that's caught up a lot in the last 24 hours
17:41:19 <edwarnicke> That's my sense as well
17:41:27 <Madhu> i would like to see an early code freeze and not on 01/27
17:41:28 <colindixon> Madhu: what's your thought and sense
17:41:37 <cdub> colindixon: that's a good executive summary ;)
17:41:47 <edwarnicke> So: Global Code Cleanup is on track to plan.  Documentation is about 3 days behind plan?
17:42:14 <Madhu> edwarnicke: cross project dependencies should be nailed ASAP
17:42:22 <Madhu> and shud not change often.
17:42:26 <colindixon> #info we'd like to keep the report high-level, most things seem on track, documentation seems to be a few days behind, but is showing progress now
17:42:37 <Madhu> to give some stable testing platform for atleast 2 weeks
17:42:40 <edwarnicke> Finalization Activities are still on track to plan
17:42:46 <edwarnicke> Release Reviews are still on track to plan
17:43:00 <colindixon> #info cross-project dependencies and versioning needs to be prioritized to be able to start testing ASAP
17:43:11 <Madhu> colindixon: thanks
17:43:22 <colindixon> #info Madhu would like to ask projects to try to get to code freeze before 1/27 if possible
17:43:29 <colindixon> I think that's a pretty good summary
17:43:50 <colindixon> I'm going to need to reach out to projects about release reviews and release notes
17:44:13 <colindixon> #action colindixon to follow up with projects about release reviews and release notes to make sure those things don't fall behind
17:44:14 <edwarnicke> Give me one second, putting up a tab on the spreadsheet for TSC report
17:44:26 <colindixon> edwarnicke: do we need that?
17:44:40 <colindixon> any other topics? people want to bring up while we're waiting?
17:45:12 <colindixon> edwarnicke: I was thinking we could just read out the notes for this last bullet
17:45:52 <edwarnicke> Are the branch recommendations done, they aren't marked on the Activites tab as such
17:46:03 <colindixon> they are done
17:46:13 <colindixon> Madhu was going to mark it as such
17:46:16 <Madhu> edwarnicke: am fixing it
17:46:52 <edwarnicke> Madhu, have you started looking at signing of artifacts (not beating you up about it, just lookign for status)
17:47:05 <Madhu> edwarnicke: no. starting today sir
17:47:30 <colindixon> ok
17:47:36 <colindixon> I'm going to call this meeting
17:47:38 <colindixon> going once
17:47:41 <edwarnicke> One moment
17:47:47 <colindixon> edwarnicke: ok
17:47:49 * cdub mutters madly at all the mailing lists
17:48:16 <networkstatic> lol
17:48:20 <colindixon> cdub: we really need to figure out if there's a saner way to divvy up the mailing lists
17:48:27 <cdub> colindixon: yes, yes there is
17:48:29 <edwarnicke> guys, how does this look for reporting to the tSC: https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=15
17:48:30 <networkstatic> consolidate...
17:48:31 <cdub> colindixon: it's call one list ;)
17:48:39 <tykeal> I'm all for consolidating them ;)
17:48:39 <networkstatic> +1
17:48:45 <colindixon> cdub: one list might kill inboxes though
17:48:48 <colindixon> but I guess that's fine
17:48:49 <cdub> colindixon: you can do topics if you don't know how to deal w/ a high (actaully low) volume list
17:49:07 <edwarnicke> cdub: Fast way to more traffic than anyone can follow... discuss is already there for common issues
17:49:15 <cdub> it's pretty easy to ignore stuff you don't care about
17:49:20 <edwarnicke> But most folks have no interest in the inside baseball of projects they aren't following
17:49:21 <cdub> and topics formalize that
17:49:39 <colindixon> edwarnicke: I might leave finalization activities as white
17:49:43 <colindixon> since it's really just getting up too
17:49:50 <edwarnicke> OK
17:50:05 <colindixon> #info tsc report is now a tab in the main sheet
17:50:09 <edwarnicke> #link https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=15 is showing the TSC summary
17:50:19 <colindixon> #topic mailing lists
17:50:34 <colindixon> #info some push to consolidate to fewer lists, but tabled to after hydrogen
17:50:37 <colindixon> #endmeeting