#opendaylight-meeting Meeting

Meeting started by colindixon at 01:45:44 UTC (full logs).

Meeting summary

  1. roll call and agenda (colindixon, 01:45:50)
    1. Ed Warnicke for controller (edwarnicke, 01:45:56)
    2. Hideyuki Tai for VTN Project (hideyuki, 01:46:20)
    3. dbainbri for docker and chicken (dbainbri1, 01:46:44)
    4. Madhu here. but not for long :( (Madhu_, 01:47:52)
    5. ChristineHsieh for SNMP4SDN (ChristineHsieh, 01:48:07)
    6. https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1 the big spreadsheet (colindixon, 01:49:30)
    7. suchiraman affinity (suchiraman, 01:49:56)
    8. Anees , opendove (ashaikh, 01:50:15)
    9. LuisGomez for Integration (LuisGomez, 01:50:20)
    10. https://wiki.opendaylight.org/view/CrossProject:Hydrogen_Release_Work this is the main wiki page we're working from for release stuff (colindixon, 01:50:33)
    11. https://wiki.opendaylight.org/images/5/55/Odl-release-sync-agenda-9a-01-20-2014.pdf this is the agenda we used yesterday and I'll update it with real information for the per-project issues at the bottom later (colindixon, 01:51:27)
    12. https://meetings.opendaylight.org/opendaylight-meeting/2014/opendaylight-meeting.2014-01-21-17.00.html meeting minutes from the earlier meeting today (colindixon, 01:52:09)
    13. https://meetings.opendaylight.org/opendaylight-meeting/2014/opendaylight-meeting.2014-01-21-01.49.html meeting minutes from yesterday, where I'm going to go over a few action items (colindixon, 01:52:27)

  2. non-java/non-OSGi bundles (colindixon, 01:55:19)
    1. ACTION: hideyuki to help ashaikh and regXboi figure out how to go about packaging, cutting and releasing non-java/non-OSGi artifacts (colindixon, 01:55:50)

  3. action items from yesterday (colindixon, 01:56:04)
    1. suchiraman has been working on dry runs for releases today (good!), but hasn't gotten to doing version skew jobs for affinity yet (colindixon, 01:56:40)
    2. hideyuki says that they should be able to have 3 people from VTN present for the 9a PST release cutting on 1/27 for up to 4 hours (colindixon, 02:00:22)
    3. The VTN project is testing with the new openflowplugin and says that they are running into issues, but they're looking into them. They will follow up with the openflowplugin team to help resolve them. (colindixon, 02:03:07)
    4. https://jenkins.opendaylight.org/affinity/job/affinity-bulk-release-dryrun/lastBuild/console (suchiraman, 02:05:29)
    5. LuisGomez "integration is currently testing controller NSF with -of13, some issues have already been reported to ofplugin project. We will be testing -of13 option till the end of the week, I will need to change the finish date for this task in the spread sheet" (colindixon, 02:08:01)

  4. downloadable release artifacts (colindixon, 02:08:58)
    1. VTN would like to add VTN artifacts to the vm images (vmdk) (colindixon, 02:10:21)
    2. ashaikh points out that it might make sense to do the same (provide VMs) for all the non-java artifacts, in particular for the virtualization edition which has more of those (colindixon, 02:12:13)
    3. hideyuki says that VTN would also be interested in docker, but that they aren't familiar with it (colindixon, 02:12:38)
    4. ACTION: hideyuki (and likely others) will reach out to shague__ about how to provide non-java artifacts as VMs to be downloaded on the download page (colindixon, 02:14:20)

  5. documentation: user guide, developer guide, release notes, etc. (colindixon, 02:17:58)
    1. https://wiki.opendaylight.org/view/CrossProject:Hydrogen_Release_Work from the release wiki page, there are links to drafts for the user guide, developer guide, release notes, and release review (colindixon, 02:18:33)
    2. https://wiki.opendaylight.org/view/HydrogenRelease:Documentation_Scope_and_Location I will link this page into that one, but I was trying to establish a scope and an a place for the documents to live here (colindixon, 02:19:07)
    3. Sarath and Venkat are working on documents for VTN Project. (hideyuki, 02:19:26)
    4. AGREED: we will have one, global developer guide which can contain information about editions and projects, but, as developers will care less about editions, it will be for all of the hydrogen release (colindixon, 02:24:13)
    5. AGREED: we will not have per-project release notes, but this information will be incorporated into per-edition release notes and tagged as project specific if need be (this will be particularly necessary in the virtualization edition) (colindixon, 02:26:55)
    6. networkstatic would like to know if we have standard iconography for the documentation (colindixon, 02:28:44)
    7. ACTION: colindixon will create the actual template pages for each edition and/or global document for user/developer guides and release notes (colindixon, 02:29:30)
    8. ashaikh suggests using subpages for the documentation like release/hydrogen/base/User_Manual (colindixon, 02:32:05)
    9. it seems like the release review documents should live in their projects namespaces to keep them with the other project lifecycle documents, however since these will be recurring, using subpages seems to make sense so pages something like <LongProjectName>:Release_Review/<ReleaseName> (colindixon, 02:34:27)
    10. http://docs.openstack.org is a good reference to look at as we start documenting like crazy (colindixon, 02:35:28)
    11. networkstatic for ovsdb (networkstatic, 02:37:37)


Meeting ended at 02:38:05 UTC (full logs).

Action items

  1. hideyuki to help ashaikh and regXboi figure out how to go about packaging, cutting and releasing non-java/non-OSGi artifacts
  2. hideyuki (and likely others) will reach out to shague__ about how to provide non-java artifacts as VMs to be downloaded on the download page
  3. colindixon will create the actual template pages for each edition and/or global document for user/developer guides and release notes


Action items, by person

  1. ashaikh
    1. hideyuki to help ashaikh and regXboi figure out how to go about packaging, cutting and releasing non-java/non-OSGi artifacts
  2. colindixon
    1. colindixon will create the actual template pages for each edition and/or global document for user/developer guides and release notes
  3. hideyuki
    1. hideyuki to help ashaikh and regXboi figure out how to go about packaging, cutting and releasing non-java/non-OSGi artifacts
    2. hideyuki (and likely others) will reach out to shague__ about how to provide non-java artifacts as VMs to be downloaded on the download page


People present (lines said)

  1. colindixon (142)
  2. edwarnicke (48)
  3. hideyuki (24)
  4. ashaikh (17)
  5. networkstatic (13)
  6. suchiraman (13)
  7. ChristineHsieh (7)
  8. Madhu_ (5)
  9. dbainbri1 (4)
  10. LuisGomez (4)
  11. odl_meetbot (2)


Generated by MeetBot 0.1.4.