#opendaylight-meeting Meeting

Meeting started by colindixon at 17:04:00 UTC (full logs).

Meeting summary

  1. agenda and roll call (colindixon, 17:04:07)
    1. oflibMichal for openflowjava (oflibMichal, 17:04:39)
    2. Andrew Grimberg for infrastructure support (tykeal, 17:04:39)
    3. Ed Warnicke for controller (edwarnicke, 17:04:42)
    4. michal_rehak / openflowplugin (michal_rehak, 17:04:43)
    5. goldavberg for lispflowmapping (goldavberg, 17:04:43)
    6. Robert Varga for yangtools/bgpcep (rovarga, 17:04:55)
    7. dbainbri (the chicken) (dbainbri, 17:05:03)
    8. Luis for Integration (LuisGomez, 17:05:12)
    9. Dana for bgpcep (dkutenic, 17:05:28)
    10. Phil Robb here for download page etc (phrobb, 17:05:29)
    11. Konsta for defense4all (Konstantin, 17:05:41)
    12. Chris Wright for rabble rousing (cdub, 17:05:42)
    13. Prasanna for OFplugin (prasanna, 17:05:43)
    14. Abhijit Kumbhare Openflowplugin (abhijitkumbhare, 17:06:11)
    15. Madhu for ovsdb (Madhu, 17:06:20)
    16. https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1 the big spreadsheet where' we're tracking these things (colindixon, 17:08:03)
    17. https://wiki.opendaylight.org/view/CrossProject:Hydrogen_Release_Work this is the wiki for tracking things related to release (colindixon, 17:08:49)
    18. https://meetings.opendaylight.org/opendaylight-meeting/2014/opendaylight-meeting.2014-01-21-17.00.html the meinutes from yesterday's meeting (colindixon, 17:09:10)

  2. action items from last time (colindixon, 17:09:23)
    1. abhijitkumbhare and michal_rehak will get the dry run up and working for openflow{java|plugin} this week (colindixon, 17:11:06)
    2. oflibMichal is actually the person responsible for this with openflowjava, he will do it tomorrow (colindixon, 17:12:29)

  3. documentation (user guides, release notes, dev guides, release review) (colindixon, 17:13:49)
    1. https://meetings.opendaylight.org/opendaylight-meeting/2014/opendaylight-meeting.2014-01-22-01.45.html this was discussed in the 5:45p PST meeting yesterday (link to minutes) (colindixon, 17:14:12)
    2. https://wiki.opendaylight.org/view/HydrogenRelease:Documentation_Scope_and_Location this was the document I put together with the scope and proposed location for each document (colindixon, 17:14:34)
    3. cdub points out that (at least some) projects will obviously have their own sections of developer guides (colindixon, 17:17:23)
    4. phrobb asks if it will be wiki, pdf or html. I think the plan is wiki out of ease with links to auto generated html docs where that makes sense, e.g., for REST APIs (colindixon, 17:17:59)
    5. cdub says he finds editions a bit odd, probably a good topic for the discuss mailing list post-hydrogen (colindixon, 17:20:43)

  4. other things from the 5:45p PST meeting (colindixon, 17:21:02)
    1. trying to get everyone working with non-java and/or non-OSGi artifacts together (colindixon, 17:22:38)
    2. I know that VTN and OpenDOVE are dealing with this (colindixon, 17:22:49)
    3. https://lists.opendaylight.org/pipermail/discuss/2014-January/001118.html that's the mail from goldavberg about this (colindixon, 17:23:26)
    4. goldavberg wants to get this working for cassandra astryanax but not for hydrogen (colindixon, 17:23:58)
    5. related to that there was also discussion of adding VMs (vmdk and/or docker) for non-OSGI and/or non-java parts (colindixon, 17:24:38)
    6. https://nexus.opendaylight.org/content/repositories/opendaylight.snapshot/org/opendaylight/controller/config-util/0.2.3-SNAPSHOT/ shows sources (edwarnicke, 17:26:56)
    7. ACTION: ashaikh to follow up with shague__ on how get the VMs up on the download page and who will actually roll the VMs. Also this will presumably pull in tykeal, LuisGomez and maybe hideyuki (these are VMs for non-Java and/or non-OSGi pieces) (colindixon, 17:27:50)

  5. people who are/are not pushing sources to nexus (colindixon, 17:29:46)
    1. projects should push source archives to nexus, we'll aggregate which projects are and aren't doing that at the end of this meeting (colindixon, 17:31:14)

  6. upcoming release task deadlines (colindixon, 17:31:32)
    1. https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1 the big spreadsheet again, I'm just going to read off things with 1/24 as the date in the "last finish date" column on the "activities" tab (colindixon, 17:31:55)
    2. we need to erradicate and have tests to check for all System.out.print(), System.out.println(), System.err.print(), and System.err.println() (colindixon, 17:33:17)
    3. related to that, we need to sanity check log levels (colindixon, 17:33:40)
    4. I believe controller has done this and merged it (edwarnicke, 17:33:42)
    5. https://wiki.opendaylight.org/view/Draft_Syslog_Level_Settings log level guidelines are here (colindixon, 17:33:59)
    6. to be more specific, I believe controller has eliminated all System.out.println outside of tests and OSGI CLI commands and merged it (edwarnicke, 17:34:06)
    7. controller has a patch pending to remove all e.printStackTraces that are not in tests or OSGI CLI commands (edwarnicke, 17:34:35)
    8. we need to update *all* internal dependencies to the current highest snapshot version (colindixon, 17:35:27)
    9. defense4all has done with Sytem.out (Konstantin, 17:35:29)
    10. ovsdb is done with system.out.println and e.printstacktrace (Madhu, 17:36:15)
    11. lispflowmapping is also done with it (goldavberg, 17:36:34)
    12. openflowjava is done with system.outs (oflibMichal, 17:37:14)
    13. bgpcep done with print (dkutenic, 17:37:30)
    14. all projects need to remove SNAPSHOT from any external dependencies (colindixon, 17:37:56)
    15. openflowplugin done with system.outs & some other items - the other items status is on the spreadsheet (abhijitkumbhare, 17:38:09)
    16. I know we have tests for copyrights, but all projects need to get that resolved by the end of the wek (colindixon, 17:38:29)
    17. lists of files with no copyright went to all projects last week. I ran a new scan yesterday and will send updated lists to all projects today. OVSDB and OpenDOVE are doneā€¦ many other projects have not seemed to have started yet. (phrobb, 17:40:13)
    18. related to external SNAPSHOT versions Madhu points out that jackson introduces some surprises here and wants to give others a heads up (colindixon, 17:40:28)
    19. Madhu says that we have communicated to everyone that versions shouldn't be increased anymore and we have good tests for that in integration tests for dependency convergence (colindixon, 17:42:17)
    20. ACTION: cdub to coordinate with edwarnicke or delegate to somebody else the task of figuring out how to test for pom.xmls pointing the the nexus group and communicating this to project leads (colindixon, 17:45:18)
    21. it sounds like LuisGomez is on track with developing tests for -of13 by the end of the week (colindixon, 17:45:50)
    22. it sounds like testing with -of13 is furthest head with OVSDB, but there are still issues being ironed out (colindixon, 17:49:32)
    23. LuisGomez for default OF, VTN manager has IT test set up, OVSDB is part set up with IT, and Affiinity isn't started yet (colindixon, 17:50:03)
    24. LuisGomez will have more idea about how worried we should be about these integration tests after the integration meeting today (colindixon, 17:51:23)

  7. cutting artifacts on 1/27 schedule and attendance (colindixon, 17:51:38)
    1. in an amazing show of commitment both VTN and SNMP4SDN will attend at 9a PST on 1/27 to be on hand for this task despite it begin 2a-6a and 1a-5a for them (colindixon, 17:52:27)
    2. ACTION: phrobb will create a wiki page and/or spreadsheet tracking this and hang it off the wiki page for cross project release info (colindixon, 17:53:36)
    3. abhijitkumbhare asks why we couldn't move it to 7a PST to make things better overall (colindixon, 17:54:38)
    4. Madhu says that 7a-8:30a is the worst possible time for him (colindixon, 17:56:07)
    5. AGREED: it seems as though we have critical mass for moving from 9a PST to 7a PST for cutting as a one-off shift on 1/27, but we will check at 5:45 and phrobb will follow up with people as part of his getting attendance promises from people (colindixon, 17:57:44)

  8. log levels (specifically for device connection and disconnection) (colindixon, 17:59:44)
    1. edwarnicke would like to suggest we make connection and disconnection of devices from the controller an info level loggable event (colindixon, 18:00:07)
    2. https://wiki.opendaylight.org/view/Draft_Syslog_Level_Settings (edwarnicke, 18:01:23)
    3. let's take this issue offline. I don't think this is going to make or break the release. my strong suspicion is that we will allow projects to decide to put this at log level of info if they choose. (colindixon, 18:04:02)


Meeting ended at 18:04:06 UTC (full logs).

Action items

  1. ashaikh to follow up with shague__ on how get the VMs up on the download page and who will actually roll the VMs. Also this will presumably pull in tykeal, LuisGomez and maybe hideyuki (these are VMs for non-Java and/or non-OSGi pieces)
  2. cdub to coordinate with edwarnicke or delegate to somebody else the task of figuring out how to test for pom.xmls pointing the the nexus group and communicating this to project leads
  3. phrobb will create a wiki page and/or spreadsheet tracking this and hang it off the wiki page for cross project release info


Action items, by person

  1. ashaikh
    1. ashaikh to follow up with shague__ on how get the VMs up on the download page and who will actually roll the VMs. Also this will presumably pull in tykeal, LuisGomez and maybe hideyuki (these are VMs for non-Java and/or non-OSGi pieces)
  2. cdub
    1. cdub to coordinate with edwarnicke or delegate to somebody else the task of figuring out how to test for pom.xmls pointing the the nexus group and communicating this to project leads
  3. edwarnicke
    1. cdub to coordinate with edwarnicke or delegate to somebody else the task of figuring out how to test for pom.xmls pointing the the nexus group and communicating this to project leads
  4. LuisGomez
    1. ashaikh to follow up with shague__ on how get the VMs up on the download page and who will actually roll the VMs. Also this will presumably pull in tykeal, LuisGomez and maybe hideyuki (these are VMs for non-Java and/or non-OSGi pieces)
  5. phrobb
    1. phrobb will create a wiki page and/or spreadsheet tracking this and hang it off the wiki page for cross project release info
  6. shague__
    1. ashaikh to follow up with shague__ on how get the VMs up on the download page and who will actually roll the VMs. Also this will presumably pull in tykeal, LuisGomez and maybe hideyuki (these are VMs for non-Java and/or non-OSGi pieces)
  7. tykeal
    1. ashaikh to follow up with shague__ on how get the VMs up on the download page and who will actually roll the VMs. Also this will presumably pull in tykeal, LuisGomez and maybe hideyuki (these are VMs for non-Java and/or non-OSGi pieces)


People present (lines said)

  1. colindixon (124)
  2. edwarnicke (67)
  3. Madhu (52)
  4. cdub (33)
  5. phrobb (15)
  6. tykeal (10)
  7. abhijitkumbhare (10)
  8. goldavberg (10)
  9. LuisGomez (7)
  10. michal_rehak (4)
  11. rovarga (4)
  12. oflibMichal (4)
  13. networkstatic (3)
  14. Konstantin (3)
  15. shague__ (2)
  16. odl_meetbot (2)
  17. ashaikh (2)
  18. dkutenic (2)
  19. prasanna (1)
  20. dbainbri (1)


Generated by MeetBot 0.1.4.