#opendaylight-meeting Meeting

Meeting started by colindixon at 17:00:21 UTC (full logs).

Meeting summary

  1. roll call and agenda (colindixon, 17:00:39)
    1. Andrew Grimberg for infrastructure support (tykeal, 17:00:41)
    2. Dana for bgpcep (dkutenic, 17:00:55)
    3. Ed Warnicke for controller (edwarnicke, 17:01:13)
    4. Vina for lispflowmapping (ermagan, 17:01:34)
    5. Abhijit Kumbhare openflowplugin (abhijitkumbhare, 17:01:38)
    6. Robert for yangtools (nite, 17:01:42)
    7. Chris Wright for posterity (cdub, 17:01:50)
    8. goldavberg for lispflowmapping (goldavberg, 17:01:54)
    9. Madhu here (Madhu, 17:01:54)
    10. Neela Jacques for moral support (Neelajacques, 17:02:43)
    11. so, my plan for today's agenda is really (1) to highlight what we *need* to get done by Friday and monday (which is pretty much everything) :p and (2) handle issues/questions people are having (colindixon, 17:02:47)
    12. oflibMichal for the openflowjava (oflibMichal, 17:03:18)
    13. https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1 the big spreadsheet of tracking all things release (colindixon, 17:03:55)
    14. https://wiki.opendaylight.org/view/CrossProject:Hydrogen_Release_Work the cross project work tracking wiki page (colindixon, 17:04:11)
    15. https://meetings.opendaylight.org/opendaylight-meeting/2014/opendaylight-meeting.2014-01-23-01.45.html meeting minutes from the 5:45 call (colindixon, 17:04:45)
    16. Konsta for defense4all (Konstantin, 17:05:33)
    17. michal_rehak / openflowplugin (michal_rehak, 17:05:35)

  2. dry runs for cutting artifacts in anticipation of monday's artifact cutting (colindixon, 17:05:52)
    1. the high order bit is that in the 5:45p PST sync yesterday, hideyuki of VTN came up with a way to get our dry run jenkins jobs to actually succeed despite running off of SNAPSHOT versions (colindixon, 17:06:40)
    2. https://jenkins.opendaylight.org/vtn/job/vtn-bulk-release-prepare-only/configure has an example of using IGNORE_SNAPSHOTS to allow the dry run to succeed. This is very useful for dryrun, but should not be done for release. (edwarnicke, 17:06:45)
    3. Many thanks to hideyuki for figuring this out and sharing it :) (edwarnicke, 17:07:08)
    4. https://jenkins.opendaylight.org/lispflowmapping/job/controller-bulk-release-prepare-only/13/ (goldavberg, 17:08:35)
    5. people should please try this and then get help on the main IRC channel (colindixon, 17:08:39)

  3. release artifact cutting on 1/27 (colindixon, 17:08:59)
    1. from 5:45pm: AGREED: Concur: AGREED: it seems as though we have critical mass for moving from 9a PST to 7a PST for cutting as a one-off shift on 1/27, but we will check at 5:45 and phrobb will follow up with people as part of his getting attendance promises from people (edwarnicke, 17:11:03)
    2. ACTION: phrobb thinks he has everyone for the 7a PST 1/27 meeting and will put a spreadsheet up hopefully before this meeting is over with: Contact Name, Project represented, and "dry run success" (colindixon, 17:12:04)

  4. per-project code cleanup tasks before friday (colindixon, 17:12:38)
    1. I have reps from all of these projects on, so I'll want an ACK (but not necessarily a readout) from all of you: openflowplugin, defnese4all, openflowjava, ovsdb, lispflowmapping, yangtools, controller, bpgpcep (colindixon, 17:13:37)
    2. basically, I just want to know that each project is aware of what they have to do and I'll harass people latter for not having updated the spreadsheet (colindixon, 17:14:30)
    3. got ACKs for all projects in attendance: openflowplugin, defnese4all, openflowjava, ovsdb, lispflowmapping, yangtools, controller, bpgpcep (colindixon, 17:18:21)

  5. enforcer not catching all version sync issues (colindixon, 17:18:41)
    1. project-info-reports:dependency-convergence (cdub, 17:19:22)
    2. mvn project-info-reports:dependency-convergence (cdub, 17:19:35)
    3. mvn validate (enforcer) (cdub, 17:19:45)
    4. mvn versions:compare-dependencies -DremotePom=org.opendaylight.controller:distribution.opendaylight:0.1.1-SNAPSHOT (cdub, 17:20:03)
    5. the latter is showing some skew that the former 2 aren't catching (cdub, 17:20:20)
    6. mainly it's been yangtools bump to 0.6.0 that's not getting caught (cdub, 17:20:45)
    7. mvn versions:compare-dependencies -DremotePom=org.opendaylight.controller:distribution.opendaylight:0.1.1-SNAPSHOTmvn versions:compare-dependencies -DremotePom=org.opendaylight.controller:distribution.opendaylight:0.1.1-SNAPSHOT -DreportOutputFile=${project.build.directory}/depDiffs.txt (cdub, 17:23:54)
    8. find -name defDiffs.txt | xargs ... (cdub, 17:24:24)

  6. documentation (colindixon, 17:25:02)
    1. https://wiki.opendaylight.org/view/Release/Hydrogen/ I posted a rood documentation page for the hydrogen release here (colindixon, 17:25:48)
    2. HELP: we *really* need people to jump in there and start to get these things up so that we have *some* documentation come release (colindixon, 17:26:21)
    3. ACTION: colindixon to look into creating some transcluded pages for truly common things (colindixon, 17:31:21)

  7. integration testing for non-base editions and for -of13 (colindixon, 17:31:59)
    1. ACTION: LuisGomez to send a mail to discuss with the state of integration tests later today (colindixon, 17:35:09)

  8. release reviews (colindixon, 17:37:48)
    1. https://wiki.opendaylight.org/view/Sample_Release_Review sample release review document which each project can copy and use (colindixon, 17:38:18)
    2. ACTION: dmm should set these reviews up, colindixon will reach out to him about this on the TSC call (colindixon, 17:38:33)

  9. call for other topics from the group (colindixon, 17:39:01)
    1. ACTION: Madhu and Gera_ and edwarnicke to look into why defense4all is having issue with virt and sp editions (colindixon, 17:39:41)

  10. TSC readout (colindixon, 17:40:15)
    1. https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=15 TSC Report Spreadsheet (edwarnicke, 17:40:49)
    2. there a variety of code cleanup tasks that each project has to do, I think we're yellow there with some projects being closer to red (colindixon, 17:42:49)
    3. Spreadsheet for the Hydrogen Artifact Creation Event on January 27th is posted in the 'Addendum' section of the Simultaneous Release page - Leads please fill in the "Dry-Run Status" (phrobb, 17:51:12)
    4. the TSC report is on the link above, the big issues we're worried about are: (1) documentation, (2) some testing and fixing failures for non-base editions and OF13, (3) getting canary tests up per-platform (colindixon, 17:52:40)
    5. https://docs.google.com/spreadsheet/ccc?key=0AveQs8CH9DEUdFg5MVBXb0k1amFJX1BRcFdmc1VKekE&usp=sharing#gid=0 the spreadsheet in question from phrobb (colindixon, 17:53:38)


Meeting ended at 17:53:45 UTC (full logs).

Action items

  1. phrobb thinks he has everyone for the 7a PST 1/27 meeting and will put a spreadsheet up hopefully before this meeting is over with: Contact Name, Project represented, and "dry run success"
  2. colindixon to look into creating some transcluded pages for truly common things
  3. LuisGomez to send a mail to discuss with the state of integration tests later today
  4. dmm should set these reviews up, colindixon will reach out to him about this on the TSC call
  5. Madhu and Gera_ and edwarnicke to look into why defense4all is having issue with virt and sp editions


Action items, by person

  1. colindixon
    1. colindixon to look into creating some transcluded pages for truly common things
    2. dmm should set these reviews up, colindixon will reach out to him about this on the TSC call
  2. edwarnicke
    1. Madhu and Gera_ and edwarnicke to look into why defense4all is having issue with virt and sp editions
  3. Gera_
    1. Madhu and Gera_ and edwarnicke to look into why defense4all is having issue with virt and sp editions
  4. LuisGomez
    1. LuisGomez to send a mail to discuss with the state of integration tests later today
  5. Madhu
    1. Madhu and Gera_ and edwarnicke to look into why defense4all is having issue with virt and sp editions
  6. phrobb
    1. phrobb thinks he has everyone for the 7a PST 1/27 meeting and will put a spreadsheet up hopefully before this meeting is over with: Contact Name, Project represented, and "dry run success"


People present (lines said)

  1. colindixon (135)
  2. edwarnicke (62)
  3. cdub (27)
  4. Madhu (18)
  5. Gera_ (8)
  6. goldavberg (8)
  7. tykeal (5)
  8. nite (5)
  9. abhijitkumbhare (4)
  10. dkutenic (4)
  11. rovarga (4)
  12. phrobb (3)
  13. LuisGomez (3)
  14. Konstantin (2)
  15. oflibMichal (2)
  16. odl_meetbot (2)
  17. michal_rehak (1)
  18. ermagan (1)
  19. ashaikh (1)
  20. Neelajacques (1)


Generated by MeetBot 0.1.4.