01:45:30 <cdub> #startmeeting
01:45:30 <odl_meetbot> Meeting started Fri Jan 24 01:45:30 2014 UTC.  The chair is cdub. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:45:30 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
01:45:52 <cdub> #topic roll call and agenda
01:46:17 <cdub> hey all, let's get started, please #info announce yourself
01:46:42 <cdub> #info Chris Wright for cat herding
01:46:43 <hideyuki> #info Hideyuki Tai for VTN Project
01:47:29 <cdub> hideyuki: this might be a quick one if it's just you and I ;)
01:47:52 <hideyuki> cdub: :)
01:48:20 <cdub> hideyuki: while waiting for any others to join, is there anything specific you'd like to have on today's agenda?
01:49:03 <hideyuki> no item from me. thank you.
01:49:48 <cdub> ok
01:50:28 <cdub> #topic dry runs
01:51:05 <cdub> hideyuki: thanks for the IGNORE_SNAPSHOTS tip, it's been passed along this morning (UTC-8) and is proving useful
01:51:22 <hideyuki> cdub: thank you.
01:51:45 <cdub> also, there's consensus to start the artifact cutting at 7am PST Jan 27 (as proposed already)
01:52:03 <hideyuki> Ok. we are fine with this.
01:52:16 <cdub> to help accommodate asia tz's
01:52:25 <hideyuki> thank you.
01:52:47 <cdub> anything to update with your dry runs, i think VTN is really leading the way here
01:53:07 <hideyuki> no update on dry runs.
01:53:23 <cdub> ok
01:53:31 <hideyuki> I mean that dry run for VTN Project was successfully done.
01:53:50 <cdub> #info VTN is status quo for dry runs and ready to go on 1/27
01:54:13 <cdub> #topic per-project cleanups
01:54:41 <cdub> i think VTN is up to date here as well
01:54:53 <hideyuki> i think so.
01:55:07 <cdub> how about freezing SNAPSHOT versions of your components?
01:55:51 <hideyuki> we freezed all SNAPSHOT versions in VTN Project.
01:56:00 <hideyuki> does this answer your question?
01:56:12 <cdub> #info VTN has frozen all SNAPSHOT versions in VTN project
01:56:17 <cdub> hideyuki: yes, it does, thaks
01:56:40 <cdub> one thing that came up earlier today
01:56:47 <hideyuki> cdub: thank you. we have no plan to count up SNAPSHOT versions of VTN component anymore until hydrogen release.
01:57:00 <cdub> perfect
01:57:18 <cdub> paiwei, banix hi
01:57:28 <cdub> we are discussing the per-project cleanup tasks
01:57:29 <networkstatic> #info networkstatic for ovsdb
01:57:52 <cdub> hey networkstatic
01:57:55 <networkstatic> hi sir
01:57:56 <cdub> one thing that came up this am
01:58:05 <cdub> (earlier today, that is)
01:58:20 <cdub> the enforcer doesn't generate the same dependency skew as other tools
01:58:44 <cdub> so, i have been running 2 other tools to cross check
02:00:22 <hideyuki> cdub: would you explain the tools for me?
02:01:02 <hideyuki> Should we use the tools for VTN Project?
02:01:49 <cdub> #info mvn versions:compare-dependencies -DremotePom=org.opendaylight.controller:distribution.opendaylight:0.1.1-SNAPSHOT -DreportOutputFile='${project.build.directory}'/dep-distro.txt (include some scripting to pull the details)
02:01:49 <cdub> #info for example, find -name null | xargs grep -h '^  [a-z]'
02:02:12 <cdub> i've found that yangtools deps weren't being caught by enforcer for some projects
02:02:15 <cdub> i'd recommend a manual run of the above
02:02:43 <hideyuki> Ok. I'll execute the above command in my local machine later.
02:03:05 <cdub> #info mvn project-info-reports:dependency-convergence    is another useful tool is
02:03:43 <cdub> hideyuki: ok, thanks
02:04:36 <cdub> hideyuki: i'll be around if you need any help
02:04:36 <cdub> #topic documentation
02:05:52 <cdub> from this morning, the biggest outcome is...we need more help
02:06:30 <cdub> #info this is noted as "red" in the TSC report this morning, meaning it's not looking on target
02:07:01 <hideyuki> cdub: ok.
02:07:13 <hideyuki> VTN Project is working on documentation work.
02:07:50 <cdub> hideyuki: thanks, your team is really on top of all of these items
02:07:59 <cdub> hideyuki: you mind a #info for that last statement?
02:08:14 <hideyuki> #info VTN Project is working on documentation work.
02:08:18 <hideyuki> cdub: thank you!
02:09:00 <cdub> #topic integration testing
02:09:39 <cdub> we didnt' get a lot of details from the integration team, but LuisGomez is going to send out a status update
02:10:21 <cdub> any update here from VTN?
02:10:40 <hideyuki> cdub: Ok. I'm waiting the status report from LuizGomez.
02:10:55 <cdub> and also, while talking about integration project...package building for the non Java bits?
02:11:25 <hideyuki> #info VTN Project has started to test VTN with the new OF plugin. however we found out problems on the new OF plugin.
02:11:48 <hideyuki> #info we will report the problem later.
02:11:52 <cdub> hideyuki: can you give us more details?
02:11:59 <cdub> heh, oh, ok...that works
02:12:22 <cdub> networkstatic and OVSDB have been doing integration testing w/ new OF plugin and hit a few issues as well
02:12:36 <cdub> so it's worth getting these out so we can compare issues
02:12:37 <networkstatic> yessir, we can trade any notes,
02:12:50 <hideyuki> #info I found out that simple forwarding in the base edition does not work with the new OF plugin when it connects with OF 1.0 minineet.
02:13:15 <cdub> interesting (and different issue from OVSDB project)
02:13:37 <cdub> hideyuki: does it work when connecting with mininet w/ 1.3 support?
02:13:50 <networkstatic> we have been turning down at init hideyuki
02:14:21 <cdub> oh, nm...base edition...that's a tested setup w/ 1.3 (on both sides)
02:14:37 <hideyuki> #info VTN does not work with the new OF 1.3 when it connecting with Mininet OF1.3, too.
02:14:58 <cdub> hideyuki: ok, i'll leave you with the action to report that and the details to the list
02:14:59 <hideyuki> cdub: Yesterday, I used the latest version of the base edition.
02:15:22 <cdub> hideyuki: i'd suggest discuss as well and openflowplugin list, to get the most eyes on it
02:15:42 <hideyuki> cdub: I wrote the problem of simple forwarding here: https://bugs.opendaylight.org/show_bug.cgi?id=306
02:15:53 <cdub> #action hideyuki will report the details of of1.3 issues to the list
02:15:58 <hideyuki> https://bugs.opendaylight.org/show_bug.cgi?id=306#c9
02:16:33 <cdub> #link https://bugs.opendaylight.org/show_bug.cgi?id=306 simpleforwarding new OF plugin to 1.0 mininet
02:16:38 <hideyuki> cdub: it is very hard to me analyze the problem of of1.3 because the new OF plugin output so so so many INFO level logs.
02:16:47 <networkstatic> yes sir
02:17:07 <networkstatic> https://gist.github.com/0205104d2f7ebfe0651f
02:17:13 <networkstatic> that will tone them down hideyuki
02:17:17 <cdub> hideyuki: yes, that's like a needle in a haystack
02:17:30 <networkstatic> edwarnicke has a patch to pull those back
02:17:36 <hideyuki> networkstatic: :)
02:17:40 <hideyuki> Ok.
02:17:55 <networkstatic> sorry its lame but saves some buffer :)
02:17:58 <cdub> #link https://gist.github.com/0205104d2f7ebfe0651f to tone down the openflowplugin logging
02:18:06 <cdub> networkstatic: useful, nonetheless
02:18:41 <hideyuki> however, if we turn off log level, how we can debug the problem?
02:19:14 <cdub> hideyuki: ok, thanks, we need to add this testing combination to the standard test runs
02:19:29 <networkstatic> yeah, sorry, bit more selectively, best luck i had was watching for the needles and greping out of the logs/ dir
02:19:44 <hideyuki> ok.
02:19:45 <cdub> #action cdub will bring this standard test issue to integration team
02:20:33 <networkstatic> its tough, wireshark flowmods are easier
02:20:52 <networkstatic> Dissector here as an FYI
02:20:53 <networkstatic> https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:OF1.3_Enabled_Wireshark
02:21:02 <cdub> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:OF1.3_Enabled_Wireshark
02:21:18 <cdub> let's hit the last couple things and then we can double back to debugging if it's useful ;)
02:21:26 <cdub> (since there's not much more to cover here)
02:21:45 <cdub> #topic release reviews
02:22:12 <cdub> this was covered in today's TSC call, dmm to manage the details of setting them up
02:22:50 <cdub> #link https://wiki.opendaylight.org/view/Sample_Release_Review this is the current review proposal
02:23:47 <cdub> #topic any other business
02:23:58 <cdub> anything else to cover?
02:24:08 <cdub> #info we did the TSC readout this morning
02:24:18 <cdub> it's in the spreadsheet
02:24:40 <hideyuki> no topic from me.
02:24:46 <cdub> #link https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=15 TSC report (less green than we'd like!)
02:25:04 <cdub> hideyuki: ok
02:25:30 <cdub> hideyuki: we will need to track the of13 vtn issue
02:25:37 <cdub> hideyuki: as it will impact the docs
02:25:39 <networkstatic> cdub one thing for over the weekend is if there are folks from projects w/ dependencies for those of us sprinting to the finish line
02:25:41 <cdub> hideyuki: and the wrapper scripts
02:26:03 <networkstatic> of13 reps
02:26:05 <hideyuki> wrapper scripts?
02:26:28 <cdub> hideyuki: sorry, the integration tree has wrapper scripts around run.sh
02:26:43 <hideyuki> cdub: ok.
02:26:55 <cdub> hideyuki: so it looks like run.virt.sh -> run.base.sh -> run.sh
02:27:05 <cdub> and some filtering to ensure a working combo
02:27:07 <hideyuki> hideyuki: I see. thank you.
02:27:35 <cdub> e.g. run.virt.sh -virt vtn (where we might want to enforce !-of13, for example)
02:28:13 <cdub> networkstatic: didn't fully parse that, you suggesting that we wrangle some of13 folks to be on standby over the weekend?
02:28:22 <networkstatic> sorry, didnt want to interupt
02:28:31 <networkstatic> we will likely need eyes of 13
02:28:33 <cdub> no worries, it's the free-for-all time ;)
02:28:42 <networkstatic> lol :)
02:28:44 <cdub> networkstatic: ok, that's reasonable to bring up
02:28:46 <networkstatic> i pinged ed if he is going to on all weekend
02:28:54 <networkstatic> Diaper up
02:29:08 <networkstatic> thats gross, lol.
02:29:19 <cdub> #info request for openflowplugin support over this final weekend sprint
02:29:24 <networkstatic> ty sir
02:29:37 <cdub> #info support meaning people on hand to help w/ issues
02:29:40 <networkstatic> will send edwarnicke hippy muffins as payment
02:29:45 <cdub> lol
02:29:49 <networkstatic> :)
02:30:15 <cdub> hideyuki: one thing that passed by above...binary packaging for VTN non-java pieces?
02:30:39 <cdub> hideyuki: you getting some help from Sam Hague for rpm packaging, for example?
02:30:42 <hideyuki> it's important.
02:30:55 <hideyuki> I sent email to Sam Hague yesterday.
02:31:20 <hideyuki> But I'm not sure the status of it.
02:31:27 <cdub> ok
02:31:47 <cdub> #info VTN rpm packaging status...TBD
02:32:03 <cdub> #action cdub to poll Sam Hague for details
02:32:15 <hideyuki> cdub: Thank you!
02:32:16 <cdub> there, i think that's probably everything
02:32:22 <cdub> last call...
02:32:25 <hideyuki> rather than rpm,
02:32:50 <hideyuki> We would like to add VTN artifacts to vm images which will be put in the download page.
02:33:07 <cdub> right, he mentioned that to me
02:33:16 <hideyuki> cdub: oh, thank you!
02:33:40 <cdub> ok, i think we're done
02:33:47 <cdub> #endmeeting