#opendaylight-meeting: tws

Meeting started by tbachman at 17:59:45 UTC (full logs).

Meeting summary

  1. agenda (tbachman, 17:59:51)
    1. Topic: karaf tutorial (tips & tricks, 3.0.2) (tbachman, 18:00:38)
    2. Topic: new Maven version (tbachman, 18:00:48)

  2. karaf tutorial (tbachman, 18:01:01)
    1. karaf helped address the challenge of release vehicles for helium (tbachman, 18:09:04)
    2. The -all features in karaf are meant as a test feature, rather than something to be used for running (tbachman, 18:09:41)
    3. in etc/org.apache.karaf.shell you can change the ssh parameters (tbachman, 18:14:15)
    4. in etc/org.apache.karaf.features.cfg you can change featuresBoot=, which determines what auto-loads on startup (tbachman, 18:14:28)
    5. flaviof good point! (tbachman, 18:14:37)
    6. flaviof notes that also it may interesting to point out that -all is a bit deceiving: for instance, odl-ovsdb-all does not include odl-ovsdb-openstack (tbachman, 18:14:54)
    7. the etc/org.apache.karaf.features.cfg file also has the ability to add feature repositories (tbachman, 18:16:08)
    8. ACTION: mlemay to document the tips and tricks that he’s showing on TWS call (tbachman, 18:16:31)
    9. mlemay shows how to set a run-level threshold using bundle:list -t command (tbachman, 18:17:31)
    10. icbts says to think of the start levels as being like using NICE in linux, where things run at different run levels (tbachman, 18:21:17)
    11. bundle:update can be used to perform in-system updates of bundles (tbachman, 18:22:24)
    12. rovarga_ and icbts say that runlevel in xNIX is a good analogy (tbachman, 18:23:34)
    13. bundle:find-class can be used to find a class, given a className (tbachman, 18:24:18)
    14. log:display can display the entire log (tbachman, 18:24:50)
    15. log:clear clears the entire log (tbachman, 18:24:58)
    16. log:set <level> sets log level (tbachman, 18:25:06)
    17. ./karaf debug starts it with a server that you can attach a debugger to (tbachman, 18:27:24)
    18. dbainbri says he noticed a high CPU spike when he starts the container (tbachman, 18:29:12)
    19. mlemay says this depends on the number of features loaded at startup (tbachman, 18:29:28)
    20. dbainbri asks if there’s a way to set an indicator so that everything’s loaded and ready to set requests (tbachman, 18:30:36)
    21. mlemay says he brought this up at the dev summit — we need a way to know the operational state of our modules… but we don’t have this today (tbachman, 18:30:59)
    22. catohornet asks if it’s possible to set a per-feature log level (tbachman, 18:31:40)
    23. mlemay says you can set this on a per-logger basis, but you need to know which classes have the logger, and their fully qualified class name (tbachman, 18:32:50)
    24. As an example, you could do: log:set TRACE org.opendaylight.controller.md.inventory.manager.NodeChangeCommiter (tbachman, 18:34:37)
    25. jmedved says this is okay for developers, but we need to do something for users (tbachman, 18:35:00)
    26. to debug with Karaf, one also can set these 2 env variables: KARAF_DEBUG=true JAVA_DEBUG_OPTS=-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=5005 (flaviof, 18:35:40)
    27. https://gist.github.com/9c545adae3ea989d9653 (flaviof, 18:36:18)
    28. https://gist.github.com/9c545adae3ea989d9653 Notes from flaviof on presentation in OVSDB on using karaf (tbachman, 18:36:43)
    29. icbts demos ktop, to show what’s going on in karaf (tbachman, 18:37:35)
    30. it shows the average CPU load, runtime, etc. (e.g. like UNIX top command) (tbachman, 18:38:01)
    31. http://icodebythesea.blogspot.com/2014/10/want-to-see-how-your-karaf-container-is.html blog on ktop command (tbachman, 18:40:51)
    32. icbts says ktop isn’t yet checked into the karaf 3.0 distribution (still working out kinks) (tbachman, 18:41:37)
    33. https://github.com/savoirtech/ktop (icbts, 18:41:57)
    34. https://github.com/savoirtech/ktop github repo for ktop (tbachman, 18:42:41)
    35. icbts says ktop is just a bundle, so you can download and install this post-helium installs if desired (tbachman, 18:43:40)
    36. icbts shows the mdsal:status command, to show ConfigRegistry and DOMDataBroker MBean info (tbachman, 18:44:34)
    37. mlemay says to install after the fact, type: install -s mvn:com.savoirtech.karaf.commands/ktop/0.1.0.M1 (tbachman, 18:44:59)
    38. icbts says he intends to contribute this to the MD-SAL team (tbachman, 18:45:40)
    39. icbts says these are examples of karaf action commands, which can provide continuous updates (tbachman, 18:46:22)
    40. alagalah_ asks if this depends on MXBeans (tbachman, 18:47:05)
    41. icbts says there are MXBeans from the controller and other components (tbachman, 18:47:22)
    42. Correction: MBeans. (alagalah_, 18:47:39)
    43. a new version of ktop will be released soon, I’ll update my blog with information on it :) (icbts, 18:51:37)

  3. maven version (tbachman, 18:51:57)
    1. rovarga_ sent an email to the lists on the need to maven 3.1.1 (tbachman, 18:52:32)
    2. The gauva library version that are compatible with our current version of maven are missing some important features (e.g. guava caches) (tbachman, 18:53:21)
    3. This is requires us to move to maven 3.1.1 (tbachman, 18:53:38)
    4. To move to 3.1.1, project committers need to change the maven version in their jenkins jobs (tbachman, 18:54:18)
    5. rovarga_ says they’ve also seen ~10% performance imrpovement in their 3.1.1 maven jenkins job (tbachman, 18:55:28)
    6. rovarga_ says 3.2.2 would be best, but not all the distributions may carry 3.2.2. (tbachman, 18:55:58)
    7. next week’s presentation will be on xSQL (tbachman, 18:59:20)


Meeting ended at 18:59:22 UTC (full logs).

Action items

  1. mlemay to document the tips and tricks that he’s showing on TWS call


Action items, by person

  1. mlemay
    1. mlemay to document the tips and tricks that he’s showing on TWS call


People present (lines said)

  1. tbachman (69)
  2. icbts (11)
  3. odl_meetbot (8)
  4. rovarga_ (7)
  5. flaviof (6)
  6. mlemay (6)
  7. alagalah_ (2)
  8. colindixon (1)


Generated by MeetBot 0.1.4.