17:59:45 <tbachman> #startmeeting tws
17:59:45 <odl_meetbot> Meeting started Mon Nov 17 17:59:45 2014 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:59:45 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:59:45 <odl_meetbot> The meeting name has been set to 'tws'
17:59:51 <tbachman> #topic agenda
18:00:38 <tbachman> #info Topic: karaf tutorial (tips & tricks, 3.0.2)
18:00:48 <tbachman> #info Topic: new Maven version
18:01:01 <tbachman> #topic karaf tutorial
18:04:14 <icbts> mlemay: Hello ?
18:09:04 <tbachman> #info karaf helped address the challenge of release vehicles for helium
18:09:41 <tbachman> #info The -all features in karaf are meant as a test feature, rather than something to be used for running
18:13:21 <flaviof> also it may interesting to point out that -all is a bit deceiving: for instance, odl-ovsdb-all does not include odl-ovsdb-openstack
18:13:33 <tbachman> #info in etc/org.apache.karaf.sheel you can change the ssh parameters
18:14:04 <tbachman> #undo
18:14:04 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x250d690>
18:14:15 <tbachman> #info in etc/org.apache.karaf.shell you can change the ssh parameters
18:14:28 <tbachman> #info in etc/org.apache.karaf.features.cfg you can change featuresBoot=, which determines what auto-loads on startup
18:14:37 <tbachman> #info flaviof good point!
18:14:54 <tbachman> #info flaviof notes that also it may interesting to point out that -all is a bit deceiving: for instance, odl-ovsdb-all does not include odl-ovsdb-openstack
18:16:08 <tbachman> #info the etc/org.apache.karaf.features.cfg file also has the ability to add feature repositories
18:16:31 <tbachman> #action mlemay to document the tips and tricks that he’s showing on TWS call
18:17:31 <tbachman> #info mlemay shows how to set a run-level threshold using bundle:list -t command
18:20:46 <icbts> Think of the start levels as being like using NICE in linux
18:21:00 <icbts> things run at different run levels
18:21:17 <tbachman> #info icbts says to think of the start levels as being like using NICE in linux, where things run at different run levels
18:22:05 <rovarga_> nice? isn't nice a thread priority thing?
18:22:24 <tbachman> #info bundle:update can be used to perform in-system updates of bundles
18:22:25 <rovarga_> it's more like runlevel (e.g. /etc/rc{1-5}.d/}, right?
18:22:32 <icbts> rovarga_: bit of both
18:22:55 <icbts> you can be running karaf at level 80 and have any bundles with runtimes below that opperating
18:23:13 <icbts> runlevel is a good analogy
18:23:34 <tbachman> #info rovarga_ and icbts say that runlevel in xNIX is a good analogy
18:24:03 <tbachman> #info budle:find-class can be used to find a class, given a className
18:24:07 <tbachman> #undo
18:24:07 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2838e10>
18:24:18 <tbachman> #info bundle:find-class can be used to find a class, given a className
18:24:19 <tbachman> [1:24pm]
18:24:40 <rovarga_> btw. about that default password ... can we generate a random password at first startup, so the distro gets to be secure by default?
18:24:50 <tbachman> #info log:display can display the entire log
18:24:58 <tbachman> #info log:clear clears the entire log
18:25:06 <tbachman> #info log:set <level> sets log level
18:25:28 <icbts> rovarga_: Make a feature request Jira at Karaf
18:27:24 <tbachman> #info ./karaf debug starts it with a server that you can attach a debugger to
18:29:12 <tbachman> #info dbainbri says he noticed a high CPU spike when he starts the container
18:29:28 <tbachman> #info mlemay says this depends on the number of features loaded at startup
18:30:36 <tbachman> #info dbainbri asks if there’s a way to set an indicator so that everything’s loaded and ready to set requests
18:30:59 <tbachman> #info mlemay says he brought this up at the dev summit — we need a way to know the operational  state of our modules… but we don’t have this today
18:31:40 <tbachman> #info catohornet asks if it’s possible to set a per-feature log level
18:32:50 <tbachman> #info mlemay says you can set this on a per-logger basis, but you need to know which classes have the logger, and their fully qualified class name
18:33:18 <rovarga_> at some point we need to start creating a message catalogue
18:33:34 <rovarga_> and maintain a KB, which explains the messages
18:33:46 <rovarga_> (will give us visibility to the quality of our messages, though)
18:33:57 <tbachman> #info As an example, you could do: og:set TRACE org.opendaylight.controller.md.inventory.manager.NodeChangeCommiter
18:34:16 <tbachman> oops
18:34:19 <tbachman> #undo
18:34:19 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2641c90>
18:34:37 <tbachman> #info As an example, you could do: log:set TRACE org.opendaylight.controller.md.inventory.manager.NodeChangeCommiter
18:35:00 <tbachman> #info jmedved says this is okay for developers, but we need to do something for users
18:35:33 <rovarga_> icbts: is https://issues.apache.org/jira/browse/KARAF-3366 good enough?
18:35:40 <flaviof> #info to debug with Karaf, one also can set these 2 env variables:  KARAF_DEBUG=true     JAVA_DEBUG_OPTS=-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=5005
18:36:01 <tbachman> flaviof: thx!
18:36:02 <icbts> rovarga_: cool, thanks :)
18:36:18 <flaviof> https://gist.github.com/9c545adae3ea989d9653
18:36:43 <tbachman> #link https://gist.github.com/9c545adae3ea989d9653 Notes from flaviof on presentation in OVSDB on using karaf
18:36:44 <flaviof> #link https://gist.github.com/9c545adae3ea989d9653 gist with another Karaf show and tell
18:36:50 <tbachman> flaviof: lol!
18:36:52 <flaviof> #undo
18:36:52 <tbachman> jinx
18:36:54 <tbachman> #undo
18:36:54 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x269d310>
18:37:17 <flaviof> tbachman: thanks.
18:37:21 <tbachman> flaviof: np!
18:37:29 <mlemay> thx flaviof
18:37:35 <tbachman> #info icbts demos ktop, to show what’s going on in karaf
18:37:53 <mlemay> note that KARAF_DEBUG=true will also spit all the KARAF Debug
18:37:59 <colindixon> ktop is awesome!
18:38:01 <tbachman> #info it shows the average CPU load, runtime, etc. (e.g. like UNIX top command)
18:38:05 * tbachman agrees
18:38:11 <mlemay> yup
18:40:51 <tbachman> #link http://icodebythesea.blogspot.com/2014/10/want-to-see-how-your-karaf-container-is.html blog on ktop command
18:41:37 <tbachman> #info icbts says ktop isn’t yet checked into the karaf 3.0 distribution (still working out kinks)
18:41:57 <icbts> https://github.com/savoirtech/ktop
18:42:19 <tbachman> #link : https://github.com/savoirtech/ktop github repo for ktop
18:42:27 <tbachman> #undo
18:42:27 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x284a0d0>
18:42:41 <tbachman> #link https://github.com/savoirtech/ktop github repo for ktop
18:43:40 <tbachman> #info icbts says ktop is just a bundle, so you can download and install this post-helium installs if desired
18:44:34 <tbachman> #info icbts shows the mdsal:status command, to show ConfigRegistry and DOMDataBroker MBean info
18:44:39 <mlemay> to install after the fact type:
18:44:40 <mlemay> install -s mvn:com.savoirtech.karaf.commands/ktop/0.1.0.M1
18:44:59 <tbachman> #info mlemay says to install after the fact, type: install -s mvn:com.savoirtech.karaf.commands/ktop/0.1.0.M1
18:45:40 <tbachman> #info icbts says he intends to contribute this to the MD-SAL team
18:46:22 <tbachman> #info icbts says these are examples of karaf action commands, which can provide continuous updates
18:47:05 <tbachman> #info alagalah_ asks if this depends on MXBeans
18:47:22 <tbachman> #info icbts says there are MXBeans from the controller and other components
18:47:39 <alagalah_> #info Correction: MBeans.
18:51:37 <icbts> #info a new version of ktop will be released soon, I’ll update my blog with information on it :)
18:51:45 <tbachman> icbts: thx for the demo!
18:51:57 <tbachman> #topic maven version
18:52:19 <alagalah_> icbts: mlemay Wonderful job, lads
18:52:32 <tbachman> #info rovarga_ sent an email to the lists on the need to maven 3.1.1
18:52:42 <icbts> alagalah_: your welcome :)
18:52:58 <mlemay> alagalah: welcome.. I'll start up wiki page
18:53:21 <tbachman> #info The gauva library version that are compatible with our current version of maven are missing some important features (e.g. guava caches)
18:53:38 <tbachman> #info This is requires us to move to maven 3.1.1
18:54:18 <tbachman> #info To move to 3.1.1, project committers need to change the maven version in their jenkins jobs
18:55:28 <tbachman> #info rovarga_ says they’ve also seen ~10% performance imrpovement in their 3.1.1 maven jenkins job
18:55:58 <tbachman> #info rovarga_ says 3.2.2 would be best, but not all the distributions may carry 3.2.2.
18:59:20 <tbachman> #info next week’s presentation will be on xSQL
18:59:22 <tbachman> #endmeeting