16:01:52 <tbachman> #startmeeting md_sal_hackers
16:01:52 <odl_meetbot> Meeting started Mon Feb  2 16:01:52 2015 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:52 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:52 <odl_meetbot> The meeting name has been set to 'md_sal_hackers'
16:01:56 <tbachman> #chair alagalah
16:01:56 <odl_meetbot> Current chairs: alagalah tbachman
16:02:04 <tbachman> #topic agenda
16:02:13 <tbachman> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/md_sal_hackers/opendaylight-meeting-md_sal_hackers.2015-01-12-16.00.html Last recorded meeting minutes
16:03:54 <tbachman> #info alagalah to migrate chapter to new archetype structure
16:04:35 <tbachman> #info jmedved needs about another 2-3 days for the documentation — getting interesting results on benchmarking performance… will target a TWS for that
16:04:44 <alagalah> #link https://wiki.opendaylight.org/view/Controller_Core_Functionality_Tutorials:Tutorials:Data_Store_Benchmarking_and_Data_Access_Patterns
16:05:05 <tbachman> #info pantelis asks if this applies to the clustered data store as well
16:05:33 <tbachman> #info jmedved says this is independent of data store type (clustered vs. non-clustered); he’s only run against non-clustered so far
16:06:04 <tbachman> #info The test varies parameters and number of elements in the lists, and number of transactions per submit, and looking at binding aware and binding independent requests and comparing results
16:06:20 <tbachman> #info pantelis asks if the tests are run internall
16:06:33 <tbachman> #info jmedved says yes, but it’s all triggered by a REST call
16:07:05 <tbachman> #info jmedved says this can be used as a loadable application on any distribution
16:07:20 <tbachman> #info pantelis says the current three-node test doesn’t exercise transaction chaining
16:07:32 <tbachman> #info jmedved says this doesn’t use transaction chaining yet, but we could add it
16:08:24 <tbachman> #info the results from the tests are CSV, so can be imported into excel spreadsheets
16:09:32 <tbachman> #info jmedved says he is able to get 30k transactions/second on a single thread using his MAC
16:10:49 <tbachman> #info algalah asks if these are synchronous or asynchronous
16:11:14 <tbachman> #info jmedved says these are synchronous - but we can do other parameterized testing (e.g. multi-threaded, async, etc.)
16:12:49 <tbachman> #action alagalah to work with zxiiro on failed job in the project
16:14:07 <tbachman> #info jmedved asks if alagalah can put out a TWS to cover all this material
16:14:16 <tbachman> #action alagalah to schedule this for next week’s TWS
16:14:31 <tbachman> #info alagalah asks if rovarga and jmedved was going to do a write up on the artifacts
16:16:35 <tbachman> #info pantelis says he noticed the concurrent broker into the clustered data store, and is changing the 05-clustering.xml file; this breaks backwards compatibility — needs a release note or something that tells people about this; it doesn’t overwrite the existing file, so controller restarts blow up
16:16:59 <tbachman> #info rovarga says we need something to say what the official helium to lithium upgrade path/process will be
16:23:00 <tbachman> #info rovarga says there’s been  a request to update the binding-independent RPC related APIs
16:23:09 <tbachman> #info rovarga says initial cut will be pushed today, will send email
16:23:32 <tbachman> #info rovarga says we should review as soon as possible — shouldn’t break anyone, and won’t affect binding-aware users
16:23:48 <tbachman> #info the patch gets away from composite nodes and all the warnings that they generate
16:24:11 <rovarga> #info https://git.opendaylight.org/gerrit/#/c/14683/ binding-independent RPC API proposal
16:24:17 <tbachman> rovarga: thx!
16:24:29 <tbachman> #link https://git.opendaylight.org/gerrit/#/c/14683/ binding-independent RPC API proposal
16:25:22 <tbachman> #endmeeting