16:59:53 <devinavery> #startmeeting MD-SAL interest call
16:59:53 <odl_meetbot> Meeting started Tue Mar  3 16:59:53 2015 UTC.  The chair is devinavery. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:59:53 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:53 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
17:04:22 <colindixon> if you chair me I can #topic things
17:04:44 <devinavery> remind me colin... whats the command
17:04:46 <devinavery> chair ?
17:04:50 <devinavery> #chair colindixon
17:04:50 <odl_meetbot> Current chairs: colindixon devinavery
17:04:50 <colindixon> #chair colindixon
17:04:50 <odl_meetbot> Current chairs: colindixon devinavery
17:05:00 <colindixon> #topic general updates
17:05:16 <moizer> #info What’s going on in Clustering?
17:05:23 <colindixon> #info tony says they are in the process of moving people from composite nodes to normalized nodes
17:05:33 <colindixon> #undo
17:05:33 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19d7690>
17:05:37 <colindixon> #info tony says they are in the process of moving people from composite nodes to normalized nodes
17:05:40 <colindixon> that works fine
17:05:56 <colindixon> #topic clustering updates
17:06:18 <colindixon> #info right now the work going on in clustering is in the form of performance
17:06:45 <colindixon> #info there has been a lot of prior work on stability (both in single-node and 3-node clusters)
17:07:08 <colindixon> #info performance work is focused on the “DS” benchmark in coretutorials as well as some apps, e.g., bgpcep
17:07:30 <colindixon> #info some bugs crop up from time-to-time, but mostly focused on performance for now
17:07:56 <colindixon> #info the next major thing would be moving to using clustering by default (with a single-node)
17:08:20 <colindixon> #info LuisGomez says he’s planning to do testing to figure out if we can make the cut-over without issues
17:08:38 <colindixon> #info LuisGomez says last he checked, there were issues in the l2switch and maybe some scale-testing
17:09:10 <colindixon> #info moizer says the hope is that if you cut over to using clustering by default, it will push people to fix issues faster
17:09:36 * colindixon notes that he is having countertops installed and may need to wander off, but he’ll try to let tbachman or devinavery know
17:11:48 <colindixon> #info devinavery asks if there’s a way to see the known issues with clustering, e.g., buzilla
17:12:10 <colindixon> #info tony says any bugs with a clustering prefix in the MD-SAL is the right things
17:12:21 * tbachman isn’t sure if his last chat went thru — having in-flight wifi issues
17:12:38 <colindixon> #info tony asks that the bug list not be posted to the wiki, but only a link to the query so that information stays in bugzilla
17:12:41 <colindixon> tbachman: noted
17:13:11 <colindixon> #action moizer to post a link to the open bugs in clustering
17:13:42 <ttkacik> https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&component=General&component=mdsal&component=netconf&component=restconf&f1=target_milestone&f2=cf_target_milestone&j_top=OR&known_name=MD-SAL%3A%20Bugs%3A%20Helium&list_id=24959&o1=substring&o2=substring&product=controller&product=yangtools&query_based_on=MD-SAL%3A%20Bu
17:13:48 <ttkacik> filter for clustering bugs
17:14:03 <moizer> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Clustering
17:14:09 <colindixon> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&component=General&component=mdsal&component=netconf&component=restconf&f1=target_milestone&f2=cf_target_milestone&j_top=OR&known_name=MD-SAL%3A%20Bugs%3A%20Helium&list_id=24959&o1=substring&o2=substring&product=controller&product=yangtools&query_based_on=MD-SAL%3A%20Bu that’s
17:14:10 <colindixon> filter for clustering bugs
17:14:37 <colindixon> #undo
17:14:37 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1ab0c90>
17:14:43 <colindixon> that link seems to be problematic
17:14:53 <colindixon> #topic migrating from composite node to normalized node
17:15:36 <colindixon> #info people are working on moving from composite nodes (the old DOM interface to the MD-SAL) since they proved inefficient for what was actually being done in OpenDaylight
17:15:52 <colindixon> #info the new APIs are based on composite nodes which are more performant
17:16:23 <colindixon> #info the most performance critical elements (data store, and RESCONF access) were moved during Helium
17:17:53 <colindixon> #info as stated during the last Lithium release cross-project IRC meeting, the controller project and yangtools are formally moving everything away from composite nodes
17:18:09 <colindixon> #info moizer asks if they will be expected to move or if tony and others will be able to do it
17:18:28 <colindixon> #Info tony says that he and a few others plan to do all of the migration for people
17:18:59 <colindixon> #info tony says that this should result in there being a lot less code as a result of this because there will only be one set of code paths
17:19:20 <colindixon> #info there *may* be some bugs, but they’re trying hard to avoid any regressions
17:19:38 <colindixon> #info LuisGomez asks when we should be expecting these changes
17:19:49 <colindixon> #info tony says they should be landing on Monday
17:22:21 <colindixon> #info colindixon asks if there will be a reduction in the code and complexity of the code for serialization since he’s had trouble with them in the past
17:23:50 <colindixon> #info tony says that is is intended and should be a lot easier that before because they were designed to be more usable by outside people
17:24:04 <colindixon> #info he also notes that the only projects outside of YANG Tools that use it are controller and ttp
17:26:21 <colindixon> #info now the process should be more about producing translation pipelines, which should be easier
17:27:20 <colindixon> #info tony says they will be maintaining sample code for using them as well (they even have a way to get the snippets cut out and put into AsciiDoc)
17:27:28 <colindixon> #info devinavery asks for any links to bugs, etc.
17:27:53 <colindixon> #info tony says that there should be links to “tree views” in bugzilla from the YANG tools and controller Lithium release plans
17:28:42 <colindixon> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Lithium:Release_Plan controller release plan
17:28:51 <colindixon> #link https://wiki.opendaylight.org/view/YANG_Tools:Lithium:Release_Plan yang tools release plan
17:28:54 <colindixon> #endmeeting