16:03:50 <colindixon> #startmeeting md-sal interest call
16:03:50 <odl_meetbot> Meeting started Tue Apr  7 16:03:50 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:50 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:50 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:03:58 <colindixon> #topic agenda bashing
16:04:01 <colindixon> #chair devinavery
16:04:01 <odl_meetbot> Current chairs: colindixon devinavery
16:04:34 <colindixon> #info we’ll cover quick look at bugs, pending changes, etc.
16:04:55 <colindixon> #info anton wants to talk about YANG tools MAC address and performance
16:05:17 <colindixon> #info we’ll do them in the opposite order doing the status update parts at 15 minutes before the top of the hour
16:05:59 <colindixon> #topic YANG Tools MAC address performance issues
16:06:19 <colindixon> #undo
16:06:19 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1a2c310>
16:07:26 <colindixon> #topic covering bugs/patches in controller/yangtools
16:07:33 <colindixon> #link
16:07:34 <colindixon> https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&columnlist=product%2Ccomponent%2Cassigned_to%2Cbug_status%2Cresolution%2Cshort_desc%2Cchangeddate%2Ccf_target_milestone&f1=cf_target_milestone&f2=days_elapsed&list_id=25751&o1=substring&o2=lessthaneq&order=bug_status%20DESC%2C&product=controller&query_format=advan
16:07:34 <colindixon> v1=Lithium&v2=7 Controller Bugs
16:12:54 <colindixon> #info there’s a bug where you can’t read the root fo the data tree from the clustered data tree
16:13:16 <colindixon> #info this is because that will span shards and cross shard reads aren’t allowed at the moment (I think)
16:13:48 <colindixon> #info it’s affecting NETCONF NB and everyone else if they use this and since the clustered datastore is on by default now, it’s affecting everyone
16:14:43 <colindixon> #info there’s a different bug where data change notifications with ONE as the notification not working right because of issues with respect to lists (I think)
16:14:49 <colindixon> #info the workaroudn is to use subtree
16:15:36 <colindixon> #topic moving to Anton’s covering of YANG tools MAC address issues
16:16:23 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=2825 this is the link for the bug
16:16:52 <colindixon> #info there’s been lots of discussion on the maling list and the bug itself
16:18:45 <colindixon> #action devinavery to post the presetnations
16:19:33 <colindixon> #link https://lists.opendaylight.org/pipermail/controller-dev/2015-March/008622.html mailing list thread starts here
16:21:04 <colindixon> #topic next week
16:21:13 <colindixon> #info we’ll cover Anton’s stuff next week
16:21:28 <colindixon> #info we’ll also cover the ongoing Andrews “thing formerly know as the message bus"
16:21:46 <colindixon> #topic anything major coming down the pipe
16:22:07 <colindixon> #info rovarga says that given we’ve passed M4, not much will hit us
16:22:15 <colindixon> #info the most major thing is making clustering default
16:22:30 <colindixon> #info rovarga says that there’s new integer validation stuff
16:23:23 <colindixon> #info ttkacik there’s new DOM committer cohort that would allow applications to reject commits even if they’re valid
16:24:46 <colindixon> #info ttkacik and rovarga both say that this might be a dangerous feature to put into Lithium at this poing and so we might hold it off until (at least) clustering default had been around for a bit longer
16:25:50 <colindixon> #info ttkacik and rovarga point out that *any* application can bring down the controller or reduce performance to near 0 by doing things wrong, so we should worry
16:26:43 <colindixon> #info the goal is to only allow stateless validation, but historically, in Hydrogen have used it for Data Change Notifications and mutating the data and all sorts of other things
16:29:22 <colindixon> #info rovarga says that, in his mind, this should eventually not be used and we should do (almost) all validation in YANG specifications
16:29:46 <colindixon> #info it sounds like this shoudl be a topic for a future time as well
16:30:22 <colindixon> #info pantelis says there’s a new Data Tree Change Listener API pending
16:32:03 <colindixon> #info this is a response to the fact that data change listeners did a lot of unnecessary work to compute changes and most applications threw most of this out
16:32:26 <colindixon> #info the idea of this API was to give a cursor/iterator to allow for lazy evaluation of changes
16:34:27 <colindixon> #info ttkacik says the APIs have already been merged, what pantelis is talking about are implementions and minor changes to the APIs to make them easier to use
16:35:15 <colindixon> #info the outstanding patches are actually Binding Aware interfaces on top of the Binding Independent implementations (that were already merged and are used by BGP)
16:37:16 <colindixon> #info catohornet asks if we shoudl talk about Karaf 3.0.3
16:37:25 <colindixon> #info consensus seems to be yes, but where
16:37:28 <colindixon> #endmeeting