21:55:34 <anipbu> #startmeeting release
21:55:34 <odl_meetbot> Meeting started Wed Sep  7 21:55:34 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
21:55:34 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:55:34 <odl_meetbot> The meeting name has been set to 'release'
21:55:45 <anipbu> #topic RC3 Blocking Bugs DLUX
21:55:48 <adetalhouet> #info adetalhouet
21:55:52 <anipbu> #info anipbu for release
21:56:05 <anipbu> Hi adetalhouet, can you elaborate on the DLUX bug?
21:56:05 <adetalhouet> I can speak for DLUX, but not too much in technical detailed
21:56:27 <adetalhouet> So basically, DLUX have recently merged an new application called YANGMAN, what ever that is
21:56:44 <anipbu> adetalhouet: can you list the exact patches that needs to be added and the exact bugs related to the patches.
21:57:00 <anipbu> rovarga: ^^^^^
21:57:03 <adetalhouet> the way patches were submitted was a big patch stack of +50 patches, making addressing review almost impossible
21:57:34 <anipbu> adetalhouet: i understand that there were 50+ patches int eh batch.  But right now, how many patches are still pending?
21:57:38 <adetalhouet> thus it was decided with the team providing those patches, that all patches of the +50 patch stack will be merged, but that reviews will have to be addressed in the follow-up
21:57:40 <anipbu> for stable/boron
21:58:08 <adetalhouet> For stable/boron, those are the patches: https://git.opendaylight.org/gerrit/#/q/status:open+project:dlux+branch:stable/boron+topic:yangman-stable/boron
21:58:23 <adetalhouet> All those are cherry-pick from master, where they are all merged already
21:58:30 <anipbu> #info need to merge https://git.opendaylight.org/gerrit/#/c/45339/
21:58:38 <anipbu> #info need to merge https://git.opendaylight.org/gerrit/#/c/45340/
21:58:49 <adetalhouet> All those patches are basically addressing reviews, listed in the following bugzilla
21:58:58 <anipbu> adetalhouet: can you confirm that these are the ONLY two patches that needs to be merged?
21:59:04 <adetalhouet> https://bugs.opendaylight.org/show_bug.cgi?id=6394
21:59:04 <adetalhouet> https://bugs.opendaylight.org/show_bug.cgi?id=6435
21:59:04 <adetalhouet> https://bugs.opendaylight.org/show_bug.cgi?id=6428
21:59:04 <adetalhouet> https://bugs.opendaylight.org/show_bug.cgi?id=6440
21:59:06 <adetalhouet> https://bugs.opendaylight.org/show_bug.cgi?id=6464
21:59:08 <adetalhouet> https://bugs.opendaylight.org/show_bug.cgi?id=6512
21:59:10 <adetalhouet> https://bugs.opendaylight.org/show_bug.cgi?id=6520
21:59:12 <adetalhouet> https://bugs.opendaylight.org/show_bug.cgi?id=6531
21:59:14 <adetalhouet> https://bugs.opendaylight.org/show_bug.cgi?id=6550
21:59:16 <adetalhouet> https://bugs.opendaylight.org/show_bug.cgi?id=6548
21:59:18 <adetalhouet> https://bugs.opendaylight.org/show_bug.cgi?id=6545
21:59:20 <adetalhouet> https://bugs.opendaylight.org/show_bug.cgi?id=6044
21:59:22 <adetalhouet> https://bugs.opendaylight.org/show_bug.cgi?id=6544
21:59:24 <adetalhouet> https://bugs.opendaylight.org/show_bug.cgi?id=6549
21:59:26 <adetalhouet> https://bugs.opendaylight.org/show_bug.cgi?id=6660
21:59:28 <adetalhouet> anipbu: I can confirm. I worked closely with Maxime, the reviewer/committer of those patches
21:59:41 <anipbu> #info bugs that are blocker: https://bugs.opendaylight.org/show_bug.cgi?id=6549
21:59:46 <adetalhouet> He met today with Daniel during the DLUX meeting, and they clarified current status
22:00:09 <anipbu> #info bugs that are blocker: https://bugs.opendaylight.org/show_bug.cgi?id=6394
22:00:25 <adetalhouet> anipbu: you have listed only the two patches that aren't +2, but all the other patches of the query I gave are to be merged
22:00:58 <adetalhouet> sorry I mis-read, those are not the only two patches.
22:01:10 <anipbu> #undo
22:01:10 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2639890>
22:01:13 <anipbu> #undo
22:01:13 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2639a10>
22:01:14 <adetalhouet> they are 20 patches
22:01:18 <anipbu> #undo
22:01:18 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x26396d0>
22:01:20 <anipbu> #undo
22:01:20 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2639d50>
22:01:24 <adetalhouet> 18 of them already has the +2
22:01:52 <anipbu> But ideally we would merge all 20
22:01:59 <adetalhouet> Correct.
22:02:10 <adetalhouet> Those that don't have +2 is because they are still verifying
22:02:13 <anipbu> adetalhouet: is there anyway we can hold off until SR1?
22:02:30 <anipbu> I mean, this is a pretty huge list of patches.
22:02:39 <adetalhouet> As per Daniel, he is fine. My point is, if we re-spiin, those could get in
22:03:58 <anipbu> #info request is to merge 20 patches listed here: https://git.opendaylight.org/gerrit/#/q/status:open+project:dlux+branch:stable/boron+topic:yangman-stable/boron
22:04:23 <rovarga> anipbu: I'm here :)
22:05:08 <anipbu> rovarga: adetalhouet: colindixon: dlux would like to merge a set of 20 patches to fix various bugs.  Daniel has stated he is fine with waiting until Boron-SR1.
22:05:36 <anipbu> The question at hand is: are these patches related to any true blocker bugs?
22:06:07 <anipbu> If they are not true blockers, can we please hold off until Boron-SR1?
22:06:10 <adetalhouet> those patches are addressing reviews made over +50 patches merged. As those were chain, reviews had to be done separately
22:06:37 <rovarga> based on the evidence I have just sent out to release (and one to TSC), I think we should merge those patches
22:07:14 <rovarga> essentially it does seem like Maxime was on PTO (or similar) for two weeks, which kept the patches in the queue
22:07:23 <adetalhouet> rovarga: regarding evidence, I agree. Max is the only active committer
22:08:09 <adetalhouet> He wasn't on PTO but busy, yes
22:08:54 <adetalhouet> Also, this Yangman work has raise good points regarding current DLUX architecture, and active committers. But I believe this is another discussion
22:09:05 <anipbu> Unfortunately Daniel nor Max is here to vouch, but I have additional questions.
22:09:42 <anipbu> first off, in terms of severity, can either of you (rovarga: adetalhouet) confirm if these are true blockers here on IRC?
22:09:43 <rovarga> adetalhouet: agreed, I think we should put it on the TSC agenda
22:09:53 <anipbu> Severity: Could you elaborate on the severity of this bug?  Is this a BLOCKER such that we cannot release Boron without it?  Is there a workaround such that we can write a release note and fix in future Boron SR1?
22:10:27 <rovarga> anipbu: I cannot judge the patches on technical merit
22:10:36 <adetalhouet> anipbu: me neither
22:10:41 <adetalhouet> rovarga: yes, I agree
22:10:50 <rovarga> anipbu: but I agree with adetalhouet's interpretation of Daniel's response
22:11:36 <anipbu> Secondly. can either of you (rovarga, adetalhouet) confirm is these have been thoroughly tested.  Testing: Could you also elaborate on the testing of all 20 patches?  How extensively have all 20 patches been tested?  Is it covered by any unit tests or system tests?
22:12:20 <adetalhouet> anipbu: I believe this is not covered by any UT more ST. I can say that this is an new UI application, and that it doesn't impact anyone.
22:12:36 <adetalhouet> Moreover, AFAIK, nobody has knowledge of this Yangman app, apart from the person of interest
22:12:48 <anipbu> Thirdly, can either of you (rovarga, adetalhouet) confirm if there is any impact to dependent projects that use dlux.  Impact: Does this fix impact any dependent projects?
22:12:48 <rovarga> knowing Daniel they definitely do not make Yangman worse
22:12:51 <adetalhouet> So I can say with confidence that it won't affect the release in anyway
22:13:03 <rovarga> and they do not impact anything else, if my understanding is accurate
22:13:49 <rovarga> anipbu: I think Yangman is not used internally, but is expected to be used by third parties
22:13:52 <adetalhouet> This has no impact whatsoever on any component other than Yangman
22:14:15 <adetalhouet> This is a self-contained UI application
22:15:30 <anipbu> #info Impact: rovarga, adetalhouet both confirm that there are no impact to dependent projects.
22:16:20 <adetalhouet> Also, as I said previously, that patches are only addressing the reviews made on the initial commits. Thus, as rovarga said, certainly improving the application rather than making it worse
22:16:28 <anipbu> adetalhouet: do you know what kind of testing was done?
22:16:34 <adetalhouet> anipbu: I don't
22:17:28 <anipbu> adetalhouet: is there any way you can pull Daniel or Max into the conversation to get their testing analysis.
22:17:32 <rovarga> anipbu: I don't either, but I think Jan has been working with Daniel
22:17:44 <anipbu> Can we pull Jan into this conversation?
22:17:46 <rovarga> and knowing Jan's testing ...
22:18:15 <adetalhouet> anipbu: Unfortunately Max is gone for the day, and isn't answering ..
22:18:29 <rovarga> I don't think so, he is probably asleep right now
22:18:37 <anipbu> I need somebody to vouch that these patches have been tested somehow.
22:19:16 * rovarga is willing to vouch for that, but cannot judge the actual extent
22:19:54 <anipbu> #info rovarga vouches that these patches have all been tested.
22:20:02 <rovarga> they definitely are not just blind drops and have seen some usage
22:20:28 <anipbu> #info these patches are not covered by any UT more ST.  This is an new UI application, and that it doesn't impact anyone.
22:21:28 <anipbu> lastly, can you both vouch that these are true blocker bugs for Boron RC3 and must be fixed (Severity).
22:23:13 <anipbu> rovarga: adetalhouet: can you both vouch that these are true blocker bugs for Boron RC3 and must be fixed in Boron RC3.
22:23:39 <adetalhouet> anipbu: those are true blockers, as addressing reviews of merged patches that are already present in stable/boron
22:24:07 <anipbu> #info adetalhouet can vouch that they are true blockers
22:25:42 <adetalhouet> That raise one of the major point we have discussed with Maxime, DLUX shouldn't be part of the release process.
22:26:07 <adetalhouet> But again, this is another discussion to have, and now/here isn't the place.
22:26:15 <anipbu> based on the analysis for severity, testing, impact.  I think we can merge these patches.  adetalhouet, I have posted questions on each individual patch (sorry, we have to go through for each patch), please reply to them on behalf of the dlux project.  anipbu will send email to TSC and if there are no objections, the release team will merge these patches
22:26:15 <anipbu> before RC3.2 is kicked off (assumming TSC has no objections)
22:26:17 <rovarga> adetalhouet: well... that depends on the architecture and where DLUX plugins live :)
22:26:45 <anipbu> adetalhouet: can i action action you to publicly reply to my questions for each and every patch?
22:27:12 <adetalhouet> "where DLUX plugins live": exactly
22:27:24 <anipbu> #action adetalhouet will respond to questions on patches
22:27:43 <adetalhouet> I really have to go now, can I do that in a couple of hours?
22:28:05 <anipbu> adetalhouet: no, we need the questions answere before 4 PM today Pacific time
22:28:49 <adetalhouet> rovarga: same goes with the committers. Once of the major blocker with this Yangman app is that Max knows nothing about YANG, he is just a UI expert, but not YANG expert at all. Thus the latency in merging the patches
22:28:56 <anipbu> okay thanks folks, I'll send an email to TSC and hopefully get their support.
22:29:13 <anipbu> Thanks adetalhouet, rovarga:
22:29:22 <rovarga> anipbu: you're welcome
22:29:43 <adetalhouet> anipbu: Sure
22:29:46 <anipbu> #info anipbu will send email to TSC and if there are no objections, the release team will merge these patches
22:29:49 <adetalhouet> anipbu: what are the questions?
22:29:50 <anipbu> #topic cookies
22:29:55 <anipbu> #endmeeting