17:00:12 <colindixon> #startmeeting tsc
17:00:12 <odl_meetbot> Meeting started Thu Mar 16 17:00:12 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:12 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:12 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:18 <colindixon> #topic agenda bashing and roll call
17:00:21 <colindixon> #info colindixon
17:00:26 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=53276#Agenda
17:00:33 <abhijitkumbhare> #info abhijitkumbhare
17:00:41 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-03-09-17.59.html last week's meeting mintues
17:00:48 <vishnoianil> #info Anil Vishnoi
17:00:50 <anipbu> #info anipbu
17:00:53 <zxiiro> #info Thanh Ha
17:01:34 <colindixon> #info vishnoianil, anipbu will followed-up wtih LACP project to clean up the committer list, it looks like it's been done
17:01:47 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
17:01:53 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
17:01:56 <hideyuki> #info Hideyuki
17:03:14 <colindixon> #info vrpolak says that the basic features for a karaf4 distribution is there, but it's missing things as basic as restconf, once that's in more project features are coming, the ETA for th RESTCONF feature is Monday
17:03:37 <LuisGomez> #info LuisGomez
17:03:37 <colindixon> #action colindixon will add Karaf 4 tracking as part of the weekly carbon readout
17:03:51 <jamoluhrsen> #info jamoluhrsen
17:04:07 <colindixon> #action phrobb to start a thread on how to have the best DDF-like developer event that works for everyone, e.g., colocated with OPNFV summit in Beijing?
17:04:49 <colindixon> #info jamoluhrsen, abhijitkumbhare, edwarnicke_, vishnoianil, colindixon, anipbu, zxiiro started to look into a 6 month timeframe for our release
17:05:05 <katie> carbon release tracking sheet
17:05:07 <katie> https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1544647361
17:05:22 <colindixon> #action colindixon to send notes from the 6-month cadence meetings to the TSC maiing list
17:05:56 <colindixon> #topic TSC mailing list votes and discussions
17:06:06 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-February/006577.html Nitrogen planning
17:06:27 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-February/006581.html  Namespace management
17:07:08 <rovarga> #info rovarga
17:07:17 <colindixon> #action zxiiro to write up what he understands about namespace management and commit it to docs someplace
17:07:28 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-February/006578.html  projects with few/no active committers
17:07:43 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2017-January/009034.html  flagship features in Carbon
17:07:53 <colindixon> #ink https://lists.opendaylight.org/pipermail/tsc/2017-March/006695.html  stricter enforcement of release requirements
17:08:02 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-March/006696.html  semantic versioning (or something like it) in Nitrogen
17:08:55 <shague> #info shague
17:09:51 <colindixon> #topic events
17:10:03 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-March/006756.html  ODL meeting at ONS
17:10:17 <colindixon> #ink https://www.opendaylight.org/global-events public events page
17:10:24 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main wiki events page
17:10:35 <colindixon> #action colindixon to add wiki events page to TSC agenda
17:11:50 <colindixon> #startvote TSC members, are you attending ONS? yes, no
17:11:50 <odl_meetbot> Begin voting on: TSC members, are you attending ONS? Valid vote options are yes, no.
17:11:50 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:11:53 <colindixon> #vote yes
17:11:54 <zxiiro> #vote yes
17:11:56 <hideyuki> #vote no
17:11:57 <rovarga> #vote no
17:11:59 <edwarnicke> #vote yes
17:12:01 <anipbu> #vote yes
17:12:01 <abhijitkumbhare> #vote no
17:12:02 <vishnoianil> #vote yes
17:12:02 <LuisGomez> #vote not sure yet
17:12:02 <odl_meetbot> LuisGomez: not sure yet is not a valid option. Valid options are yes, no.
17:12:04 <rovarga> (most likely no)
17:12:07 <jamoluhrsen> #vote i could
17:12:07 <odl_meetbot> jamoluhrsen: i could is not a valid option. Valid options are yes, no.
17:12:30 <edwarnicke> There will be so much attending you will be sick of attending! ;)
17:12:38 <jamoluhrsen> #vote yes
17:12:45 <LuisGomez> #vote yes
17:12:52 <abhijitkumbhare> #vote yes
17:12:54 <shague> #vote no
17:13:00 <colindixon> #endvote
17:13:00 <odl_meetbot> Voted on "TSC members, are you attending ONS?" Results are
17:13:00 <odl_meetbot> yes (8): zxiiro, LuisGomez, edwarnicke, colindixon, jamoluhrsen, anipbu, vishnoianil, abhijitkumbhare
17:13:00 <odl_meetbot> no (3): shague, hideyuki, rovarga
17:13:22 <colindixon> #info note that LuisGomez, abhijitkumbhare, jamoluhrsen are not attending ONS, but could attend a breakfast TSC meeting
17:14:04 <anipbu> +1 to moving to hawaii
17:14:42 <jamoluhrsen> 9-10?
17:14:53 <jamoluhrsen> k
17:16:54 <colindixon> #startvote should we move the Thursday 4/6 TSC call to be a breakfast meeting at ONS at 7:30-8:15 or cancel ut? breakfast, cancel
17:16:54 <odl_meetbot> Begin voting on: should we move the Thursday 4/6 TSC call to be a breakfast meeting at ONS at 7:30-8:15 or cancel ut? Valid vote options are breakfast, cancel.
17:16:54 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:17:15 <colindixon> #endvote
17:17:15 <odl_meetbot> Voted on "should we move the Thursday 4/6 TSC call to be a breakfast meeting at ONS at 7:30-8:15 or cancel ut?" Results are
17:18:18 <colindixon> #startvote should we move the Thursday 4/6 TSC call to be a breakfast meeting at ONS at 7:30-8:15, evening 5-6p, or cancel it? breakfast, cancel, evening
17:18:18 <odl_meetbot> Begin voting on: should we move the Thursday 4/6 TSC call to be a breakfast meeting at ONS at 7:30-8:15, evening 5-6p, or cancel it? Valid vote options are breakfast, cancel, evening.
17:18:18 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:18:22 <colindixon> #vote breakfast
17:18:51 <jamoluhrsen> #vote breakfast
17:18:54 <edwarnicke> #vote cancel
17:19:02 <anipbu> #vote cancel
17:19:04 <zxiiro> #vote cancel
17:19:07 <LuisGomez> #vote cancel
17:19:20 <hideyuki> #vote cancel
17:19:22 <abhijitkumbhare> #vote either way :)
17:19:22 <odl_meetbot> abhijitkumbhare: either way :) is not a valid option. Valid options are breakfast, cancel, evening.
17:19:26 <shague> is there a "fine with any option" vote
17:19:49 <colindixon> #endvote
17:19:49 <odl_meetbot> Voted on "should we move the Thursday 4/6 TSC call to be a breakfast meeting at ONS at 7:30-8:15, evening 5-6p, or cancel it?" Results are
17:19:49 <odl_meetbot> cancel (5): hideyuki, zxiiro, LuisGomez, edwarnicke, anipbu
17:19:49 <odl_meetbot> breakfast (2): colindixon, jamoluhrsen
17:20:06 <colindixon> #agreed we will cancel the Thurdsay, 4/6 TSC call because of ONS
17:22:06 <colindixon> #Info colindixon asks phrobb and CaseyODL when we wanted to have some kind of OpenDaylight group gathering to chat about interesting topics?
17:22:51 <colindixon> #info the answers as to when it might happen seems to be Tuesday or Thursday evening
17:23:07 <colindixon> #action phrobb, CaseyODL and colindixon to follow up with some kind of planning formal or informal
17:24:09 <colindixon> #Info lunch also might be an option, some uncoference time might be possible too
17:25:25 <colindixon> #info there is a DDF coming up 5/30 and 6/1, we're looking to get topics by the end of april to put up some agenda so people (mostly semi-outsiders) can decide whether to attend
17:26:20 <colindixon> #info the OPNFV summit's CFP is open until 3/27
17:26:22 <colindixon> #undo
17:26:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19199d0>
17:26:31 <colindixon> #info the OPNFV summit's (Beijing in late June) CFP is open until 3/27
17:27:24 <abhijitkumbhare> whom are they conning? :)
17:27:26 <colindixon> #info the CFP for LinuxCon/ContainerCon/CloudOpen in China closes 3/18, there is a networking track there (it's the week after the OPNFV summit in Beijing)
17:28:05 <colindixon> #topic Boron
17:28:26 <colindixon> #info the cutoff for SR3 is 3/19, and the relased date is looking at 3/23
17:28:32 <colindixon> #info there are 46 open patches
17:28:43 <katie> Total	46		 netvirt 	16	"	snmp4sdn"	2 netconf	3	dlux	3 openflowplugin	7	l2switch	1 usc	1	iotdm	2 topoprocessing	1	genius	3 sfc	1	vtc	1 ovsdb	2	docs	1 tsdr	1	aaa	1
17:29:01 <colindixon> #info from kate: "Total	46	netvirt 16	"	snmp4sdn"	2 netconf	3	dlux	3 openflowplugin	7	l2switch	1 usc	1	iotdm	2 topoprocessing	1 genius	3 sfc	1	vtc	1 ovsdb	2	docs	1 tsdr	1	aaa	1"
17:29:09 <edwarnicke> This is really really good data :)
17:29:15 <edwarnicke> katie: Many thanks :)
17:29:52 <zxiiro> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/207/ Current Boron build attempt
17:31:13 <colindixon> #info rovarga notes that Boron-SR3 is the first RFC-compatible version of RESTCONF, we might want to make a bigger splash about that
17:31:19 <gzhao> katie: good work
17:31:37 <hideyuki> katie: Good work!
17:32:04 <abhijitkumbhare> +1 on good work katie
17:32:15 <colindixon> #action rovarga, phrobb, CaseyODL, and colindixon to work with marketing about maybe commenting Boron-SR3's RFC-compatible RESTCONF
17:32:24 <katie> thanks everybody :)
17:32:49 <colindixon> #info rovarga asks about if there are any blocking Boron-SR3 bugs, people say no, but we should probably ask
17:33:36 <colindixon> #info vishnoianil say that there are blocking bugs in OFP, but there are patches that will get in by sunday for it
17:34:07 <colindixon> #action katie to email the release list to ask if there are other blocking bugs and start to track them
17:34:56 <colindixon> #action colindixon, anipbu, zxiiro, and anipbu to work to generate a possible list of blocking bugs for Boron-SR3
17:35:04 <colindixon> #undo
17:35:04 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1aeced0>
17:35:08 <colindixon> #action colindixon, katie, zxiiro, and anipbu to work to generate a possible list of blocking bugs for Boron-SR3
17:35:18 <anipbu> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=IN_PROGRESS&bug_status=WAITING_FOR_REVIEW&f1=cf_target_milestone&f2=cf_target_milestone&j_top=OR&list_id=67733&o1=substring&o2=substring&query_format=advanced&resolution=---&v1=Boron&v2=--- <--- Eight blocker bugs in openflowplugin,
17:35:18 <anipbu> odlparent, netvirt
17:35:32 <colindixon> #undo
17:35:32 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1aeced0>
17:35:33 <colindixon> #undo
17:35:33 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x192f6d0>
17:35:46 <colindixon> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=IN_PROGRESS&bug_status=WAITING_FOR_REVIEW&f1=cf_target_milestone&f2=cf_target_milestone&j_top=OR&list_id=67733&o1=substring&o2=substring&query_format=advanced&resolution=---&v1=Boron&v2=--- <--- Eight blocker bugs in openflowplugin, odlparent, netvirt
17:36:06 <colindixon> #topic carbon
17:37:04 <colindixon> #info M3 and M4 missign reports down from 27 and 26 to 9 for each
17:37:32 <katie> snmp no resource to go on
17:37:37 <colindixon> #Info we still haven't gotten a response from SNMP except that there are no resources to work on
17:38:40 <colindixon> #info the following projets in ODL rely on SNMP: eman, tsdr, and didm, so removing it would actively hurt those projects
17:38:51 <colindixon> #info phrobb further points out that people might be using outside OpenDaylight
17:38:56 <colindixon> #undo
17:38:56 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a001d0>
17:39:05 <colindixon> #info phrobb further points out that people might be using it outside OpenDaylight
17:39:17 <katie> vpnservice	2	inactive Merge to Netvirt sdninterfaceapp, LACP, didm	2	no change since M2 natapp	2	Not paticipate Carbon snbi	2	Not paticipate Carbon usecplugin	2	Not paticipate Carbon yangide	2	Not paticipate Carbon No response
17:39:24 <katie> other projects changes
17:41:08 <katie> "atrium capwap cardinal centinel eman next of-config opflex yang-push"
17:41:39 <zxiiro> so if they are not participating that means "natapp" and "snbi" need to be removed from autorelease/distribution?
17:41:41 <colindixon> #info vpnservice is not participating in Carbon (Merge to Netvirt)
17:41:42 <colindixon> #info sdninterfaceapp, LACP, didm	have no change since M2
17:41:43 <colindixon> #info natapp, snbi, usecplugin, and yangide are not participating Carbon
17:42:18 <colindixon> #action zxiiro to remove natapp, snbi, usecplugin, vpnservice and yangide from autorelease if they aren't already
17:42:35 <colindixon> #action colindixon to remove natapp, snbi, usecplugin, vpnservice and yangide from docs if they aren't already
17:42:52 <colindixon> #action colindixon to ping ryan about aaa M4 readout
17:42:53 <katie> M4 status missing:
17:42:54 <katie> "alto atrium capwap cardinal centinel docs eman integration/distribution next of-config opflex packetcable ttp yang-push"
17:42:56 <colindixon> #undo
17:42:56 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1aecc90>
17:43:18 <colindixon> #action colindixon to ping ryan about aaa M4 and M5 readout
17:44:00 <colindixon> #info missing M4 status from: alto atrium capwap cardinal centinel docs eman integration/distribution next of-config opflex packetcable ttp yang-push
17:44:15 <colindixon> katie: I know that ttp and docs are now in, so that may be a bit out of date
17:44:44 <anipbu> #action katiezhang to follow up with validation of M4 Status per project
17:44:54 <colindixon> #info katie validated that M4 status had correct informatin and is working to ping projects where information is pining those projects to update
17:45:07 <colindixon> #Info colindixon asks about M5 offset 0, katie says everyone but aaa is in
17:45:17 <colindixon> #info M4 offset 1 is due today
17:45:51 <katie> NetVirt Intent to seek functionality freeze waiver
17:46:15 <katie> https://lists.opendaylight.org/pipermail/release/2017-March/009587.html
17:46:33 <katie> "Requesting a waiver to add a new feature to netvirt - odl-netvirt-federation [1]. It enables neutron networks to expand beyond a single OpenStack instance to allow L2 switching and L3 routing between remote sites using the federation service [2]. This feature does not introduce any API change and only add new API that is currently not consumed by any other ODL project. Complete description of the netvirt federation plugin
17:46:48 <katie> [INTENT TO CHANGE SEEK API FREEZE WAIVER] SFC MAC Chaining
17:46:56 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2017-March/009587.html NetVirt request to add a user facing feature to add more user-control over how things are activated, the functionality was already there
17:47:09 <katie> "Note: This email is an advisement of intent to seek a waiver of '''API FREEZE'''.  The patch for this would be going to: SFC https://git.opendaylight.org/gerrit/#/c/52901/  The following projects have been determined to be impacted:  Netvirt - Consumer GBP - Consumer   No API changing code will be committed until these projects have agreed to wave API FREEZE, but Gerrits may be pushed.  The following bugzilla has already
17:47:26 <colindixon> #link "Note: This email is an advisement of intent to seek a waiver of '''API FREEZE'''.  The patch for this would be going to: SFC https://git.opendaylight.org/gerrit/#/c/52901/  The following projects have been determined to be impacted:  Netvirt - Consumer GBP - Consumer  No API changing code will be committed until these projects have agreed to wave API FREEZE, but Gerrits may be pushed.  The following bugzilla h
17:47:27 <colindixon> already
17:48:05 <katie> "Integration/Distribution is now [0] building Karaf 4 based distribution (new URL [1], Karaf 3 is still on the old URL [2]).  At the moment, the Karaf 4 distribution does not contain Restconf, and there are no csit jobs.  {project}-distribution-check-carbon jobs now can access Karaf 4 features, so any open contribution got a ""recheck"" post, just to lower the small probability of breaking.  Projects are welcome to add the
17:49:24 <colindixon> #info jamoluhrsen notes that the integration team sees migrating to Karaf 4 as a risk to the release, not critical yet, but real
17:51:20 <colindixon> #info rovarga notes that sdninterfaceapp has not made any progress on getting off of their fork of bgpcep despite it being the only listed deliverable for Carbon
17:52:12 <colindixon> #info colindixon notes that, in essence, the TSC has two (maybe 3 options), drop them from Carbon, leave them in Carbon, lastly maybe label them as experimental
17:53:36 <colindixon> #info rovarga notes that it's not just about copying code, but really because the promised to do this both as part of the boron release review and the carbon release plan
17:55:17 <colindixon> #info colindixon notes that he's not sure what the precedent would be of saying that you can't copy properly licensed code into your repo, rovarga notes (as he put above) it's less aobut that and more about not meeting promised deliverables
17:58:05 <colindixon> #info edwarnicke asks if there are mechanically, problems with having sdninterface in the project, colindixon says no, edwarnicke asks about stoping over the same model, using the same ports, using the same models, etc.
17:59:01 <colindixon> #info colindixon notes that even if the stomped on the same models, or same ports, if they said that they weren't compatible, we would still have allowed them to be here
18:01:20 <colindixon> #action colindixon to start a thread on the TSC list about what to do with sdninterfaceapp given what has happened
18:02:51 <LuisGomez> as a minimum i would like to hear from sdninterfaceapp people before voting or deciding on removing them from release.
18:02:55 <colindixon> #topic TSC membership
18:03:15 <colindixon> #info phrobb says that Lori will take Alexis's seat on the TSC
18:03:17 <anipbu> congrats lori!
18:03:30 <anipbu> thanks alexis!
18:03:36 <colindixon> congrats lori
18:03:47 <colindixon> #action colindixon to send out the mail about Lorin being the newest TSC member
18:03:47 <vina_ermagan> congrats Lori!
18:03:59 <LuisGomez> congrats lori :)
18:04:06 <vina_ermagan> congrats lori!
18:04:22 <colindixon> #undo
18:04:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1ad6810>
18:04:26 <jamoluhrsen> cool lori!
18:04:27 <colindixon> #action colindixon to send out the mail about Lori being the newest TSC member
18:04:31 <lori> thanks everyone!
18:04:38 <lori> I missed the meeting
18:04:44 <colindixon> #topic cookies
18:04:44 <lori> aaargh
18:04:46 <vishnoianil> congrates lori :)
18:04:46 <jamoluhrsen> lori, now you have to be on these calls every week
18:04:49 <lori> timezone changes
18:04:54 <lori> right
18:04:56 <CaseyODL> lori: Please send me your headshot and Bio so that I can update the webpage.
18:05:10 <colindixon> #endmeeting