17:00:51 <skitt> #startmeeting tsc
17:00:51 <odl_meetbot> Meeting started Thu Aug 10 17:00:51 2017 UTC.  The chair is skitt. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:51 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:51 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:57 <skitt> #chair CaseyODL
17:00:57 <odl_meetbot> Current chairs: CaseyODL skitt
17:01:16 <skitt> #topic Roll call and agenda bashing
17:01:21 <skitt> #info TSC members please info in
17:01:24 <skitt> #info skitt
17:01:25 <lori> #info lori
17:01:27 <anipbu> #info anipbu
17:01:30 <huan> #huan
17:01:32 <skitt> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=63242#Agenda
17:01:37 <skitt> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-03-16.59.html
17:01:38 <huan> #info huan
17:01:42 <jamoluhrsen> #info jamoluhrsen
17:01:46 <klou__> #info klou
17:01:49 <gilesheron> #info gilesheron (proxy for edwarnicke)
17:01:54 <vishnoianil> #info Anil Vishnoi
17:02:09 <dfarrell07> 8
17:02:31 <zxiiro> #info Thanh
17:03:11 <skitt> #link https://lists.opendaylight.org/pipermail/tsc/2017-August/007764.html
17:03:26 <skitt> #info release engineering to look at the yangtools branching proposal
17:03:58 <skitt> #action release engineering to look at the yangtools branching proposal
17:04:53 <skitt> #action colindixon to allow co-hosts for the TSC meeting
17:05:01 <abhijitkumbhare> #info abhijitkumbhare
17:05:11 <skitt> #action colindixon to follow up about one last non-responsive security response team member
17:05:58 <shague_> #info shague
17:06:31 <skitt> #info the request for a security manager is on the agenda for the next board meeting
17:06:41 <skitt> #topic TSC mailing list votes and discussions
17:07:38 <skitt> #topic Events
17:07:55 <skitt> #info cablelabs event was a success
17:08:04 <skitt> #info lots of interest in ODL
17:08:09 <skitt> #info next big event: DDF
17:08:17 <skitt> #info please add topics to the topics page
17:08:31 <skitt> #link https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum
17:09:00 <dfarrell07> #link https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum Add DDF topics here
17:09:07 <dfarrell07> #undo
17:09:41 <skitt> #info encourage cross-project discussions at our DDF (ONAP etc.)
17:11:02 <phrobb> #info Oxygen DDF on Oct. 9th and 10th
17:11:05 <dfarrell07> CaseyODL: "Tentatively scheduled for the second week of October in the Bay Area, CA."
17:11:26 <CaseyODL> https://wiki.opendaylight.org/view/Events:Main
17:11:42 <rovarga> #info rovarga
17:11:48 <skitt> CaseyODL, https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum still says "tentatively"
17:12:15 <rovarga_> #infor rovarga_
17:12:18 <rovarga_> #info rovarga_
17:12:20 <rovarga_> :)
17:12:33 <jamoluhrsen> #action CaseyODL to update this wiki page to not be tentative for DDF https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum#OpenDaylight_Oxygen_Developer_Forum_-_2017
17:12:43 <skitt> two rovarga_ oh dear
17:12:52 <skitt> ;-)
17:13:56 <abhijitkumbhare> dfarrell07: about the hotel - Embassy Suites by Hilton Santa Clara Silicon Valley, 2885 Lakeside Dr, Santa Clara, CA 95054 is right in front of the Ericsson building
17:14:00 <rovarga_> skitt: more reviews for you :)
17:14:21 <skitt> rovarga_, that’s something I wouldn’t mind
17:15:17 <skitt> #info OPNFV and ONAP events in December
17:16:15 <skitt> #info having aligned project releases will simplify the organisation of collaborative events
17:17:04 <skitt> #info mid-December is Oxygen M3 which is ideal for integrating with upstreams and downstreams
17:18:31 <skitt> #info opportunity to prepare Fluorine as well
17:20:25 <abhijitkumbhare> phrobb: we cannot hear you
17:20:34 * dfarrell07 gives big +1 to this cross-project-LF-networking-integration-style event
17:20:44 <skitt> #action CaseyODL to start a thread to discuss a December meet-up
17:25:06 <zxiiro> rovarga_: skitt: sorry for the delay on responding to the yangtools version bump email. I just responded and ACKed that Releng can take care of it.
17:25:51 <skitt> #info multiple logistical questions to address
17:26:37 <vishnoianil> phrobb +1 for joint DDF event
17:27:02 <vishnoianil> phrobb lets start the thread on mailing list to get the opinion from other community members
17:27:12 <skitt> #action phrobb to pursue the opportunity and keep the TSC up to speed
17:27:15 <vishnoianil> phrobb +1 from my side
17:27:20 <skitt> #topic Carbon
17:27:39 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule   <--- Carbon SR2 on 8/17/2017 with cutoff this Sunday (branches will be locked).
17:27:40 <skitt> #info Carbon release next week
17:27:49 <anipbu> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/buildTimeTrend   <--- We have not had a successful build of Carbon since July 27
17:28:08 <anipbu> #link https://bugs.opendaylight.org/show_bug.cgi?id=8941   <--- Pending One Blocker Bug for Carbon SR2
17:28:12 <rovarga_> zxiiro: awesome, thanks :)
17:29:48 <skitt> #topic Nitrogen
17:30:10 <skitt> #info 43 projects in Nitrogen
17:30:32 <skitt> #info 5 not in the distribution yet: gbp, snmp, faas, + 2 leaf projects
17:30:49 <skitt> #info M5 is August 14, which is also RC0
17:31:01 <anipbu> https://jenkins.opendaylight.org/releng/view/CLM/
17:33:10 <gilesheron> #info if gbp removes its dependency on faas then faas becomes a leaf and can be dropped
17:35:16 <skitt> #info gbp no longer depends on faas
17:36:30 <skitt> #action gzhao to reach out to the faas team
17:36:53 <skitt> #info no successful autorelease for quite a while
17:37:23 <gzhao> skitt: thanks
17:37:39 <skitt> gzhao, you're welcome
17:41:07 <abhijitkumbhare> CaseyODL: at the center of the page https://www.opendaylight.org/about/governance/tsc there is a link to “White Paper: “OpenDaylight: An Open Source Community and Meritocracy for Software-Defined Networking”. This link points to https://www.opendaylight.org/news/foundation-news/2013/04/opendaylight-open-source-community-and-meritocracy-software-defined. When you click the link you get a “404 not
17:41:08 <abhijitkumbhare> found”.
17:41:14 <skitt> #info odlparent needs to settle on a final Nitrogen version
17:41:23 <skitt> #info all projects need to upgrade and we need to track this
17:42:52 <abhijitkumbhare> CaseyODL: of course the white paper may be obsolete now
17:44:53 <skitt> #info odlparent 2.0.4 can be used as the final version for Nitrogen, barring bugs
17:45:17 <skitt> #info if any SFT-related change is necessary, its impact can be limited to integration/distribution
17:46:18 <skitt> #link patches for projects to migrate to 2.0.4: https://git.opendaylight.org/gerrit/#/q/topic:odlparent-2.0.4
17:50:33 <skitt> #info ultimately, micro-version bumps should happen automatically (once we have appropriate sanity tests)
17:52:39 <skitt> #info distribution-check is obsolete on every patch in odlparent-style projects, it's only needed on releases
17:52:48 <skitt> #topic System Integration and Testing
17:53:07 <skitt> #info lack of committers on int/dist
17:55:58 <skitt> #info suggestion to grant zxiiro rights to merge patches in int/dist
17:56:05 <skitt> #info but that goes against project sovereignty
17:57:26 <skitt> #info projects are governed by their committers
17:57:43 <skitt> #info the TSC can only step in when solicited by projects
18:01:13 <skitt> #action jamoluhrsen to ask edwarnicke to vote to grant zxiiro committer rights (temporarily)
18:01:33 <skitt> #info reminder about the resource thread
18:02:07 <gilesheron> #info Ed is offline until Monday I think?
18:02:14 <jamoluhrsen> is the scope for zxiiro's merge status strict? around adding projects/features to int/dist? or any patches?
18:02:32 <jamoluhrsen> if Ed is offline until Monday, the problem is still there.
18:02:50 <zxiiro> jamoluhrsen: the stricter the better. Blanket permissions are dangerous
18:03:29 <dfarrell07> the common point we need to figure out is what happens when a project is blocking the release
18:03:37 <dfarrell07> and if the TSC can do something about that
18:03:56 <rovarga_> dfarrell07: yup, drop that project out of SR :)
18:04:09 <rovarga_> this exactly is the reason we have to kill autorelease asap
18:04:23 <dfarrell07> rovarga_: not so easy for int/dist ;)
18:04:27 <rovarga_> centralized things exert pressure to have centralized control
18:05:00 <skitt> #info we might need to delay the release
18:05:04 <rovarga_> dfarrell07: well.. do we have people willing to contribute time and care to become committers?
18:05:40 <skitt> #info same issue with the docs project
18:05:44 <dfarrell07> rovarga_: vratko talked about that on int/* call, he "has ideas" that we ran out of time to talk about
18:06:24 <skitt> #action skitt to start committer votes
18:06:27 <skitt> #topic Cookies
18:06:40 <skitt> #endmeeting