#opendaylight-meeting: kernel

Meeting started by vorburger at 17:04:32 UTC (full logs).

Meeting summary

  1. Agenda? (vorburger, 17:04:38)
    1. Fluorine SR1, Oxygen SR4 (vorburger, 17:04:58)
    2. skitt mentions that the requirement is a passing autorelease for Fluorine SR1 (vorburger, 17:06:09)
    3. Oxygen SR4 needs to bee updated to carry yangtools-2.0.6.5 (rovarga, 17:07:34)
    4. the projects affected are bgpcep, controller, mdsal, netconf, sxp, and int/dist (skitt, 17:07:59)
    5. ACTION: skitt to file a bug in int/dist to determine whether to complete or remove feature-repos (skitt, 17:12:50)
    6. ACTION: skitt to file a bug in int/dist to migrate to artifact POMs (skitt, 17:13:00)

  2. new PingPongDataBroker interface for simpler annotation instead of XML based dependency injection? (vorburger, 17:14:56)
    1. https://lists.opendaylight.org/pipermail/controller-dev/2018-November/014678.html (vorburger, 17:15:50)
    2. @Named ? (vorburger, 17:19:15)
    3. @Qualifier in CDI and Spring (vorburger, 17:19:40)
    4. @Filter for Blueprint annotation (vorburger, 17:19:50)
    5. grep for "filter" in https://osgi.org/xmlns/blueprint/v1.0.0/blueprint.xsd (vorburger, 17:22:09)
    6. http://aries.apache.org/modules/blueprint.html "Example showing use of filter" - empty ;-) (vorburger, 17:22:56)

  3. Any other business? (vorburger, 17:23:07)
  4. Annotations, other, in general? (vorburger, 17:23:59)
    1. both JSR 305 javax.annotation, e.g. @NonNull, and CDI e.g. @PostDestroy are in javax.annotation, which is a problem in OSGi (vorburger, 17:25:30)
    2. SpotBugs has their own, see link (vorburger, 17:26:37)
    3. https://github.com/spotbugs/spotbugs/tree/release-3.1/spotbugs-annotations/src/main/java/edu/umd/cs/findbugs/annotations (vorburger, 17:26:38)
    4. SpotBugs struggles with other annotations, specifically TYPE_USE type annotations (vorburger, 17:28:11)
    5. https://github.com/google/error-prone/issues/1158 (rovarga, 17:30:42)
    6. so we should just drop null analysis with SpotBugs (vorburger, 17:34:19)
    7. we could instead of NullAway or vorburger's http://www.lastnpe.org (TBD TBC) (vorburger, 17:34:36)
    8. skitt and rovarga mention that NullAway is an Error-Prone plugin, but that EP is NOK on Java 11 :-( (vorburger, 17:35:00)
    9. but we could just skip EP while we build on Java 11 until that's supported (vorburger, 17:35:18)
    10. ACTION: skitt to check that the null features in SpotBugs are disabled (skitt, 17:38:55)
    11. ACTION: skitt to send an email to discuss@ to start the discussion on what features we want from EP (skitt, 17:39:39)
    12. ACTION: vorburger pick up https://git.opendaylight.org/gerrit/#/c/63838/ some day when time (not immediate future), and compare it to NullAway (vorburger, 17:39:54)

  5. exists() support in mdsal (vorburger, 17:44:03)
    1. available in DOM API but not exposed in the Binding DataBroker (vorburger, 17:44:18)
    2. ACTION: rovarga is filing and issue to add that (vorburger, 17:44:33)

  6. Web components move from AAA to infrautils? (vorburger, 17:46:49)
    1. rovarga objects to Web components move from AAA to infrautils, and aaa and netconf for restconf thus becoming dependant on infrautils for the web components, because it would prevent moving aaa and netconf to move to MRI (vorburger, 17:57:55)
    2. vorburger is not a fan of more projects becoming MRI (but that wasn't the question here) (vorburger, 17:58:23)
    3. ergo Web components shall not move from AAA to infrautils in the short term (vorburger, 17:58:43)
    4. if aaa and netconf move to MRI in Neon then we could revisit this discussion (seeing if infrautils becomes MRI as well) (vorburger, 17:59:35)


Meeting ended at 17:59:48 UTC (full logs).

Action items

  1. skitt to file a bug in int/dist to determine whether to complete or remove feature-repos
  2. skitt to file a bug in int/dist to migrate to artifact POMs
  3. skitt to check that the null features in SpotBugs are disabled
  4. skitt to send an email to discuss@ to start the discussion on what features we want from EP
  5. vorburger pick up https://git.opendaylight.org/gerrit/#/c/63838/ some day when time (not immediate future), and compare it to NullAway
  6. rovarga is filing and issue to add that


Action items, by person

  1. rovarga
    1. rovarga is filing and issue to add that
  2. skitt
    1. skitt to file a bug in int/dist to determine whether to complete or remove feature-repos
    2. skitt to file a bug in int/dist to migrate to artifact POMs
    3. skitt to check that the null features in SpotBugs are disabled
    4. skitt to send an email to discuss@ to start the discussion on what features we want from EP
  3. vorburger
    1. vorburger pick up https://git.opendaylight.org/gerrit/#/c/63838/ some day when time (not immediate future), and compare it to NullAway


People present (lines said)

  1. vorburger (34)
  2. skitt (5)
  3. odl_meetbot (4)
  4. rovarga (2)


Generated by MeetBot 0.1.4.