16:03:13 <skitt> #startmeeting kernel projects
16:03:13 <odl_meetbot> Meeting started Tue Sep  4 16:03:13 2018 UTC.  The chair is skitt. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:13 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:13 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:03:33 <skitt> #chair vorburger rovarga
16:03:33 <odl_meetbot> Current chairs: rovarga skitt vorburger
16:05:03 <skitt> #info we need to go over the kernel projects which will be involved in MRI
16:09:00 <skitt> #info migration: odlparent 4 involves lots of changes, but mostly mechanical, and will be documented
16:09:17 <skitt> #info yangtools might require changes to application logic around empty list handling
16:10:00 <skitt> #info empty lists will disappear along with the parent hierarchy which becomes empty
16:10:06 <skitt> #info this also applies to choices and augmentations
16:10:39 <skitt> #action skitt to initiate the migration wiki page
16:11:36 <skitt> #info md-sal involves migrating Optional (but many projects will be shielded by controller) and a few other changes
16:12:50 <skitt> #action vorburger to build a timeline of project patches by filing bugs with deadlines
16:15:10 <skitt> #info bump patch merges are scheduled to occur between Oct 6 and 19
16:15:53 <skitt> #link pending patches for odlparent: https://git.opendaylight.org/gerrit/#/q/project:odlparent+status:open
16:17:12 <skitt> #action to start a thread on odlparent-dev to go over pending patches
16:25:25 <skitt> #info ODLPARENT-161, the issue around SpotBugs and Guava nullable annotations, is a big issue
16:25:30 <skitt> #info but not a blocker for 4.0.0
16:25:39 <skitt> #info it will be documented and fixed ASAP in a patch release
16:25:45 <vorburger> #info due to a problem with SpotBugs and Guava we recommend projects stay on FindBugs until this is solved
16:25:55 <skitt> #info note that this stops us from running static analysis on JDK 9+
16:27:13 <vorburger> #info rovarga put in a change which deactivates FindBugs on JDK 9+ so this doesn't block us from further exploring building and running ODL on JDK 9+
16:27:58 <vorburger> #topic Clustering
16:28:08 <vorburger> #info nothing in particular today, says shague
16:28:39 <skitt> #endmeeting