#opendaylight-meeting: Kernel Projects call

Meeting started by rovarga at 17:06:03 UTC (full logs).

Meeting summary

  1. odlparent-5.0.0 (rovarga, 17:06:08)
    1. https://jira.opendaylight.org/projects/ODLPARENT/versions/10825 is the tracker (rovarga, 17:06:16)
    2. most of the targeted issues are in review (rovarga, 17:06:27)
    3. there are couple of patches we want in 4.0.10, will wait for them to land before branching (rovarga, 17:06:44)
    4. not sure about https://jira.opendaylight.org/browse/ODLPARENT-176 (rovarga, 17:08:26)
    5. the bundle name is useful in general (rovarga, 17:08:37)
    6. and this can always be tuned in a particular deployment (rovarga, 17:08:49)
    7. most notably, high-log-deployments will probably end up using logstash or something of that kind to capture the logs (and sift through them) (rovarga, 17:09:17)

  2. karaf-4.2.3 (rovarga, 17:16:27)
    1. karaf-4.2.3 bumps javax.annotation version to 1.3.0 (rovarga, 17:16:41)
    2. and multipatch fails of the dreaded package resolution conflicts (rovarga, 17:19:08)
    3. we may need to postpone 4.2.4 upgrade until we have sorted out oour JSR305 story, at least in APIs (rovarga, 17:19:28)

  3. RFC8040 and filter (rovarga, 17:19:43)
    1. the question is whether the new RESTCONF supports https://tools.ietf.org/html/rfc8040#section-4.8.4 filters (rovarga, 17:20:42)
    2. RFC8040 seems to specify filters only for notification streams, not for individual GETs (rovarga, 17:26:34)
    3. since they are XPath based, we are pretty sure they are not implemented for GETs even as an extension (rovarga, 17:26:54)

  4. multipatch issues (rovarga, 17:27:22)
    1. the problem is with topic=fooBar, where the latest tag is checked out and the patches are checked out on it (rovarga, 17:28:54)
    2. for odlparent master patches cannot been cherry-picked on top of odlparent-4.0.9 tag (rovarga, 17:29:12)
    3. https://jenkins.opendaylight.org/releng/view/integration/job/integration-multipatch-test-sodium/9/ (rovarga, 17:29:59)
    4. the best thing would be to introduce topic:foo to perform a checkout (rovarga, 17:33:24)
    5. ACTION: LuisGomez will try to come up with a solution for odlparent only (rovarga, 17:34:13)

  5. tell-based protocol (rovarga, 17:36:10)
    1. ofp testing is still stuck on topology links not being torn down (rovarga, 17:36:41)
    2. functional testing has only this issue outstanding (rovarga, 17:37:46)
    3. https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-3node-clustering-perf-bulkomatic-only-neon/ (LuisGomez, 17:39:06)
    4. we have a failure with performance jobs, but that may need tweaking (rovarga, 17:40:58)
    5. it seems that switching to tell-based protocol by default is feasible in Sodium timeframe (rovarga, 17:45:04)

  6. NETCONF scale testing (rovarga, 17:47:46)
    1. jmorvay asks about scaling of SB devices (rovarga, 17:47:59)
    2. for a simple test tool, I could attach 10K sessions with 965MiB retained heap (rovarga, 17:48:27)
    3. for stable/neon (rovarga, 17:48:37)
    4. with sshd-core-2.2.0 (staged at https://git.opendaylight.org/gerrit/#/c/76300/) I could attach 10K sessions with 744MiB retained heap (rovarga, 17:49:27)
    5. Bala reports similar results with 10GiB heap and a real device (rovarga, 17:49:57)
    6. real device == ~70 YANG models (rovarga, 17:50:14)
    7. https://jira.opendaylight.org/browse/NETCONF-590 tracks transport layer rework (rovarga, 17:53:02)
    8. which blocks https://jira.opendaylight.org/browse/NETCONF-571 (rovarga, 17:53:38)
    9. which is about 50% of our current static steady-state memory overhead (not counting SchemaContext overheads) (rovarga, 17:56:28)

  7. anyxml handling in get-config (rovarga, 17:57:47)
    1. Bala reports that it did not seem to work in Carbon (rovarga, 17:57:59)
    2. it may be a missing bit in yangtools codecs, where we do not handle one of the directions (rovarga, 17:58:30)
    3. will follow up after testing a recent version (rovarga, 17:58:45)


Meeting ended at 17:58:58 UTC (full logs).

Action items

  1. LuisGomez will try to come up with a solution for odlparent only


Action items, by person

  1. LuisGomez
    1. LuisGomez will try to come up with a solution for odlparent only


People present (lines said)

  1. rovarga (43)
  2. odl_meetbot (3)
  3. LuisGomez (2)


Generated by MeetBot 0.1.4.