#opendaylight-openflowplugin: OpenFlow Plugin Meeting March 7 2016

Meeting started by abhijitkumbhare at 17:01:43 UTC (full logs).

Meeting summary

  1. Agenda (abhijitkumbhare, 17:02:12)
    1. Lithium Design Migration & blocking issues for the migration (abhijitkumbhare, 17:03:00)
    2. DDF (abhijitkumbhare, 17:03:20)
    3. Boron planning (abhijitkumbhare, 17:03:40)
    4. Top issues (abhijitkumbhare, 17:03:59)
    5. Committer Promotion (abhijitkumbhare, 17:04:46)

  2. Top issues (abhijitkumbhare, 17:07:36)
    1. Group Delete (abhijitkumbhare, 17:07:57)
    2. Group Delete behavior has changed in OpenFlow 1.3.5 (abhijitkumbhare, 17:09:09)
    3. ODL behavior is as per 1.3.1 (abhijitkumbhare, 17:09:36)
    4. OVS spec may be following 1.3.5 (abhijitkumbhare, 17:10:09)
    5. vishnoianil thinks OVS should be backward compatible to 1.3.1 even if OVS is following 1.3.5 (abhijitkumbhare, 17:11:44)
    6. More investigation needed (abhijitkumbhare, 17:12:34)
    7. Muthu / Shuva will try with the ID based delete and check if that works across the different versions of OVS (abhijitkumbhare, 17:13:52)
    8. Luis will try a candidate patch with HW switches in Brocade (LuisGomez, 17:14:28)

  3. Blockers for Lithium migration (abhijitkumbhare, 17:15:32)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=5328 OpenFlow 1.0 (abhijitkumbhare, 17:16:58)
    2. The OpenFlow 1.0 issue has been fixed (abhijitkumbhare, 17:17:16)
    3. https://bugs.opendaylight.org/show_bug.cgi?id=5388 Cluster issue: Flow push does not work after owner instance is killed (abhijitkumbhare, 17:18:19)
    4. This has been fixed (abhijitkumbhare, 17:18:34)
    5. ACTION: jbacigal to add gerritt ID in the bug - OR mark it as duplicate of 5075 (abhijitkumbhare, 17:19:50)
    6. https://bugs.opendaylight.org/show_bug.cgi?id=5271 Stability issue: Longevity test (abhijitkumbhare, 17:20:28)
    7. This fix is needed but not a blocker (abhijitkumbhare, 17:20:42)
    8. This issue is intermittent (abhijitkumbhare, 17:21:42)
    9. ACTION: LuisGomez to observe 5271 and update (abhijitkumbhare, 17:22:16)
    10. https://bugs.opendaylight.org/show_bug.cgi?id=4925 Clustering: OpenFlow connections unstable (abhijitkumbhare, 17:23:26)
    11. ACTION: Muthu To have 4925 tested with the latest stable/beryllium & master builds and report back (abhijitkumbhare, 17:24:23)

  4. Lithium Design Migration (abhijitkumbhare, 17:25:10)
    1. The migration to happen for Boron (but we need to get the projects migrated as soon as possible on the master); Beryllium Service Releases will keep the default as the Helium design (abhijitkumbhare, 17:28:47)
    2. Flip the default to Lithium design - strategy? (abhijitkumbhare, 17:30:24)
    3. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan (hideyuki, 17:43:41)
    4. AGREED: OFP will create an unmerged patch to flip the default (abhijitkumbhare, 17:50:07)
    5. AGREED: The dependent projects should use this patch to fix issues by M1 offset 2 (March 24) (abhijitkumbhare, 17:51:00)
    6. AGREED: If no outstanding issues - the patch will be merged to make the Li design as the default (abhijitkumbhare, 17:51:38)
    7. AGREED: OFP will issue a weather report for this by March 9 (abhijitkumbhare, 17:52:06)

  5. Committer Promotion (abhijitkumbhare, 17:54:49)
    1. Abhijit will first discuss with the committers & interested folks (Jozef) over email the process before starting a vote on the mailing lists (abhijitkumbhare, 17:57:18)

  6. Bugs raised by projects during Lithium migration (abhijitkumbhare, 17:58:24)
    1. AGREED: Should be marked blockers and fixed with a priority (abhijitkumbhare, 17:58:46)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=5432 (hideyuki, 17:59:24)
    3. https://bugs.opendaylight.org/show_bug.cgi?id=4671 (hideyuki, 18:00:18)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=5432 Li: Enable "get-flow-statistics-from-flow-table" RPC by default (abhijitkumbhare, 18:00:31)
    5. Anna will work with Michal and jbacigal (abhijitkumbhare, 18:02:57)

  7. Boron Planning (abhijitkumbhare, 18:03:57)
    1. ACTION: jbacigal vishnoianil kamalr Muthu everyone - please come up with your contribution ideas for Boron for next meeting (abhijitkumbhare, 18:10:22)
    2. The Boron planning may need 2-3 meetings more (abhijitkumbhare, 18:11:34)


Meeting ended at 18:11:40 UTC (full logs).

Action items

  1. jbacigal to add gerritt ID in the bug - OR mark it as duplicate of 5075
  2. LuisGomez to observe 5271 and update
  3. Muthu To have 4925 tested with the latest stable/beryllium & master builds and report back
  4. jbacigal vishnoianil kamalr Muthu everyone - please come up with your contribution ideas for Boron for next meeting


Action items, by person

  1. jbacigal
    1. jbacigal to add gerritt ID in the bug - OR mark it as duplicate of 5075
    2. jbacigal vishnoianil kamalr Muthu everyone - please come up with your contribution ideas for Boron for next meeting
  2. kamalr
    1. jbacigal vishnoianil kamalr Muthu everyone - please come up with your contribution ideas for Boron for next meeting
  3. LuisGomez
    1. LuisGomez to observe 5271 and update
  4. vishnoianil
    1. jbacigal vishnoianil kamalr Muthu everyone - please come up with your contribution ideas for Boron for next meeting


People present (lines said)

  1. abhijitkumbhare (49)
  2. odl_meetbot (6)
  3. hideyuki (3)
  4. LuisGomez (1)
  5. kamalr (0)
  6. jbacigal (0)
  7. vishnoianil (0)


Generated by MeetBot 0.1.4.