#opendaylight-openflowplugin: OpenFlow Plugin Meeting April 27, 2017

Meeting started by abhijitkumbhare at 15:03:36 UTC (full logs).

Meeting summary

  1. Agenda (abhijitkumbhare, 15:04:14)
    1. Karaf 3, Karaf 4 and OpenFlow Plugin status (abhijitkumbhare, 15:06:08)
    2. Issues (abhijitkumbhare, 15:07:02)

  2. Issues: Bug 6459 (abhijitkumbhare, 15:08:11)
    1. jbacigal wanting to know how to delete the node once the Karaf instance killed (abhijitkumbhare, 15:11:02)
    2. vishnoianil provided suggestion on how to handle this (abhijitkumbhare, 15:16:45)

  3. Plug & play frameworks / features (abhijitkumbhare, 15:25:38)
    1. Sometimes different use cases need different optimizations - whether for performance or for stability or some other metric (abhijitkumbhare, 15:28:03)
    2. Suggestion is to have different possible plug & play components for select features (abhijitkumbhare, 15:28:30)
    3. Needs more discussion for Nitrogen, etc. (abhijitkumbhare, 15:29:03)

  4. Karaf3, Karaf4 & OpenFlow Plugin (abhijitkumbhare, 15:37:41)
    1. Some issues but not in OFP (abhijitkumbhare, 15:38:22)
    2. Issues in RESTCONF (abhijitkumbhare, 15:38:33)
    3. Not sure we have Karaf 4 issues - as there are issues in other projects - we cannot even run OFP in Karaf 4 (abhijitkumbhare, 15:40:17)
    4. Not able to run Plugin in Karaf4 - feature install being restarted from RESTCONF or MDSAL (abhijitkumbhare, 15:41:24)

  5. Bugs (abhijitkumbhare, 15:43:42)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=6755 (abhijitkumbhare, 15:44:37)
    2. Bug 6755: Perf test 100K flow installation does not not work in Cluster (abhijitkumbhare, 15:45:23)
    3. Possible performance regression - Jozef will take a look at it next week (abhijitkumbhare, 15:46:10)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=6908 Bug 6908 - failed to update port status - all new OVS ports fail from this point (abhijitkumbhare, 15:46:49)
    5. Bug 6908 - failed to update port status - all new OVS ports fail from this point (abhijitkumbhare, 15:46:56)
    6. tomasslusny has a patch for this - vishnoianil reviewing this (abhijitkumbhare, 15:47:45)
    7. https://bugs.opendaylight.org/show_bug.cgi?id=7184 (abhijitkumbhare, 15:48:25)
    8. Bug 7184 - [Boron] Switch connection sometimes bounces on non-owner node when OWNER is shut down (abhijitkumbhare, 15:48:29)
    9. Luis thinks this is better with Carbon - maybe related split connection handler (abhijitkumbhare, 15:49:18)
    10. https://bugs.opendaylight.org/show_bug.cgi?id=7763 (abhijitkumbhare, 15:49:31)
    11. Bug 7763 - Openflow plugin deletes switch from topology while changing mastership from one controller to another (abhijitkumbhare, 15:49:48)
    12. ACTION: jbacigal to update the bug status for bug 7763 https://bugs.opendaylight.org/show_bug.cgi?id=7763 (abhijitkumbhare, 15:51:42)
    13. https://bugs.opendaylight.org/show_bug.cgi?id=7948 (abhijitkumbhare, 15:51:55)
    14. Bug 7948 - br-sfc become slave and disconnect from ODL (abhijitkumbhare, 15:52:09)
    15. Bug 7948 is somewhere in MD-SAL (abhijitkumbhare, 15:54:19)
    16. ACTION: jbacigal to check with the MD-SAL folks (abhijitkumbhare, 15:54:34)
    17. https://bugs.opendaylight.org/show_bug.cgi?id=7957 (abhijitkumbhare, 15:55:36)
    18. Bug 7957 - OF channel fail/recover does not work when FRM config is modified (abhijitkumbhare, 15:55:48)
    19. Apparently fixed with split connection (abhijitkumbhare, 15:56:02)
    20. https://bugs.opendaylight.org/show_bug.cgi?id=8057 (abhijitkumbhare, 15:57:01)
    21. Bug 8057 - Missing rules after OVS restart - even though they exist in config/inventory-nodes (abhijitkumbhare, 15:57:17)
    22. https://bugs.opendaylight.org/show_bug.cgi?id=8103 (abhijitkumbhare, 15:59:21)
    23. Bug 8103 - Switch scalability regression due to missing table miss flows (abhijitkumbhare, 15:59:33)
    24. Assigned to Arun for now - but cc’ed to vishnoianil . If Arun is stuck - we can have vishnoianil take a look (abhijitkumbhare, 16:03:21)
    25. https://bugs.opendaylight.org/show_bug.cgi?id=8245 (abhijitkumbhare, 16:04:54)
    26. Bug 8245 - No OF rules after ODL sync (abhijitkumbhare, 16:05:06)
    27. Most likely: working as designed (abhijitkumbhare, 16:05:29)


Meeting ended at 16:06:12 UTC (full logs).

Action items

  1. jbacigal to update the bug status for bug 7763 https://bugs.opendaylight.org/show_bug.cgi?id=7763
  2. jbacigal to check with the MD-SAL folks


People present (lines said)

  1. abhijitkumbhare (49)
  2. odl_meetbot (5)


Generated by MeetBot 0.1.4.