#opendaylight-openflowplugin: OpenFlow Plugin Meeting Jan 12, 2017

Meeting started by abhijitkumbhare at 16:06:47 UTC (full logs).

Meeting summary

  1. Agenda (abhijitkumbhare, 16:07:02)
    1. M3 status (abhijitkumbhare, 16:07:42)
    2. Documentation & wiki (abhijitkumbhare, 16:08:16)
    3. Config knobs (abhijitkumbhare, 16:12:52)
    4. Direct RPC stats (abhijitkumbhare, 16:13:21)
    5. Code Reviews & bugs (abhijitkumbhare, 16:13:52)

  2. M3 status (abhijitkumbhare, 16:14:11)
    1. Discussion about what functionality freeze means - the definition available on the ODL Carbon release plan (abhijitkumbhare, 16:28:47)
    2. “Split connection layer from core” status - mostly done & being tested. Couple of patches may be needed. Code review needs to be done for this by vishnoianil & shuva. (abhijitkumbhare, 16:29:53)
    3. ACTION: jbacigal1 needs to add vishnoianil & shuva to the code reviewer list for his patches for “Split connection layer from core" (abhijitkumbhare, 16:30:39)
    4. “Southbound Manager” status - shuva will send an email about the functionality of this and request for code review (abhijitkumbhare, 16:31:40)
    5. ACTION: shuva to send an email about the functionality of this and request for code review about “Southbound Manager" (abhijitkumbhare, 16:32:16)
    6. Usability improvements - will be discussed under the config knobs (abhijitkumbhare, 16:33:01)

  3. Config knobs (abhijitkumbhare, 16:33:20)
    1. Currently config options in yang files as well as in the cfg file - which do not map one to one (abhijitkumbhare, 16:34:10)
    2. Also this hybrid approach can cause some race conditions (abhijitkumbhare, 16:35:45)
    3. https://git.opendaylight.org/gerrit/#/c/44386/ (shuva, 16:41:34)
    4. ACTION: shuva to initiate a discussion on the relative merits of the config knob approaches as well as how to resolve this. This needs to be resolved before M4. (abhijitkumbhare, 16:50:57)

  4. Documentation & wiki (abhijitkumbhare, 16:51:27)
    1. shuva suggests removing the wiki references/info to be changed to the Lithium design and keep the archived documentation accessible (abhijitkumbhare, 16:52:39)

  5. Direct RPC stats (abhijitkumbhare, 16:53:49)
    1. Tomas says needs some augmentations (abhijitkumbhare, 16:54:52)

  6. Other topics (abhijitkumbhare, 16:57:40)
    1. Review the patch 40817 (abhijitkumbhare, 16:57:55)
    2. https://git.opendaylight.org/gerrit/#/c/40817/ (abhijitkumbhare, 16:58:05)


Meeting ended at 17:02:29 UTC (full logs).

Action items

  1. jbacigal1 needs to add vishnoianil & shuva to the code reviewer list for his patches for “Split connection layer from core"
  2. shuva to send an email about the functionality of this and request for code review about “Southbound Manager"
  3. shuva to initiate a discussion on the relative merits of the config knob approaches as well as how to resolve this. This needs to be resolved before M4.


Action items, by person

  1. shuva
    1. jbacigal1 needs to add vishnoianil & shuva to the code reviewer list for his patches for “Split connection layer from core"
    2. shuva to send an email about the functionality of this and request for code review about “Southbound Manager"
    3. shuva to initiate a discussion on the relative merits of the config knob approaches as well as how to resolve this. This needs to be resolved before M4.


People present (lines said)

  1. abhijitkumbhare (27)
  2. odl_meetbot (4)
  3. shuva (3)
  4. hideyuki (1)


Generated by MeetBot 0.1.4.