#opendaylight-openflowplugin: OpenFlow Plugin Meeting March 23, 2017

Meeting started by abhijitkumbhare at 15:08:25 UTC (full logs).

Meeting summary

  1. Agenda (abhijitkumbhare, 15:09:12)
    1. Major issues (abhijitkumbhare, 15:09:29)
    2. Patches to be merged for the Carbon features (abhijitkumbhare, 15:10:03)
    3. Blocker Bugs (abhijitkumbhare, 15:11:56)
    4. Mastership service (abhijitkumbhare, 15:17:22)

  2. Mastership service (abhijitkumbhare, 15:17:49)
    1. Potential solution for the clustering issues (abhijitkumbhare, 15:18:06)
    2. Write the wiki, run the tests, review the patch & then decide if this is too risky or should be included in Carbon (abhijitkumbhare, 15:20:02)

  3. Blocker Bugs (abhijitkumbhare, 15:20:40)
    1. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&list_id=75949&product=openflowplugin&query_format=advanced&resolution=--- (abhijitkumbhare, 15:21:47)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=6459 [Li plugin] Reconciliation not triggering after a single node reboot in a non OFHA scenario (abhijitkumbhare, 15:23:37)
    3. https://git.opendaylight.org/gerrit/53532 (vishnoianil, 15:32:22)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=6908 Assigned to Tomas Slusny for review (abhijitkumbhare, 15:36:55)
    5. https://bugs.opendaylight.org/show_bug.cgi?id=6908 Flow matching function (operational flow reconciliation) is not stable (abhijitkumbhare, 15:38:59)
    6. Patch https://git.opendaylight.org/gerrit/#/c/53545/ has been cherry picked - needs to be merged (abhijitkumbhare, 15:39:39)
    7. ACTION: abhijitkumbhare to ask the release team to get https://bugs.opendaylight.org/show_bug.cgi?id=6917 in Boron SR 3 (abhijitkumbhare, 15:41:53)
    8. ACTION: vishnoianil to merge https://git.opendaylight.org/gerrit/#/c/53545/ once https://bugs.opendaylight.org/show_bug.cgi?id=6917 is raised as a blocker (abhijitkumbhare, 15:43:02)
    9. https://bugs.opendaylight.org/show_bug.cgi?id=7184 [Boron] Switch connection sometimes bounces on non-owner node when OWNER is shut down (abhijitkumbhare, 15:44:15)
    10. 7184 related to connection layer issues - and will get fixed once split connection handler issues is merged (abhijitkumbhare, 15:46:27)
    11. https://bugs.opendaylight.org/show_bug.cgi?id=7763 Openflow plugin deletes switch from topology while changing mastership from one controller to another (abhijitkumbhare, 15:47:41)
    12. 7763 needs to be fixed in master (abhijitkumbhare, 15:49:10)
    13. https://bugs.opendaylight.org/show_bug.cgi?id=7770 Only 1 cluster instance is able to push table miss flow after initial switch connection (abhijitkumbhare, 15:49:25)
    14. Miroslav fix (https://git.opendaylight.org/gerrit/#/c/52115/) needs to be revisited as there is a -1 (abhijitkumbhare, 15:53:41)
    15. Fix should not depend on the new mastership service (abhijitkumbhare, 15:55:00)

  4. Mastership service (contd) (abhijitkumbhare, 15:56:59)
    1. https://git.opendaylight.org/gerrit/#/c/53713/ (abhijitkumbhare, 15:57:05)
    2. Above patch for mastership service - needs some more changes for FRM & FRS (abhijitkumbhare, 15:57:46)
    3. https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-1node-flow-services-frs-only-carbon/ (LuisGomez, 16:00:29)


Meeting ended at 16:09:42 UTC (full logs).

Action items

  1. abhijitkumbhare to ask the release team to get https://bugs.opendaylight.org/show_bug.cgi?id=6917 in Boron SR 3
  2. vishnoianil to merge https://git.opendaylight.org/gerrit/#/c/53545/ once https://bugs.opendaylight.org/show_bug.cgi?id=6917 is raised as a blocker


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare to ask the release team to get https://bugs.opendaylight.org/show_bug.cgi?id=6917 in Boron SR 3
  2. vishnoianil
    1. vishnoianil to merge https://git.opendaylight.org/gerrit/#/c/53545/ once https://bugs.opendaylight.org/show_bug.cgi?id=6917 is raised as a blocker


People present (lines said)

  1. abhijitkumbhare (31)
  2. odl_meetbot (5)
  3. LuisGomez (1)
  4. vishnoianil (1)
  5. Hema_ (0)
  6. tomasslusny (0)
  7. jbacigal (0)


Generated by MeetBot 0.1.4.