#opendaylight-openflowplugin: OpenFlow Plugin Meeting March 30, 2017

Meeting started by abhijitkumbhare at 15:03:09 UTC (full logs).

Meeting summary

  1. Agenda (abhijitkumbhare, 15:04:00)
    1. High Priority Issues (abhijitkumbhare, 15:04:47)
    2. Status of feature merges (abhijitkumbhare, 15:05:26)

  2. Status of feature merges (abhijitkumbhare, 15:07:41)
    1. Unmerged features are: (abhijitkumbhare, 15:08:50)
    2. * Split Connection Handler (abhijitkumbhare, 15:09:11)
    3. https://git.opendaylight.org/gerrit/#/q/status:open+project:openflowplugin+branch:master+topic:%22Split+connection+layer+...%22 (shuva, 15:09:15)
    4. * Bundles (abhijitkumbhare, 15:09:25)
    5. * Mastership service (abhijitkumbhare, 15:09:45)
    6. Aligning the config knobs yang & config file (abhijitkumbhare, 15:10:30)
    7. https://git.opendaylight.org/gerrit/#/c/53862/ (shuva, 15:11:13)
    8. https://bugs.opendaylight.org/show_bug.cgi?id=7218 (tomasslusny, 15:11:56)
    9. https://git.opendaylight.org/gerrit/#/c/53630/ (shuva, 15:13:04)
    10. ACTION: shuva to review & merge bug 7218 changes from Hema & Tomas after the build succeeds (abhijitkumbhare, 15:16:18)
    11. shuva reviewing the split connection layer patches (abhijitkumbhare, 15:17:31)
    12. Higher priority to get the split connection handler patches merged (abhijitkumbhare, 15:20:30)
    13. Mastership service merge should be lower priority - and of course make sure all the clustering is stable - otherwise move it to Nitrogen (abhijitkumbhare, 15:21:21)
    14. We will merge bundles after the branch cutoff (abhijitkumbhare, 15:26:33)

  3. High Priority issues: needed by NetVirt (abhijitkumbhare, 15:27:43)
    1. Issue 1: https://bugs.opendaylight.org/show_bug.cgi?id=8025 (abhijitkumbhare, 15:29:22)
    2. - group+flow installation dependency missing API, similar for flow+packet_out - this forces us to add sleeps which are problematic and will not scale well (abhijitkumbhare, 15:29:35)
    3. shuva lists a few options for this: (abhijitkumbhare, 15:31:22)
    4. FRS could be used - but FRS not well tested (abhijitkumbhare, 15:32:08)
    5. Southbound Manager by shuva (abhijitkumbhare, 15:32:47)
    6. ACTION: shuva will respond on the bug 8025 on the different options including working around (abhijitkumbhare, 15:34:05)
    7. ACTION: Hema__ will also discuss with the NetVirt folks about 8025 (abhijitkumbhare, 15:35:44)
    8. Issue 2: https://bugs.opendaylight.org/show_bug.cgi?id=8057 (abhijitkumbhare, 15:36:25)
    9. - some flows missing after OVS restart - critical for OVS failure recovery (abhijitkumbhare, 15:36:30)
    10. ACTION: jbacigal looking at bug 8057 with the split connection layer handling (abhijitkumbhare, 15:38:22)
    11. Issue 3: https://bugs.opendaylight.org/show_bug.cgi?id=8087 (dup https://bugs.opendaylight.org/show_bug.cgi?id=7948 ?) (abhijitkumbhare, 15:38:50)
    12. - The bug seen in CSIT (total failure, OVS does not connect to ODL) (abhijitkumbhare, 15:39:08)
    13. jbacigal thinks bug 8087 will be solved by the split connection handler - and does not see it with the split connection handler (abhijitkumbhare, 15:40:23)
    14. ACTION: jbacigal to follow up on bug 8087 (abhijitkumbhare, 15:41:00)
    15. Issue 4: https://bugs.opendaylight.org/show_bug.cgi?id=6908 - finally under review so not sure it's worth bringing up https://git.opendaylight.org/gerrit/#/c/53905/ (abhijitkumbhare, 15:41:38)
    16. Waiting for a response from NetVirt whether the patch by tomasslusny is working or not (abhijitkumbhare, 15:43:07)
    17. Fix for 6908 (https://git.opendaylight.org/gerrit/#/c/53905/) will be merged after NetVirt has tested it (abhijitkumbhare, 15:44:16)

  4. Critical issues (abhijitkumbhare, 15:45:27)
    1. jbacigal says some critical bugs fixes by Robert Varga merged: (abhijitkumbhare, 15:47:21)
    2. https://git.opendaylight.org/gerrit/#/c/52965/ Bug 7901 & 8060 fixed by this patch (abhijitkumbhare, 15:49:18)

  5. CSIT failures (abhijitkumbhare, 15:50:14)
    1. https://lists.opendaylight.org/pipermail/openflowplugin-dev/2017-March/006973.html Email by LuisGomez about CSIT failures (abhijitkumbhare, 15:50:33)
    2. Boron only issue: Reconciliation with 10 switches and 1K flows/groups is not stable (new) (abhijitkumbhare, 15:52:04)
    3. Bug: https://bugs.opendaylight.org/show_bug.cgi?id=8102 - needs to be reworked (abhijitkumbhare, 15:52:44)
    4. Table Miss Flow feature - seems to have some issue (abhijitkumbhare, 15:54:34)
    5. https://bugs.opendaylight.org/show_bug.cgi?id=7770 & https://bugs.opendaylight.org/show_bug.cgi?id=8103 (abhijitkumbhare, 15:55:46)
    6. https://git.opendaylight.org/gerrit/#/c/53557/3 Table Miss gerrit patch (tomasslusny, 15:57:51)
    7. ACTION: LuisGomez will test https://git.opendaylight.org/gerrit/#/c/53557 (abhijitkumbhare, 15:58:39)


Meeting ended at 16:04:45 UTC (full logs).

Action items

  1. shuva to review & merge bug 7218 changes from Hema & Tomas after the build succeeds
  2. shuva will respond on the bug 8025 on the different options including working around
  3. Hema__ will also discuss with the NetVirt folks about 8025
  4. jbacigal looking at bug 8057 with the split connection layer handling
  5. jbacigal to follow up on bug 8087
  6. LuisGomez will test https://git.opendaylight.org/gerrit/#/c/53557


Action items, by person

  1. Hema__
    1. Hema__ will also discuss with the NetVirt folks about 8025
  2. jbacigal
    1. jbacigal looking at bug 8057 with the split connection layer handling
    2. jbacigal to follow up on bug 8087
  3. shuva
    1. shuva to review & merge bug 7218 changes from Hema & Tomas after the build succeeds
    2. shuva will respond on the bug 8025 on the different options including working around


People present (lines said)

  1. abhijitkumbhare (62)
  2. odl_meetbot (13)
  3. shuva (4)
  4. tomasslusny (2)
  5. Hema__ (0)
  6. jbacigal (0)


Generated by MeetBot 0.1.4.