15:03:34 <CaseyODL> #startmeeting AdvisooryGroup
15:03:34 <odl_meetbot> Meeting started Thu Jul 21 15:03:34 2016 UTC.  The chair is CaseyODL. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:03:34 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:34 <odl_meetbot> The meeting name has been set to 'advisoorygroup'
15:04:02 <CaseyODL> #chair phrobb colindixon
15:04:02 <odl_meetbot> Current chairs: CaseyODL colindixon phrobb
15:07:26 <colindixon> phrobb, CaseyODL: it's typically helpful to do a #topic before an #infos or other stuff otherwise the first ones end up weirdly dangling under a non-topic
15:08:00 <colindixon> e.g., https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-06-16-17.01.html
15:08:50 <CaseyODL> #topic CORD/Edge Computing discussion
15:09:36 <CaseyODL> #info  Phil asks for a follow up on the email thread regarding CORD and where we may want to focus our efforts.
15:11:05 <CaseyODL> #info Beau points out that there is another discussion where we would do a presentation of our own version of CORD in the ODL booth at OpenStack
15:12:04 <CaseyODL> #info Discussions are early, but OPNFV is still a potential home for the edge computing elements.
15:12:57 <CaseyODL> #info Bryan notes that AT&T is interested in CORD and it's  future.
15:13:47 <CaseyODL> #info Bryan: The advantage of OPNFV is it's focus on the datacenter.
15:16:19 <CaseyODL> #info Beau notes that 2 POC solution is challenging at first due to the logistics.  MCORD is more difficult to implement due to limited NFV functions.
15:17:28 <CaseyODL> #info Beau: We are currently testing and I will report back as we develop new research and testing.
15:20:55 <CaseyODL> #info Pedro responds to a question regarding RIFT.io.  He points out that there is a open source MANO project that works with ODL.
15:26:21 <CaseyODL> #info  Phil we will continue to work with the Open CORD and OPNFV communities.   We are actively looking for people who interested in working on these projects.
15:26:51 <CaseyODL> #topic Discuss impending changes to ODL's YANG Models and RESTCONF interface and it's impact on end users. How best can the ODL community communicate and execute on changes that impact end users?
15:26:53 <colindixon> https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#Information_From_Past_Meetings
15:27:08 <CaseyODL> #link https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#Information_From_Past_Meetings
15:29:11 <CaseyODL> #info Colin: There is a chance that we may be moving to RESTCONF draft 11.  It is currently under final review by ISG.  We would like to have a standards compliant version of RESTCONF.  There are a number of changes.  It will change the way that people are building apps on top of ODL.
15:29:52 <CaseyODL> #info Tighter integration with the IETF would be better.
15:29:53 <colindixon> #link https://wiki.opendaylight.org/view/File:Restconf_v2_analysis.odt writeup of the differences
15:30:48 <CaseyODL> #info Some of the encoding of patches will change and URLs will change.
15:30:59 <CaseyODL> #info The ways that keys are expressed will also change.
15:32:42 <CaseyODL> #info It is all loosely coupled.  Random things will break.  We will not be able to deprecate this in Carbon.  This will take time.
15:32:59 <CaseyODL> #info This is the biggest migration since the AD/MD SAL migration.
15:33:34 <CaseyODL> #info This is something that is coming in the next 6 to 18 months.
15:34:12 <CaseyODL> #info Brian asks if this was a topic at ODL Summit.
15:34:33 <CaseyODL> #info Colin: I would be floored if it isn't.
15:34:54 <CaseyODL> #action Phil will ensure that this is a topic at ODL Summit.
15:36:03 <CaseyODL> #info Colin: My personal take is given the widespread use of Draft 2, we should continue to support it for as long as we can.  But there is a cost to maintain two different versions of RESTCONF.
15:36:27 <CaseyODL> #info Chris asks how much is contained in a certain module vs a Project?
15:36:56 <phrobb> #action phrobb to ensure there is a session on RESTCONF migration at the ODL Summit in September
15:37:05 <CaseyODL> #info It's mostly contained in RESTCOF
15:39:03 <CaseyODL> #info I expect that we have at least two releases where both drafts will exist side by side.  There is no automated tool to update your applications and we need to give time for our community to update.
15:40:25 <CaseyODL> #info RESTCONF will use YANG 1.1 and not 1.0.  ODL currently doesn't have support for YANG 1.1.  This may result in some weird issues depending on how that turns out.
15:43:07 <CaseyODL> #info Brian asks what our plan is for YANG 1.1.
15:43:32 <CaseyODL> #info Colin: The simple answer is that we want to do it, but we don't have a current plan.
15:44:58 <CaseyODL> #info The challenge of maintaining multiple versions of YANG north and south bound will not be easy.
15:46:06 <CaseyODL> #info Pedro: If we want to keep up with the IETF, we need to focus on this.
15:48:33 <CaseyODL> #info Pedro: IETF Berlin met to discuss Open Source again.  There is a lot of awareness and we should be a part of that.
15:49:00 <CaseyODL> #info Chris: Some of the larger vendors who work in ODL are sending reps to IETF.
15:54:38 <phrobb> #info Harvey Newman notes that the orchestrators that he is aware of are not dealing with service delivery across regions... the problems they are solving are smaller than the real problems
15:55:17 <phrobb> #info Harvey asks, if there are orch. ideas that include data center, storage systems, etc. are there orch. that incorporate those ideas?
15:57:36 <phrobb> #info Harvey notes, the question is about orch of end to end systems, apart from academia is a coherent unified orchestration/abstraction being worked on anywhere?
15:59:55 <CaseyODL> #info Colin states that nobody is currently working on this.  However it is something that we should discuss further in the future.
16:00:56 <phrobb> #linkhttps://meetings.webex.com/collabs/#/files/detail?fileID=OEG1MNBKU72KYGJMFXJCCA9INV-9VIB&containerID=U537T353F0XW3RDNWO0OL2ZB0O-9VIB&containerType=us <-- this is the webex recording
16:01:11 <CaseyODL> #action Colin will send out the TWS meeting info regarding migration efforts.
16:01:48 <CaseyODL> #link https://meetings.webex.com/collabs/#/files/detail?fileID=OEG1MNBKU72KYGJMFXJCCA9INV-9VIB&containerID=U537T353F0XW3RDNWO0OL2ZB0O-9VIB&containerType=us
16:02:13 <CaseyODL> #info link to the Webex recording
16:02:21 <CaseyODL> #endmeeting