#opendaylight-users: advisory group

Meeting started by CaseyODL at 15:02:16 UTC (full logs).

Meeting summary

  1. Agenda (CaseyODL, 15:05:23)
    1. Review Opendaylight Beryllium Performance Report and CORD discussion (CaseyODL, 15:06:14)

  2. Performance Report (CaseyODL, 15:06:30)
    1. Luis talks about the motivation and strategy for the Performance Report (CaseyODL, 15:07:08)
    2. Provide basic performance numbers, make recommendations for optimal performance, clear doubts on ODL Performance compared to other controllers. (CaseyODL, 15:08:40)
    3. Test Strategy was to include as many protocols as possible, test the REST as well as SB plugin performance, use Real and simulated devices in the SB, use separate labs to confirm results and test against other Open Source Controllers. (CaseyODL, 15:11:40)
    4. For the first report, we used controller single instance. We didn't report CPU or Memory usage analysis. Tested OpenFlow, Netconf, BGP, PCEP, OVSDB. We compared against ONOS and Floodlight (CaseyODL, 15:16:22)
    5. In the future we will test cluster performance, stability, CPU/Memory usage analysis and more plugins if possible. (CaseyODL, 15:17:41)
    6. Luis asks how ODL is typically deployed. (CaseyODL, 15:21:35)
    7. Pedro. Suggests that using it to test OpenFlow and BGP separately. (CaseyODL, 15:22:54)
    8. However would want to test simultaneously in the future. (CaseyODL, 15:23:26)
    9. Brian Doesn't currently use OpenFlow. They primarily use Netconf (CaseyODL, 15:24:01)
    10. Kev is combining OpenFlow and BGP in the lab. Sometimes they use Netconf. (CaseyODL, 15:24:24)
    11. Kevin uses OpenFlow for Firewall, and test most other plugins. (CaseyODL, 15:25:37)
    12. Pedro is using OVSDB to control the configuration of the switches. (CaseyODL, 15:26:55)
    13. Luis pointed out that some people are using a limited combination of plugins. Adding similar tests in the future would be nice if we can find the time. (CaseyODL, 15:29:44)
    14. in the interest of priorities, we may not test against other controllers in the future. (CaseyODL, 15:30:22)
    15. Luis and Phil talk about trying to do future comparisons though OPNFV so that it is a more neutral testing ground. (CaseyODL, 15:33:01)
    16. Kevin asked if the paper is published. (CaseyODL, 15:34:35)
    17. https://www.opendaylight.org/resources/odl-performance (CaseyODL, 15:35:02)
    18. Phil asks if we should test against internal services? (CaseyODL, 15:37:30)
    19. Brian believes that we should remain focused on REST. (CaseyODL, 15:37:30)
    20. Luis reported that we have the ability to test Java APIs as well as REST APIs. (CaseyODL, 15:47:09)
    21. If we wanted to buy hardware to aid in the testing, what does the AG suggest? (CaseyODL, 15:47:41)
    22. Size of clusters, OpenFlow switches, etc. Where should we optimize? (CaseyODL, 15:48:13)
    23. Pedro said that it could be a long discussion and offered to meet with Phil at OPNFV. (CaseyODL, 15:48:38)
    24. Brian asked Why didn't you test this in Rackspace or Asure? (CaseyODL, 15:50:49)
    25. Phil that's a good question and we can look into that. (CaseyODL, 15:50:49)
    26. Brian said that we are not currently running ODL on bare metal. But I understand that some people may want to. (CaseyODL, 15:51:55)
    27. Phil: There is a significant capex and opex expense for this. But we want to test these things if there is a value. (CaseyODL, 15:52:37)
    28. Phil comments that this is a great place for user orgs to get involved. Feel free to write tests and help influence testing in the future. (CaseyODL, 15:55:20)
    29. Brian wants a front row seat for the next Performance Report. :) (CaseyODL, 15:56:50)
    30. Luis reports that we will probably release the next Performance report during OpenDaylight Summit. (CaseyODL, 15:57:33)

  3. CORD (CaseyODL, 15:57:44)
    1. Phil reports to the AG that the CORD project is mostly edge computing. Asks the AG where they think would be a good place to build out CORD? (CaseyODL, 15:59:17)
    2. Chris said that CORD is interesting, but doesn't really play a role for his organization unless it starts to encompass more than just OpenFlow. (CaseyODL, 16:00:10)
    3. Chris suggests that we start a mail thread to discuss this further. (CaseyODL, 16:00:47)
    4. ACTION: phrobb will start a thread with the AG to discuss the CORD topic in depth. (CaseyODL, 16:01:25)


Meeting ended at 16:01:46 UTC (full logs).

Action items

  1. phrobb will start a thread with the AG to discuss the CORD topic in depth.


Action items, by person

  1. phrobb
    1. phrobb will start a thread with the AG to discuss the CORD topic in depth.


People present (lines said)

  1. CaseyODL (48)
  2. odl_meetbot (8)
  3. bryan_att (2)
  4. colindixon (1)
  5. phrobb (0)
  6. probb (0)


Generated by MeetBot 0.1.4.