15:02:16 <CaseyODL> #startmeeting advisory group
15:02:16 <odl_meetbot> Meeting started Thu Jun 16 15:02:16 2016 UTC.  The chair is CaseyODL. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:16 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:16 <odl_meetbot> The meeting name has been set to 'advisory_group'
15:02:34 <CaseyODL> #chair colindixon probb
15:02:34 <odl_meetbot> Warning: Nick not in channel: probb
15:02:34 <odl_meetbot> Current chairs: CaseyODL colindixon probb
15:02:46 <colindixon> coming, 2 secs
15:05:23 <bryan_att> hi, just got a ping to join this meeting. is it IRC-only?
15:05:23 <CaseyODL> #topic Agenda
15:06:14 <CaseyODL> #info Review Opendaylight Beryllium Performance Report and CORD discussion
15:06:30 <CaseyODL> #topic Performance Report
15:07:08 <CaseyODL> #info Luis talks about the motivation and strategy for the Performance Report
15:07:30 <CaseyODL> bryan_att: You don't have to be here, just thought you may want to.  The main meeting is on webex.
15:07:54 <bryan_att> CaseyODL: can you forward the webex info?
15:08:40 <CaseyODL> #info Provide basic performance numbers, make recommendations for optimal performance, clear doubts on ODL Performance compared to other controllers.
15:08:53 <CaseyODL> bryan_att: https://meetings.webex.com/collabs/meetings/join?uuid=MCYBAQNO8PMMQ1RD917HIUQRK1-9VIB
15:11:40 <CaseyODL> #info Test Strategy was to include as many protocols as possible, test the REST as well as SB plugin performance, use Real and simulated devices in the SB, use separate labs to confirm results and test against other Open Source Controllers.
15:16:22 <CaseyODL> #info For the first report, we used controller single instance.  We didn't report CPU or Memory usage analysis.  Tested OpenFlow, Netconf, BGP, PCEP,  OVSDB.  We compared against ONOS and Floodlight
15:17:41 <CaseyODL> #info In the future we will test cluster performance, stability, CPU/Memory usage analysis and more plugins if possible.
15:21:17 <CaseyODL> #info info Luis asks how ODL is typically deployed.
15:21:29 <CaseyODL> #undo
15:21:29 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x26abc90>
15:21:35 <CaseyODL> #info Luis asks how ODL is typically deployed.
15:22:54 <CaseyODL> #info Pedro.  Suggests that using it to test OpenFlow and BGP separately.
15:23:26 <CaseyODL> #info However would want to test simultaneously in the future.
15:24:01 <CaseyODL> #info Brian Doesn't currently use OpenFlow.  They primarily use Netconf
15:24:24 <CaseyODL> #info Kev is combining OpenFlow and BGP in the lab.  Sometimes they use Netconf.
15:25:37 <CaseyODL> #info Kevin uses OpenFlow for Firewall, and test most other plugins.
15:26:55 <CaseyODL> #info Pedro is using OVSDB to control the configuration of the switches.
15:29:44 <CaseyODL> #info Luis pointed out that some people are using a limited combination of plugins.  Adding similar tests in the future would be nice if we can find the time.
15:30:22 <CaseyODL> #info in the interest of priorities, we may not test against other controllers in the future.
15:33:01 <CaseyODL> #info Luis and Phil talk about trying to do future comparisons though OPNFV so that it is a more neutral testing ground.
15:34:35 <CaseyODL> #info Kevin asked if the paper is published.
15:35:02 <CaseyODL> #link https://www.opendaylight.org/resources/odl-performance
15:37:30 <CaseyODL> #info Phil asks if we should test against internal services?
15:37:30 <CaseyODL> #info Brian believes that we should remain focused on REST.
15:38:40 <CaseyODL> #chair phrobb
15:38:40 <odl_meetbot> Current chairs: CaseyODL colindixon phrobb probb
15:47:09 <CaseyODL> #info Luis reported that we have the ability to test Java APIs as well as REST APIs.
15:47:41 <CaseyODL> #info If we wanted to buy hardware to aid in the testing, what does the AG suggest?
15:48:13 <CaseyODL> #info Size of clusters, OpenFlow switches, etc.   Where should we optimize?
15:48:38 <CaseyODL> #info Pedro said that it could be a long discussion and offered to meet with Phil at OPNFV.
15:49:35 <CaseyODL> #info Why didn't you test this in Rackspace or Asure?
15:49:45 <CaseyODL> #undo
15:49:45 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x29c3d90>
15:50:49 <CaseyODL> #info Brian asked Why didn't you test this in Rackspace or Asure?
15:50:49 <CaseyODL> #info Phil that's a good question and we can look into that.
15:51:55 <CaseyODL> #info Brian said that we are not currently running ODL on bare metal.  But I understand that some people may want to.
15:52:37 <CaseyODL> #info Phil:  There is a significant capex and opex expense for this.  But we want to test these things if there is a value.
15:55:20 <CaseyODL> #info Phil comments that this is a great place for user orgs to get involved.   Feel free to write tests and help influence testing in the future.
15:56:50 <CaseyODL> #info Brian wants a front row seat for the next Performance Report.  :)
15:57:33 <CaseyODL> #info Luis reports that we will probably release the next Performance report during OpenDaylight Summit.
15:57:44 <CaseyODL> #topic CORD
15:59:17 <CaseyODL> #info Phil reports to the AG that the CORD project is mostly edge computing.  Asks the AG where they think would be a good place to build out CORD?
16:00:10 <CaseyODL> #info Chris said that CORD is interesting, but doesn't really play a role for his organization unless it starts to encompass more than just OpenFlow.
16:00:47 <CaseyODL> #info Chris suggests that we start a mail thread to discuss this further.
16:01:25 <CaseyODL> #action phrobb will start a thread with the AG to discuss the CORD topic in depth.
16:01:46 <CaseyODL> #endmeeting