#opendaylight-docs: docs

Meeting started by colindixon at 16:01:34 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 16:02:53)
    1. denise wants 20 mintues to ask questions (colindixon, 16:03:01)
    2. colindixon wasts to talk about meeting times (colindixon, 16:03:07)
    3. colindixon will also mumble about interns (colindixon, 16:03:14)

  2. new meeting time (colindixon, 16:03:57)
    1. https://lists.opendaylight.org/pipermail/documentation/2016-February/000602.html the new meeting time is noon pacific on Tuesdays (colindixon, 16:04:44)
    2. http://doodle.com/poll/9aude6w3yk8yvmyk doodle poll results (colindixon, 16:05:07)
    3. ACTION: CaseyODL to update the meeting in the calendar (colindixon, 16:05:33)
    4. we will next week at noon pacific on Tuesday and from there on out (colindixon, 16:05:55)

  3. interns (colindixon, 16:06:26)
    1. we have an intern to work on documention toolchain improvements (colindixon, 16:06:40)
    2. so yay, thanks CaseyODL and the LF (colindixon, 16:07:11)
    3. ACTION: zxiiro to talk to yangtools about removing maven 3.1 support to get this merged and then find a second project that we could play with, likely mdsal (colindixon, 16:09:33)
    4. ACTION: colindixon to add being able to auto-generate YANG javadoc this as a requirement for Boron (colindixon, 16:09:34)
    5. ACTION: colindixon to try to work on getting project categorization for this page https://wiki.opendaylight.org/view/Project_list (colindixon, 16:09:36)
    6. ACTION: https://wiki.opendaylight.org/view/Docucentral colindixon to work with casey to start to populate this (colindixon, 16:09:37)
    7. ACTION: anipbu to set up a meeting with Denise, phrobb, CaseyODL, to get a demo from NEXT to figure out what's there and how to document it (colindixon, 16:09:39)
    8. ACTION: colindixon and phrobb to help Denise in updating the features table, there's an e-mail about this (colindixon, 16:09:40)
    9. ACTION: anipbu and colindixon to work on docs reviewing checklist using the above information (colindixon, 16:09:41)
    10. ACTION: colindixon and phrobb to review the getting started guide with Denise's updates (colindixon, 16:09:42)

  4. questions from denise (colindixon, 16:09:44)
    1. https://docs.google.com/document/d/1IA31oRAEO155fygbENCYb6QKKTg7G5lxtSlBOusXvNc/edit#heading=h.hbhzyw3uq4tp (colindixon, 16:09:56)
    2. denise asks if it's right that we have feature parity with the neutron ovs reference implementation (colindixon, 16:16:52)
    3. phrobb and colindixon say to reach out to Anil Vishnoi, Sam Hague and Flavio Fernandes about that, they supposedly have a nuanced document about this (colindixon, 16:20:20)
    4. https://jenkins.opendaylight.org/autorelease/job/autorelease-release-beryllium/47/ (anipbu, 16:22:31)
    5. https://docs.google.com/spreadsheets/d/1Kfp5HVQGydNegEjp6dD2V3XsUnqpice0bysWbdxABA4/edit#gid=789555159 (anipbu, 16:24:15)
    6. denise asks about APIs with JavaDoc and YANG APIdoc (colindixon, 16:33:12)
    7. phrobb says it's sucking with zxiiro right now, we have limited support now and need help from projects (colindixon, 16:33:35)
    8. https://nexus.opendaylight.org/content/sites/site/org.opendaylight.yangtools/boron/apidocs/index.html YangTools javaapi docs (Boron) (zxiiro, 16:34:56)
    9. ACTION: phrobb to follow up with zxiiro to figure out what can be done by Beryllium release (colindixon, 16:35:01)
    10. as last time, colindixon thinks Beryllium-SR1 is more likely (colindixon, 16:35:26)


Meeting ended at 14:51:52 UTC (full logs).

Action items

  1. CaseyODL to update the meeting in the calendar
  2. zxiiro to talk to yangtools about removing maven 3.1 support to get this merged and then find a second project that we could play with, likely mdsal
  3. colindixon to add being able to auto-generate YANG javadoc this as a requirement for Boron
  4. colindixon to try to work on getting project categorization for this page https://wiki.opendaylight.org/view/Project_list
  5. https://wiki.opendaylight.org/view/Docucentral colindixon to work with casey to start to populate this
  6. anipbu to set up a meeting with Denise, phrobb, CaseyODL, to get a demo from NEXT to figure out what's there and how to document it
  7. colindixon and phrobb to help Denise in updating the features table, there's an e-mail about this
  8. anipbu and colindixon to work on docs reviewing checklist using the above information
  9. colindixon and phrobb to review the getting started guide with Denise's updates
  10. phrobb to follow up with zxiiro to figure out what can be done by Beryllium release


Action items, by person

  1. anipbu
    1. anipbu to set up a meeting with Denise, phrobb, CaseyODL, to get a demo from NEXT to figure out what's there and how to document it
    2. anipbu and colindixon to work on docs reviewing checklist using the above information
  2. colindixon
    1. colindixon to add being able to auto-generate YANG javadoc this as a requirement for Boron
    2. colindixon to try to work on getting project categorization for this page https://wiki.opendaylight.org/view/Project_list
    3. https://wiki.opendaylight.org/view/Docucentral colindixon to work with casey to start to populate this
    4. colindixon and phrobb to help Denise in updating the features table, there's an e-mail about this
    5. anipbu and colindixon to work on docs reviewing checklist using the above information
    6. colindixon and phrobb to review the getting started guide with Denise's updates
  3. zxiiro
    1. zxiiro to talk to yangtools about removing maven 3.1 support to get this merged and then find a second project that we could play with, likely mdsal
    2. phrobb to follow up with zxiiro to figure out what can be done by Beryllium release


People present (lines said)

  1. colindixon (32)
  2. odl_meetbot (4)
  3. zxiiro (3)
  4. anipbu (2)


Generated by MeetBot 0.1.4.