#opendaylight-docs: docs

Meeting started by colindixon at 19:03:23 UTC (full logs).

Meeting summary

  1. agenda (colindixon, 19:03:26)
    1. https://git.opendaylight.org/gerrit/#/c/39371/ (colindixon, 19:03:43)
    2. https://meetings.opendaylight.org/opendaylight-docs/2016/docs/opendaylight-docs-docs.2016-05-17-19.01.html last week's meeting minutes (colindixon, 19:04:21)
    3. zxiiro says that he's working on creating a global verify job for docs that will run on any project adding docs (colindixon, 19:05:24)
    4. https://lists.opendaylight.org/pipermail/documentation/2016-May/000707.html e-mail about boron documentation review committee (colindixon, 19:06:05)
    5. https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 anipbu set up a documentation review spreadsheet (colindixon, 19:06:25)
    6. https://git.opendaylight.org/gerrit/#/q/project:docs+topic:opendaylight-with-openstack three patches from zxiiro to migrate the openstack guide to readthedocs (colindixon, 19:08:36)
    7. https://opendaylight.readthedocs.io/en/latest/opendaylight-with-openstack/index.html the docs are here (colindixon, 19:08:49)
    8. ACTION: colindixon to migrate some content from the asciidoc getting started guide into the readthedocs to be able to clean up th asciidoc version (colindixon, 19:10:08)
    9. ACTION: colindixon to reach out to the projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version (colindixon, 19:11:01)

  2. migration to RST (colindixon, 19:12:14)
    1. ACTION: Xinghao to help get a contributing to the docs guide working, it likely wants to live in the docs project itself (colindixon, 19:12:52)
    2. colindixon asks if we want to document migration or just do it for projects and then helping them understand (colindixon, 19:13:55)
    3. colindixon asks how migration worked for zxiiro (colindixon, 19:14:12)
    4. basically 1.) copy/paste, 2.) search and replace headers to the new style, 3.) change *word* to **word**, 4.) dealing with talbes is easier with list-table (colindixon, 19:16:14)
    5. http://docutils.sourceforge.net/docs/ref/rst/directives.html#list-table list-table documentation here (colindixon, 19:16:33)
    6. https://opendaylight.readthedocs.io/en/latest/opendaylight-with-openstack/index.html (colindixon, 19:17:50)
    7. colindixon asks when we want to take this to projects (colindixon, 19:24:32)
    8. https://wiki.opendaylight.org/view/Documentation/Tools/reStructuredText (anipbu, 19:28:19)
    9. https://github.com/anipbu/adoc2rst (anipbu, 19:28:20)
    10. ACTION: colindixon to populate the documentation reivew matrix with some assignments (colindixon, 19:31:50)
    11. ACTION: colindixon anipbu and zxiiro to work on converting some of the user guide and developer guide pieces so we can iron out more bugs (colindixon, 19:33:44)
    12. colindixon won't be here the next two weeks (colindixon, 19:34:01)


Meeting ended at 19:34:03 UTC (full logs).

Action items

  1. colindixon to migrate some content from the asciidoc getting started guide into the readthedocs to be able to clean up th asciidoc version
  2. colindixon to reach out to the projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version
  3. Xinghao to help get a contributing to the docs guide working, it likely wants to live in the docs project itself
  4. colindixon to populate the documentation reivew matrix with some assignments
  5. colindixon anipbu and zxiiro to work on converting some of the user guide and developer guide pieces so we can iron out more bugs


Action items, by person

  1. anipbu
    1. colindixon anipbu and zxiiro to work on converting some of the user guide and developer guide pieces so we can iron out more bugs
  2. colindixon
    1. colindixon to migrate some content from the asciidoc getting started guide into the readthedocs to be able to clean up th asciidoc version
    2. colindixon to reach out to the projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version
    3. colindixon to populate the documentation reivew matrix with some assignments
    4. colindixon anipbu and zxiiro to work on converting some of the user guide and developer guide pieces so we can iron out more bugs


People present (lines said)

  1. colindixon (23)
  2. odl_meetbot (3)
  3. anipbu (2)


Generated by MeetBot 0.1.4.