#opendaylight-docs: docs

Meeting started by colindixon at 19:01:31 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 19:01:36)
    1. https://git.opendaylight.org/gerrit/#/q/topic:gsg2rst colindixon migrated the entire getting started guide to reST and cleand up the older version as patches here (colindixon, 19:02:45)
    2. it looks like anipbu did a lot of reviewing of documentation patches and +1ed them if the edits are minor and a reader could understand how to use the features even with the minor issues (colindixon, 19:05:04)
    3. colindixon asks how to track when to get those fixed, for now anipbu's take is to just let them reflect on the quality of their project if they don't fix them (colindixon, 19:07:16)
    4. https://git.opendaylight.org/gerrit/#/c/40962/ colindixon pushed some enhanced documentation about how the docs project works and basic information about the directory structure and the like (colindixon, 19:08:19)
    5. https://meetings.opendaylight.org/opendaylight-docs/2016/docs/opendaylight-docs-docs.2016-06-28-19.01.log.txt (colindixon, 19:09:17)
    6. https://lists.opendaylight.org/pipermail/documentation/2016-June/000762.html e-mail informaing projects of project-speciific installation instructions being migrated to reST (colindixon, 19:10:48)
    7. ACTION: colindixon to reach out to the projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version (colindixon, 19:11:16)
    8. ACTION: colindixon to populate the documentation reivew matrix with some assignments (colindixon, 19:11:25)
    9. ACTION: colindixon to look into making zxiiro a committer on docs (colindixon, 19:12:42)

  2. status update from Xinghao (colindixon, 19:14:06)
    1. xinghao asks if there's a need for an automated tool (colindixon, 19:15:32)
    2. https://lists.opendaylight.org/pipermail/documentation/2016-June/000747.html xinghao looked into using pandoc (colindixon, 19:16:27)
    3. anipbu says to make sure sure to focus on the 90/10 point where we get 90% of the value with 10% of the work focusing on the key parts (colindixon, 19:17:28)
    4. ACTION: xinghao to provide a sample input and output for his tool for next week's meeting (or hopefully before then) (colindixon, 19:18:52)
    5. https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 (anipbu, 19:21:13)

  3. status of reviewing docs patches (colindixon, 19:21:24)
    1. https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 (colindixon, 19:21:29)
    2. https://wiki.opendaylight.org/view/Documentation/Tools/AsciiDoc_Tips#Common_Errors (colindixon, 19:23:04)

  4. david karr asks about images and video in asciidoc (colindixon, 19:25:34)
    1. https://wiki.opendaylight.org/view/Documentation/Tools/AsciiDoc_Tips#Common_Errors the first two common errors show how to work with images (indirectly) (colindixon, 19:26:03)
    2. videos are best done with URLs to YouTube or something similar (colindixon, 19:27:35)
    3. http://www.telecomasia.net/content/sdnlab-joins-opendaylight-project (anipbu, 19:28:58)
    4. http://i.youku.com/opendaylight (anipbu, 19:29:59)

  5. where project documenrtation live (colindixon, 19:30:13)
    1. anipbu asks wehther we should encourage projects to do away with wiki-based documentation (colindixon, 19:30:27)
    2. colindixon says (in agreement with anipbu) that projects should be able to do whatever they want, but it's likely that they want to keep a single copy of docs in one place, and that's likely git (colindixon, 19:32:19)

  6. video for china (colindixon, 19:32:39)
    1. it sounds like Huawei is providing subtitles and uploading our YouTube videos to YouKu here: http://i.youku.com/opendaylight (colindixon, 19:33:24)


Meeting ended at 20:35:13 UTC (full logs).

Action items

  1. colindixon to reach out to the projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version
  2. colindixon to populate the documentation reivew matrix with some assignments
  3. colindixon to look into making zxiiro a committer on docs
  4. xinghao to provide a sample input and output for his tool for next week's meeting (or hopefully before then)


Action items, by person

  1. colindixon
    1. colindixon to reach out to the projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version
    2. colindixon to populate the documentation reivew matrix with some assignments
    3. colindixon to look into making zxiiro a committer on docs


People present (lines said)

  1. colindixon (32)
  2. odl_meetbot (5)
  3. anipbu (5)


Generated by MeetBot 0.1.4.