#opendaylight-docs: docs

Meeting started by colindixon at 19:03:27 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 19:03:34)
    1. https://meetings.opendaylight.org/opendaylight-docs/2016/docs/opendaylight-docs-docs.2016-07-12-19.04.html last week's meeting minutes (colindixon, 19:03:48)
    2. ACTION: colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches (colindixon, 19:03:54)
    3. ACTION: xinghao__ to extend the pandoc conversion script to split things on section/chapter/whatever so we get one file per project (or some approximation of that) (colindixon, 19:04:56)
    4. https://git.opendaylight.org/gerrit/#/c/41786/ script xinghao__ wrote to do conversion of a full guide to a single reST file (colindixon, 19:05:48)
    5. ACTION: colindixon to follow up with projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version (colindixon, 19:06:01)
    6. https://bugs.opendaylight.org/show_bug.cgi?id=6197 colindixon posted a bug about the top bar being too big on narrow windows (colindixon, 19:06:45)
    7. ACTION: colindixon and/or zxiiro to fix the favicon (colindixon, 19:07:39)
    8. ACTION: phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money (colindixon, 19:07:48)
    9. ACTION: colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior (colindixon, 19:08:01)
    10. https://wiki.opendaylight.org/view/Documentation/Tools/reStructuredText is the wiki page comparing and contrasting reST and AsciiDoc (colindixon, 19:09:47)

  2. migrating the user guide and developer guide to reST in boron (colindixon, 19:10:56)
    1. colindixon thinks this is blocking on xinghao__'s script to automatically migrate the two guides with reasonable splits into reST files (colindixon, 19:11:30)
    2. xinghao__ says he thinks he can have this done by the end of this week (colindixon, 19:12:39)

  3. docs reviewing backlog (colindixon, 19:12:44)
    1. https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 documentation patch backlog (colindixon, 19:13:10)

  4. when to migrate from AsciiDoc to reST again (colindixon, 19:19:37)
    1. davidmichaelkarr notes that doing the conversion after the documentation production during a lull makes the most sense, maybe the beginning of the next release (colindixon, 19:20:43)
    2. anipbu says maybe in between release reviews and the release (which would get it for us in boron) (colindixon, 19:20:56)
    3. colindixon sasy that makes a lot of sense (colindixon, 19:21:03)
    4. anipbu asks if we should get permission before then so we can just do it (colindixon, 19:21:25)
    5. colindixon says he thinks that's a really good idea, but he wants to make sure that we can actually do automatic migration before we go looking for permission (colindixon, 19:21:51)
    6. hopefully that will be late this week or early next week (colindixon, 19:22:01)


Meeting ended at 19:22:03 UTC (full logs).

Action items

  1. colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches
  2. xinghao__ to extend the pandoc conversion script to split things on section/chapter/whatever so we get one file per project (or some approximation of that)
  3. colindixon to follow up with projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version
  4. colindixon and/or zxiiro to fix the favicon
  5. phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money
  6. colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior


Action items, by person

  1. colindixon
    1. colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches
    2. colindixon to follow up with projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version
    3. colindixon and/or zxiiro to fix the favicon
    4. colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
  2. xinghao__
    1. xinghao__ to extend the pandoc conversion script to split things on section/chapter/whatever so we get one file per project (or some approximation of that)
  3. zxiiro
    1. colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches
    2. colindixon and/or zxiiro to fix the favicon
    3. phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money


People present (lines said)

  1. colindixon (25)
  2. odl_meetbot (3)
  3. zxiiro (2)
  4. xinghao__ (1)


Generated by MeetBot 0.1.4.