18:01:18 <colindixon> #startmeeting docs
18:01:18 <odl_meetbot> Meeting started Tue Aug  2 18:01:18 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:01:18 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:18 <odl_meetbot> The meeting name has been set to 'docs'
18:01:23 <colindixon> #topic agenda bashing
18:02:23 <colindixon> nm, docs call isn't for an hour
18:02:29 <colindixon> I guess I'll just leave this open
18:54:21 <anipbu> colindixon: I've updated the spreadsheet for projects that did not submit any changes but have stated in their milestone status that they have no change from previous release.  Column C has link to email, and Column D is marked "No Change".
18:54:32 <colindixon> sweet
18:54:48 * colindixon goes to look
19:00:58 <colindixon> #info per-project patch status
19:01:26 <colindixon> #info xinghao's asciidoc => docbook => reST => split reST converter
19:02:01 <colindixon> #info plans for migration in boron
19:02:21 <colindixon> #action colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches (the naive thing doesn't work)
19:02:29 <colindixon> #action colindixon to follow up with projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version
19:02:34 <colindixon> #action colindixon and/or zxiiro to fix the favicon
19:02:40 <colindixon> #action colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
19:02:49 <colindixon> #action phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money
19:03:00 <zxiiro> i'll ping Phil about it again
19:03:37 <colindixon> #link https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 anipbu went through the documentation tracker and marked patches with "no change" if the project said there was no change
19:03:50 <colindixon> #action colindixon to e-mail projects with no docs and no e-mail saying there won't be any after anipbu does his update
19:04:15 <colindixon> #action colindixon and xinghao to check for cross-project links in the guides, to make sure they still work (colindixon is pretty sure they won't, but there aren't very many)
19:08:56 <colindixon> #action colindixon to abandon the seemingly abandoned patches and send e-mails to the relevant projects
19:09:10 <colindixon> #action colindixon and xinghao to make sure content above chapters works
19:10:03 <colindixon> #topic per-project patch status
19:10:22 <colindixon> #link https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863
19:10:30 <colindixon> #info 2 patches waiting for review
19:10:46 <colindixon> #info 23 patchces waiting for input/approval from the project
19:11:03 <colindixon> #info 18 projects which have no new documentation in Boron and haven't said that's intentional
19:11:58 <colindixon> #topic xinghao's patch to do automatic migration
19:12:39 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/42104/
19:12:56 <colindixon> #info xinghao says that cross-project links don't always work in HTML, some sanity checking will be required
19:13:16 <colindixon> #Info that means we'd likely want projects to at least read through their documentation post-conversions once
19:15:01 <colindixon> #topic our plan for migration
19:15:38 <colindixon> #info additional topcis: (i) TWS on Monday, (ii) enabling edit on github
19:16:26 <colindixon> #info options: (1) migrate the dev and user guides in Carbon, (2) migrate everyging with an option to opt-out, (3) migrate everything with project's having to opt-in
19:17:22 <colindixon> #Info consequencnes: (a) we have migrate open patches to reST for people, (b) we might have two different places docs lifeā€”at least we could link from the reST to the PDF in the relvant places (maybe backwards as well)
19:17:28 <colindixon> #Info also, when?
19:19:28 <colindixon> #info anipbu notes that if wait for carbon, that forces us to keep AsciiDoc alive for longer and that means you can't easily cherry-pick from carbon to boron
19:20:05 <colindixon> #info anipbu also notes that patches after the branch cutting really need 3 possible branch targets: stable/beryllium, stable/boron, and master (carbon)
19:21:15 <colindixon> #info colindixon says his intution is to make it opt-out, and do the full migration as soon as we can manage after the TWS and get the open patches down as much as possible
19:22:19 <colindixon> #info it sounds like we have conensus on that and we'll try for it based on community feedback, we might have to wait for TSC approval on next Thursday
19:22:26 <colindixon> #topic TWS on monday
19:23:04 <colindixon> #info colindixon was planning to show off what we currently have, show it building, show the reST wiki page, show xinghao_'s script, and then present the above migration plan
19:23:33 <colindixon> #info it would be cool to show javadoc generation in sphinx as well
19:25:38 <colindixon> #info note that projects can use whatever format they want for docs in theier repo
19:25:52 <colindixon> #topic enabing edit on github or something similar
19:30:58 <colindixon> #info making the edit on github link work from our docs seems hard, but would be awesome
19:31:29 <colindixon> #info in particular submodules, kind of make things hard, since we'd need to resolve to multiple git repositories
19:32:13 <colindixon> #link https://gerrit.googlesource.com/plugins/github/+/master/README.md the github gerrit plugin might give us a way to translate pull requests to gerrit patches automatically, which makes it possible, if annoying
19:34:20 <colindixon> #endmeeting