#opnfv-pharos: Cross Community CI

Meeting started by fdegir at 13:00:24 UTC (full logs).

Meeting summary

  1. Rollcall (fdegir, 13:00:29)
    1. Tapio (ttallgren, 13:00:38)
    2. Victor Morales (electrocucaracha, 13:00:53)
    3. Tianwei Wu (hw_wutianwei_, 13:01:20)

  2. OpenCI Updates: Event Driven/Federated CI/CD (fdegir, 13:02:02)
    1. We are working on bringing the prototype up based on what is proposed on the docs shared last week (fdegir, 13:02:29)
    2. https://docs.google.com/document/d/1WyjD6Wz4p7jVnEtRfwhsKltrtHxDiJZGaj5Nn0U-psE/edit# (fdegir, 13:02:42)
    3. yolanda_ is also helping out with it by writing a utility to publish events to activemq message broker (fdegir, 13:03:03)
    4. I hope to have it up and running before OpenDev which we can hopefully have a demo to OPNFV before that (fdegir, 13:03:41)
    5. Manuel Buil (mbuil, 13:04:39)

  3. OpenCI Updates: Zuul Prototype (fdegir, 13:04:51)
    1. Zuul is up and running on my VM and I'll move it to OPNFV machine during the rest of the week (fdegir, 13:05:19)
    2. Markos Chandras (hwoarang, 13:05:25)
    3. A sample change is (fdegir, 13:05:44)
    4. https://gerrit.opnfv.org/gerrit/#/c/56399/ (fdegir, 13:05:46)
    5. Periyasamy Palanisamy (epalper, 13:08:46)

  4. Baremetal Status (fdegir, 13:11:08)
    1. mbuil started looking into introducing baremetal for XCI (fdegir, 13:11:22)
    2. ACTION: fdegir to request access for hwoarang for lf-pod4 & ericsson-pod2 (fdegir, 13:13:45)
    3. ACTION: mbuil to share his spec regarding pdf/idf introduction and baremetal support (fdegir, 13:15:03)

  5. Promotion criterias/test scope for CI Loops used by XCI (fdegir, 13:16:20)
    1. The changes talking about the terminology, CI loops and criterias are up for review (fdegir, 13:16:41)
    2. https://gerrit.opnfv.org/gerrit/#/q/status:open+project:releng-xci+branch:master+topic:set-promotion-criterias (fdegir, 13:16:50)
    3. It didn't get much love from scenario owners so I'll ping them again (fdegir, 13:17:05)

  6. Tagging repos/Pinning scenarios (fdegir, 13:20:14)
    1. sdnvpn repo has been tagged with 6.0.0 project internal tag and the scenario is pinned in xci (fdegir, 13:20:30)
    2. sfc repo is waiting to be tagged so we can pin the scenario (fdegir, 13:21:47)
    3. Tagging/pinning generic scenarios requires us to move them to their own repo since tagging and pinning can't be done while they're in same repo (fdegir, 13:22:24)
    4. So the folder releng-xci/xci/scenarios will be moved to its own repo releng-xci-scenarios as is and the history will be preserved (fdegir, 13:23:16)
    5. ACTION: fdegir to submit a ticket to helpdesk for the move (fdegir, 13:23:36)
    6. ACTION: fdegir hwoarang to look at possible impacts of this move (fdegir, 13:23:50)

  7. Long Duration Testing Support (fdegir, 13:26:09)
    1. We will not be able to support LDT near term (fdegir, 13:26:25)

  8. Scenario Status Check (fdegir, 13:31:45)
    1. All k8s scenarios are now supported on openSUSE (fdegir, 13:33:29)
    2. ACTION: hw_wutianwei_ electrocucaracha epalper to start talking about onap scenario in xci on k8s (fdegir, 13:38:06)

  9. Scenario Consolidation and SDF (fdegir, 13:44:17)
    1. Thanks to hw_wutianwei_, Taseer, and hwoarang, we now have 4 k8s scenarios that are crucial for scenario consolidation and SDF work (fdegir, 13:44:48)
    2. We are supporting that work with prototyping and if anyone is interested in it and have ideas, please provide them on the etherpad (fdegir, 13:45:19)
    3. https://etherpad.opnfv.org/p/scenario-consolidation (fdegir, 13:45:31)

  10. AoB (fdegir, 13:46:35)
    1. Some of you might be aware of this that David decided to stop working in XCI and stepping from committer role (fdegir, 13:47:08)
    2. I want to thank David for all the contributions he made (fdegir, 13:47:39)
    3. https://gerrit.opnfv.org/gerrit/#/c/56471/ (fdegir, 13:48:07)
    4. The change adding proxy support for k8s scenarios needs reviews (fdegir, 13:51:45)
    5. https://gerrit.opnfv.org/gerrit/#/c/56159/ (fdegir, 13:51:52)


Meeting ended at 13:59:07 UTC (full logs).

Action items

  1. fdegir to request access for hwoarang for lf-pod4 & ericsson-pod2
  2. mbuil to share his spec regarding pdf/idf introduction and baremetal support
  3. fdegir to submit a ticket to helpdesk for the move
  4. fdegir hwoarang to look at possible impacts of this move
  5. hw_wutianwei_ electrocucaracha epalper to start talking about onap scenario in xci on k8s


Action items, by person

  1. electrocucaracha
    1. hw_wutianwei_ electrocucaracha epalper to start talking about onap scenario in xci on k8s
  2. epalper
    1. hw_wutianwei_ electrocucaracha epalper to start talking about onap scenario in xci on k8s
  3. fdegir
    1. fdegir to request access for hwoarang for lf-pod4 & ericsson-pod2
    2. fdegir to submit a ticket to helpdesk for the move
    3. fdegir hwoarang to look at possible impacts of this move
  4. hw_wutianwei_
    1. hw_wutianwei_ electrocucaracha epalper to start talking about onap scenario in xci on k8s
  5. hwoarang
    1. fdegir to request access for hwoarang for lf-pod4 & ericsson-pod2
    2. fdegir hwoarang to look at possible impacts of this move
  6. mbuil
    1. mbuil to share his spec regarding pdf/idf introduction and baremetal support


People present (lines said)

  1. fdegir (171)
  2. hwoarang (25)
  3. ttallgren (22)
  4. electrocucaracha (17)
  5. mbuil (17)
  6. hw_wutianwei_ (11)
  7. epalper (8)
  8. collabot` (3)
  9. jmorgan1 (2)


Generated by MeetBot 0.1.4.