#opendaylight-clustering: “clusteringhackers”

Meeting started by moizr at 16:06:28 UTC (full logs).

Meeting summary

  1. agenda bashing (tbachman, 16:07:10)
    1. two node clustering update (tbachman, 16:07:17)
    2. testing (integration) status (tbachman, 16:07:28)
    3. other items (tbachman, 16:07:33)
    4. colindixon asks the status of migrating the existing core applications (e.g. openflowplugin) (tbachman, 16:07:59)
    5. moizr says there’s no explicit work going on in that area (tbachman, 16:08:10)
    6. moizr says probably not all the apps are designed to support clustering (tbachman, 16:08:29)
    7. jmedved says there is work going on in the openflowplugin to help make it clustering aware (tbachman, 16:08:47)
    8. moizr would like to see guidelines on how projects should change their apps to support clustering (tbachman, 16:09:39)
    9. colindixon says we have best practices: 1) store everything in the MD-SAL; 2) do app local caching where needed (tbachman, 16:10:04)

  2. bugzilla review (tbachman, 16:10:57)
    1. moizr says we had about 29 last week, now down to 17, most related to performance enhancements (tbachman, 16:11:15)
    2. all the integration tests for 3-node cluster are now working (tbachman, 16:11:41)
    3. The link state topology issue was discovered with BGP, where serialization of binary data was a problem (tbachman, 16:12:35)
    4. The in-progress bugs were suspended while getting the SR1 bugs fixed (tbachman, 16:14:09)
    5. There only bug in the confirmed status that needs to be addressed is the one where the leader should abandon (Bug ID 2371) (tbachman, 16:15:49)
    6. pantelis asks about the serialized UID version in some of the RAFT messages to get rid of sonar warnings, and whether these will be backed out (breaks backwards compatibility) (tbachman, 16:17:12)
    7. ACTION: pantelis will create a bug to keep track of the serialized UID version in the RAFT messages (tbachman, 16:18:07)

  3. two node clustering update (tbachman, 16:18:21)
    1. https://git.opendaylight.org/gerrit/#/c/12832/ (markmozolewski2, 16:18:28)
    2. https://git.opendaylight.org/gerrit/#/c/12832/ gerrit review for current two-node work (tbachman, 16:18:44)
    3. markmozolewski2 says there are some additional changes that will be empty unit tests to cover the use cases that they plan to support (tbachman, 16:19:16)
    4. markmozolewski2 says they also rely on a network partition detection algorithm that’s separate from this code. (tbachman, 16:19:37)
    5. markmozolewski2 requests folks to have a look and provide comments on the gerrit (tbachman, 16:19:56)

  4. testing (integration) status (tbachman, 16:20:03)
    1. moizr says we still haven’t had a stable build on the integration branch (tbachman, 16:20:34)
    2. moizr checked clustering, and says that all the tests on single-node openflow are now passing (tbachman, 16:20:59)
    3. https://git.opendaylight.org/gerrit/#/c/12831 gerrit for refactoring clustering integration tests (tbachman, 16:22:56)
    4. moizr would like to see one other person try this out (tbachman, 16:23:15)
    5. etka says they are 80% of the way of getting the 3-node setup (tbachman, 16:23:39)
    6. catohornet says she can get to the clustering test by the end of the week (tbachman, 16:23:55)
    7. moizr says all the VMs need the same username and password for the 3-cluster test (tbachman, 16:24:14)


Meeting ended at 16:26:42 UTC (full logs).

Action items

  1. pantelis will create a bug to keep track of the serialized UID version in the RAFT messages


People present (lines said)

  1. tbachman (34)
  2. odl_meetbot (4)
  3. colindixon (2)
  4. moizr (2)
  5. markmozolewski2 (1)


Generated by MeetBot 0.1.4.