#opendaylight-clustering: Clustering-Hackers

Meeting started by alagalah at 15:06:06 UTC (full logs).

Meeting summary

  1. Uyen (HP) mentioned there are usability issues (alagalah, 15:06:19)
    1. Jan mentions we should continue this topic over next few weeks on Monday call (alagalah, 15:06:34)
    2. ghall mentions it maybe worth clearing a schedule for a couple of hours, and put themselves in the mindset of doing something simple. (alagalah, 15:08:16)

  2. hard topics (colindixon, 15:10:32)
    1. parent pom, e.g., parent pom structure is confusing, complicated, and has lots of duplicate things (colindixon, 15:11:13)
    2. topics to discuss: pom.xml and how to use them (jmedved, 15:11:29)
    3. mlemay suggest that we look into the config subsystem and how its use can be abstracted (jmedved, 15:12:01)
    4. mlemay says that the XML part may be at least some of it, but not all of it (colindixon, 15:12:22)
    5. uyen says it’s the lack of transparency and how config subsystem hooks into OSGI; is there a chance to move to blueprint? (jmedved, 15:12:32)
    6. devinaverys says also, whatever we can do to make the tooling better, e.g., java binding 2.0 is a very good topic (colindixon, 15:13:28)
    7. devin says that we should tackle anything that concerns tooling (java bindings v2), design it in a way where it’s more consumable than what we have today (jmedved, 15:13:49)
    8. yuen want the generated apis more consumable - should we use annotations to make generated APIs more consumer friendly and/or easier to debug (jmedved, 15:14:38)
    9. colindixon says progress already made, existing generated APIs have javadoc, so we have to make use of some things already there (jmedved, 15:15:26)
    10. colindixon says we should just do the pom xml, and do it once (jmedved, 15:15:49)
    11. ghall says blueprint was mentioned, is that actually on the table? (colindixon, 15:18:01)
    12. colindixon, mlemay: blueprints not really the solution, do not provide deterministic load order (jmedved, 15:18:05)
    13. https://git.opendaylight.org/gerrit/#/c/11704/ lispflowmapping pom restructure (devinavery, 15:18:19)
    14. : mlemay says that we need to make the configs work together better (jmedved, 15:18:28)
    15. colindixon says that edwarnicke would say no because blueprint doesn’t get determnistic load order (colindixon, 15:18:30)

  3. config subsystem (colindixon, 15:21:08)
    1. colindixon asks whether the config susbsystem is it? (jmedved, 15:21:27)
    2. jmedved says that given the requirements, it’s the only thing that solves them that we’re aware of (colindixon, 15:21:54)
    3. devinavery; wants to know in writing what are the problems that the config susbsystem is desgined to solve? (jmedved, 15:21:58)
    4. Info on subsystem: https://wiki.opendaylight.org/view/OpenDaylight_Toolkit:MD-SAL-Simple_Archetype (alagalah, 15:22:29)
    5. uyen asks how much of the benefits do we get if not *everyone* uses the config subsystem (colindixon, 15:22:43)
    6. devinavery - wants to know why we should move to a single config system (jmedved, 15:22:50)
    7. More: https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:Toaster_Tutorial#Config-subsystem_Context (alagalah, 15:22:58)
    8. rovarga: config subsystem solves 3 areas of problems: (jmedved, 15:23:10)

  4. requirements/problems (colindixon, 15:23:10)
    1. first problem is service injection in a determnistic order, but also in a dynamic way, i.e., can be changed at runtime (colindixon, 15:24:17)
    2. configuration can be used by jmx, but it needs it own serialization format and does not use the domain specific language (jmedved, 15:25:12)
    3. provides information about the configuration and runtime statistics about the controller that is, in some ways better than JMX (colindixon, 15:27:18)
    4. rovarga also notes that everything from the config subystem also integrates via JMX (colindixon, 15:27:46)
    5. the third part is making sense about namespaces and lifecycle managment between the two above things (that is serice injection and monitoring/config) (colindixon, 15:29:10)
    6. to summarize: (1) service injection w/deterministic load order and runtime modification (2) runtime config/stats including atomic two phase commit config changes, (3) namespace/lifecycle managment for (1) and (2) (colindixon, 15:32:20)
    7. moiz asks if the runtime reloading modules things is somthing that people actually want to use (colindixon, 15:34:48)
    8. tony (I think) answers that yes, we do this in our current system with netconf and the config subsystem do this (colindixon, 15:35:30)
    9. moiz says that’s really more reconfig, not reloading (colindixon, 15:35:43)
    10. mlemay says he’s torn because he tends to reload things by bringing up a new clustered node with the right config without having to modifiy config (colindixon says that this is his experience as well) (colindixon, 15:37:36)
    11. alagalah asks if we have actual customer wants requirements, in the absence of that we should keep going with the status quo and improving it and reassess only when it stops us from being able do things (or do thing easily) (alagalah, 15:41:43)
    12. Notes: status quo portion attributed to devinavery (alagalah, 15:41:59)
    13. moizer asks if there are pieces of functionality we could drop to make things easier (colindixon, 15:42:20)
    14. rovarga: we have a full feature set, let’s gather requirements to make things simpler (jmedved, 15:42:39)
    15. colindixon says config subsystem issuse is less the substance rather than lack of documentation (jmedved, 15:43:14)
    16. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Config:Main (rovarga, 15:43:30)
    17. https://wiki.opendaylight.org/view/OpenDaylight_Toolkit:MD-SAL-Simple_Archetype (alagalah, 15:43:57)
    18. colindixon: working through a lot of documentation - but still need steps by step instructions (jmedved, 15:44:17)
    19. my proposal from earlier (Needs more work for completion) https://wiki.opendaylight.org/view/OpenDaylight_Controller:Config:JavaShim (raghu67, 15:44:22)
    20. rovarga: documentation exists but needs to be imrpoved; how to configure things, how to enable apps info is there (jmedved, 15:44:59)
    21. colindixon; does not see a step by step cookbook (detailed steps what to do at each step) (jmedved, 15:45:59)
    22. first tutorial gor java introduces basic concepts and how they work (string, integres, etc.) (jmedved, 15:46:35)
    23. devinavery suggests a FIRST STEP may not be to re-write the wiki pages but make a decent way to navigate to these information (alagalah, 15:49:04)
    24. ACTION: colindixon to help try and convert this page into a step-by-step gude: https://wiki.opendaylight.org/view/OpenDaylight_Controller:Config:Examples:Sample_Project (colindixon, 15:50:24)
    25. ACTION: Everyone learn config subsystem :) (moizer, 15:50:42)
    26. FYI, In the ODL in 5 minutes series Ed has started first few episodes are related to config subsystem http://www.opendaylight.org/blogs/2014/07/opendaylight-5-minutes-or-less-video-series (raghu67, 15:52:34)
    27. ACTION: alagalah to be guinea pig to go through documentation linked in this meetbot to see if its useful for a noob to learn config subsystem... target: 10/13 (alagalah, 15:54:22)
    28. ACTION: rovarga to provide examples of how to to live reconfiguration to devinavery (and probably the controller-dev list) (colindixon, 15:55:20)
    29. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Config:Examples:Netconf#Spawning_additional_netconf_connector_while_controller_is_running this maybe the result of that action item (colindixon, 15:55:34)

  5. wrap up (colindixon, 15:57:37)
    1. devinavery notes that it sounds like we want to go understand things and refactor the wiki docs this week (colindixon, 15:58:06)
    2. devinavery asks if we could do that sooner in the week, that would be good since then we could iterate before next week (colindixon, 15:58:44)
    3. alagalah notes that in his opinion, its not that the issue is that we need new features, its just that the config subsystem is hard to consume without documentation/tutorials, so that they can get enough proficiency in it to identify what features are missing (alagalah, 15:58:53)


Meeting ended at 16:04:31 UTC (full logs).

Action items

  1. colindixon to help try and convert this page into a step-by-step gude: https://wiki.opendaylight.org/view/OpenDaylight_Controller:Config:Examples:Sample_Project
  2. Everyone learn config subsystem :)
  3. alagalah to be guinea pig to go through documentation linked in this meetbot to see if its useful for a noob to learn config subsystem... target: 10/13
  4. rovarga to provide examples of how to to live reconfiguration to devinavery (and probably the controller-dev list)


Action items, by person

  1. alagalah
    1. alagalah to be guinea pig to go through documentation linked in this meetbot to see if its useful for a noob to learn config subsystem... target: 10/13
  2. colindixon
    1. colindixon to help try and convert this page into a step-by-step gude: https://wiki.opendaylight.org/view/OpenDaylight_Controller:Config:Examples:Sample_Project
  3. devinavery
    1. rovarga to provide examples of how to to live reconfiguration to devinavery (and probably the controller-dev list)
  4. rovarga
    1. rovarga to provide examples of how to to live reconfiguration to devinavery (and probably the controller-dev list)


People present (lines said)

  1. colindixon (47)
  2. alagalah (41)
  3. jmedved (25)
  4. odl_meetbot (11)
  5. moizer (6)
  6. devinavery (5)
  7. raghu67 (3)
  8. mlemay_ (2)
  9. mmarsale (2)
  10. rovarga (2)


Generated by MeetBot 0.1.4.