16:13:06 <colindixon> #startmeeting docs
16:13:06 <odl_meetbot> Meeting started Wed Mar  4 16:13:06 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:13:06 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:13:06 <odl_meetbot> The meeting name has been set to 'docs'
16:13:12 <colindixon> #topic agenda bashing
16:13:23 <colindixon> #info future webex/meeting venues
16:13:38 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/status:open+project:docs incoming patches for us to review
16:13:46 <dneary> Hi there
16:14:08 <dneary> Hangout says it's over
16:14:22 <dneary> Are people on Webex now?
16:15:31 <colindixon> yeah
16:15:46 <colindixon> https://cisco.webex.com/ciscosales/j.php?MTID=mc3e15ff840fe00b786ee56675541955b
16:16:33 <colindixon> #info the state of the documentation info for projects
16:17:33 <colindixon> #topic future meetings for WebEX
16:17:58 <colindixon> #action colindixon to reach out to phrobb and get the LF webex to use for this meeting and update the invite and meeting info
16:18:18 <colindixon> #topic state of docs info and walkthorughs for projects
16:19:03 <Moi> Ok, i am in
16:20:06 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Lithium_Project_Documentation_Requirements#Step-by-step_Guide this is the steb-by-step process for submitting docs (and specificially outlines) that we sent out
16:21:01 <colindixon> #info if anyone wants to review these steps or the templates, please do
16:21:49 <colindixon> #info you can find the templates if you clone the docs repo and look in the manuals/readme/src/main/asciidoc folder (also listed in the step-by-step)
16:23:12 <colindixon> #info manny asks if we’re copying the helium docs over
16:23:29 <colindixon> #info colindixon says not in a file-by-file but we will likely encourage projects to copy content over
16:24:08 <dneary> Getting on the call
16:24:13 <colindixon> #topic incoming docs to review
16:24:27 <dneary> Needed to manually enter the webex link on my phone (no IRC on phone)
16:24:30 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/status:open+project:docs we already have 4 incoming patches to review
16:25:03 <colindixon> #info we should expect ~20 total in the next 36 hours
16:25:36 <Moi> what's the date for finishing review for the docs?
16:26:03 <colindixon> #info Moi asks when when we need to finish reviewing docs
16:26:38 <colindixon> #info colindixon says there’s no real deadline, next week would be a good target to get them reviewed and as many as possible merged
16:30:22 <colindixon> #info manny asks what we should be looking for as we review things, colindixon says that we should be looking for basic grammar and formatting issues as well as if the overall structure makes sense (which it should because they’re copying templates)
16:32:54 <colindixon> #info dneary asks about gerrit workflow if there’s any point to add comments to something that already has a -1, colindixon says yes
16:35:03 <colindixon> #info dneary aks gerrit workflow and if there’s a way to see the diffs between patch sets, colindixon says there is, you click on the patch set numbers at the top of the files in the diff view
16:35:37 <dneary> "project:docs reviewer:self"shows me all of my comments by the way.
16:35:41 <dneary> Thanks colindixon
16:35:47 <colindixon> dneary: yeah
16:35:52 <colindixon> I can give some more cool queries later
16:42:57 <colindixon> #action colindixon to add to the process that when you push a new patch addressing feedback to add a +0 comment saying what you’ve addressed
16:43:39 <colindixon> #topic Helium-SR2 docs
16:44:07 <colindixon> #info Helium-SR2 was release a while ago, there were some changes to VTN docs in the user guide and developer guide
16:44:16 <colindixon> #info we didn’t post them to the downloads page
16:44:27 <colindixon> #action colindixon to make sure we get those posted
16:45:06 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Helium-SR2_Combined_Release_Notes Helium-SR2 combined release notes
16:47:17 <colindixon> #link https://git.opendaylight.org/gerrit/gitweb?p=docs.git;a=blob;f=manuals/install-guide/src/main/asciidoc/core-release-notes.adoc;h=0769a391f7dd69baa7001719eee20feeaaddf250;hb=refs/heads/stable/helium here’s an example of what I did for Helium-SR1
16:47:27 <colindixon> #info if anyone has time to do that, it would be great
16:48:13 <colindixon> #topic docs action items
16:48:34 <colindixon> #link https://docs.google.com/spreadsheets/d/1yAsfKJitnKM82D8s-2aHtoUaFQszD23zFqKWA9fuKro/edit?pli=1#gid=0 spreadsheet for tracking action items
16:48:52 <colindixon> #action colindixon to link the action items spreadsheet into the docs group main page
16:58:46 <colindixon> #info everyone reviews and updates the action items
17:03:36 <colindixon> #action dneary to move the openstack guide to asciidoc if that makes sense
17:04:06 <colindixon> #action dneary to start a thread on the documentation mailing list about why/if we should be using AsciiDoc in git and tools that might make it easier
17:05:03 <colindixon> #info colindixon notes that the two reasons he’s aware of to use it are:
17:05:04 <colindixon> #info (1) to get useable versions of documentation for specific releases that can also be updated, e.g., to have a stable/helium branch
17:05:41 <colindixon> #info (2) so that we can produce PDFs for docs that really should be downloads with the software, e.g., the quckstart/install guide
17:05:44 <colindixon> #endmeeting