#opendaylight-docs: docs

Meeting started by colindixon at 15:08:55 UTC (full logs).

Meeting summary

  1. upcoming deadlines (colindixon, 15:09:05)
    1. M4 is quickly coming up (4/16) and we need complete drafts by then (colindixon, 15:09:21)
    2. we should just be aware of that and try to make sure we can do the best (colindixon, 15:11:31)

  2. quick start guide (colindixon, 15:11:35)
    1. Manny note sthat Shahida asked last time about whether we should have a quick start guide or not (colindixon, 15:12:22)
    2. colindixon says that in his mind the installation guide is the quick start guide (colindixon, 15:12:40)
    3. https://www.opendaylight.org/sites/opendaylight/files/bk-install-guide-20141002.pdf colindixon notes that for most projects the installation guide will look like table 1.1 on page 8 of the Helium installation guide (colindixon, 15:16:42)
    4. ACTION: colindixon to work with Moi to get the directory strucgture fo the installation/qsg stuff to provide security considerations (colindixon, 15:19:17)
    5. shahida asks should we rename it to “Getting Started” or “Quick Start Guide” instead of “Installation Guide” (colindixon, 15:23:08)
    6. Manny says it makes more sense to him to call it “Getting Started” (colindixon, 15:23:20)
    7. Moi also chimes in for that (colindixon, 15:23:29)
    8. ACTION: colindixon to change the name to getting started (colindixon, 15:23:44)
    9. ACTION: Moi and Shahida to check in their content once it’s renamed (colindixon, 15:24:06)
    10. as part of the getting started docuemnt, we probalby want to show the basics of how to get the DLUX UI up, how to connectto mininet, and maybe even how to make a REST(CONF) call (colindixon, 15:25:47)
    11. ACTION: Shahida to e-mail Manny to ask him to add those to the tracking doc (colindixon, 15:26:37)

  3. projects doing their docs (colindixon, 15:27:35)
    1. https://lists.opendaylight.org/pipermail/documentation/2015-March/000401.html only 12 of 44 projects have given us docs of any kind (colindixon, 15:28:01)
    2. somebody on the docs team has now (as of last night) reviewed or merged every patch we’ve gotten so far (colindixon, 15:28:25)
    3. Moi asks what we do if they don’t do it (colindixon, 15:28:37)
    4. there are a few options: (i) yell at them, (ii) just ship without docs for them, or (iii) ask the TSC to drop them from the release (colindixon, 15:29:13)
    5. https://meetings.opendaylight.org/opendaylight-meeting/2015/weekly_lithium_irc_sync/opendaylight-meeting-weekly_lithium_irc_sync.2015-03-25-14.30.html colindixon raised the issue of nobody giving us docs on the weekly sync call (colindixon, 15:30:56)

  4. user guide (colindixon, 15:31:31)
    1. Manny reached out to ttkacik about user guide content (colindixon, 15:32:22)
    2. Manny hasn’t heard back from him at all (colindixon, 15:32:37)
    3. the core question is what non-project-specific user information needs to be done (colindixon, 15:35:01)
    4. colindixon asks if we actually need any detailed insturctions for the user guide or if that is almost all going to be in the Getting Started Guide (colindixon, 15:36:01)
    5. Moi says we need some front-matter, e.g., an introduction to bind things together (colindixon, 15:36:21)
    6. colindixon isn’t sure that we actually need anything beyond the introduction and references, he suspects not, at least for the user guide (colindixon, 15:38:28)
    7. https://www.opendaylight.org/sites/opendaylight/files/User-Guide-Helium-SR2.pdf Divya points out that the current user guide is purely project-oriented (colindixon, 15:42:19)
    8. Divya asks if we should have some high-level cross-project documentation/integration isseus (colindixon, 15:43:08)

  5. going back to the getting started guide (colindixon, 15:43:37)
    1. http://www.opendaylight.org/resources/getting-started-guide Shahida points out that we should figure out how to merge our content with this page (colindixon, 15:43:57)
    2. colindixon notes that we should probably move sections 1-4 from the Helium user guide to the gettings started guide (colindixon, 15:44:36)
    3. ACTION: colindixon or Manny to e-mail the release list to ask (1) if there is non-project-specific content other than what we’re planning that needs to be developed and (2) if there are cross-project documentation sections that we should be aware of (colindixon, 15:45:38)

  6. what content are we migrating and editing from Helium to Lithium (colindixon, 15:49:57)
    1. colindixon says in his mind it’s sections 1-4 of the user guide and the installation guide (which as of now) we’re talking about merging and making the getting started guide (colindixon, 15:50:25)

  7. developer guide front matter (colindixon, 15:53:11)
    1. right now the front matter is really just about git and gerrit, which is more about contributing to opendaylight than developing on top of opendayligh (colindixon, 15:53:49)
    2. we might want to leave the part about downloading the code (colindixon, 15:54:01)
    3. Moi says we probably want to add sections about how to develop apps on top of OpenDaylight (colindixon, 15:54:25)
    4. one section is really about building an MD-SAL app for ODL in Java (there are wiki pages about this) (colindixon, 15:54:51)
    5. ACTION: colindixon to find the Ed’s getting started archetype wiki pages so we can maybe just use that (colindixon, 15:55:10)
    6. the other major part would be developing using REST/RESTCONF and I’m not sure where to go steal that from (colindixon, 15:55:33)
    7. ACTION: colindixon to e-mail manny to add those two sections to the task list doc (colindixon, 15:55:48)

  8. next meeting (colindixon, 15:57:26)
    1. we should go over the task list next time (colindixon, 15:57:32)


Meeting ended at 15:57:35 UTC (full logs).

Action items

  1. colindixon to work with Moi to get the directory strucgture fo the installation/qsg stuff to provide security considerations
  2. colindixon to change the name to getting started
  3. Moi and Shahida to check in their content once it’s renamed
  4. Shahida to e-mail Manny to ask him to add those to the tracking doc
  5. colindixon or Manny to e-mail the release list to ask (1) if there is non-project-specific content other than what we’re planning that needs to be developed and (2) if there are cross-project documentation sections that we should be aware of
  6. colindixon to find the Ed’s getting started archetype wiki pages so we can maybe just use that
  7. colindixon to e-mail manny to add those two sections to the task list doc


Action items, by person

  1. colindixon
    1. colindixon to work with Moi to get the directory strucgture fo the installation/qsg stuff to provide security considerations
    2. colindixon to change the name to getting started
    3. colindixon or Manny to e-mail the release list to ask (1) if there is non-project-specific content other than what we’re planning that needs to be developed and (2) if there are cross-project documentation sections that we should be aware of
    4. colindixon to find the Ed’s getting started archetype wiki pages so we can maybe just use that
    5. colindixon to e-mail manny to add those two sections to the task list doc
  2. Moi
    1. colindixon to work with Moi to get the directory strucgture fo the installation/qsg stuff to provide security considerations
    2. Moi and Shahida to check in their content once it’s renamed


People present (lines said)

  1. colindixon (50)
  2. dneary (4)
  3. odl_meetbot (3)
  4. Moi (2)


Generated by MeetBot 0.1.4.