15:08:55 <colindixon> #startmeeting docs
15:08:55 <odl_meetbot> Meeting started Wed Mar 25 15:08:55 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:08:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:08:55 <odl_meetbot> The meeting name has been set to 'docs'
15:09:05 <colindixon> #topic upcoming deadlines
15:09:21 <colindixon> #info M4 is quickly coming up (4/16) and we need complete drafts by then
15:11:31 <colindixon> #info we should just be aware of that and try to make sure we can do the best
15:11:35 <colindixon> #topic quick start guide
15:12:22 <colindixon> #info Manny note sthat Shahida asked last time about whether we should have a quick start guide or not
15:12:40 <colindixon> #info colindixon says that in his mind the installation guide is the quick start guide
15:16:42 <colindixon> #link https://www.opendaylight.org/sites/opendaylight/files/bk-install-guide-20141002.pdf colindixon notes that for most projects the installation guide will look like table 1.1 on page 8 of the Helium installation guide
15:17:45 <Moi> Do we need a getting started folder to put the GSG and the security considerations in? Who can create that folder? I checked in the security doc in the installation folder but abandoned it thinking it should go into the GSG folder.
15:18:27 <colindixon> Moi: I can help
15:18:45 <Moi> okay, great! Thanks, Colin.
15:19:17 <colindixon> #action colindixon to work with Moi to get the directory strucgture fo the installation/qsg stuff to provide security considerations
15:23:08 <colindixon> #info shahida asks should we rename it to “Getting Started” or “Quick Start Guide” instead of “Installation Guide”
15:23:20 <colindixon> #info Manny says it makes more sense to him to call it “Getting Started”
15:23:29 <colindixon> #info Moi also chimes in for that
15:23:44 <colindixon> #action colindixon to change the name to getting started
15:24:06 <colindixon> #action Moi and Shahida to check in their content once it’s renamed
15:25:47 <colindixon> #info as part of the getting started docuemnt, we probalby want to show the basics of how to get the DLUX UI up, how to connectto mininet, and maybe even how to make a REST(CONF) call
15:26:37 <colindixon> #action Shahida to e-mail Manny to ask him to add those to the tracking doc
15:27:35 <colindixon> #topic projects doing their docs
15:28:01 <colindixon> #link https://lists.opendaylight.org/pipermail/documentation/2015-March/000401.html only 12 of 44 projects have given us docs of any kind
15:28:25 <colindixon> #info somebody on the docs team has now (as of last night) reviewed or merged every patch we’ve gotten so far
15:28:37 <colindixon> #info Moi asks what we do if they don’t do it
15:29:13 <colindixon> #info there are a few options: (i) yell at them, (ii) just ship without docs for them, or (iii) ask the TSC to drop them from the release
15:30:56 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/weekly_lithium_irc_sync/opendaylight-meeting-weekly_lithium_irc_sync.2015-03-25-14.30.html colindixon raised the issue of nobody giving us docs on the weekly sync call
15:31:31 <colindixon> #topic user guide
15:32:22 <colindixon> #info Manny reached out to ttkacik about user guide content
15:32:37 <colindixon> #info Manny hasn’t heard back from him at all
15:35:01 <colindixon> #info the core question is what non-project-specific user information needs to be done
15:36:01 <colindixon> #info colindixon asks if we actually need any detailed insturctions for the user guide or if that is almost all going to be in the Getting Started Guide
15:36:21 <colindixon> #info Moi says we need some front-matter, e.g., an introduction to bind things together
15:38:28 <colindixon> #info colindixon isn’t sure that we actually need anything beyond the introduction and references, he suspects not, at least for the user guide
15:42:19 <colindixon> #link https://www.opendaylight.org/sites/opendaylight/files/User-Guide-Helium-SR2.pdf Divya points out that the current user guide is purely project-oriented
15:43:08 <colindixon> #info Divya asks if we should have some high-level cross-project documentation/integration isseus
15:43:37 <colindixon> #topic going back to the getting started guide
15:43:57 <colindixon> #link http://www.opendaylight.org/resources/getting-started-guide Shahida points out that we should figure out how to merge our content with this page
15:44:36 <colindixon> #info colindixon notes that we should probably move sections 1-4 from the Helium user guide to the gettings started guide
15:45:38 <colindixon> #action colindixon or Manny to e-mail the release list to ask (1) if there is non-project-specific content other than what we’re planning that needs to be developed and (2) if there are cross-project documentation sections that we should be aware of
15:49:57 <colindixon> #topic what content are we migrating and editing from Helium to Lithium
15:50:25 <colindixon> #info colindixon says in his mind it’s sections 1-4 of the user guide and the installation guide (which as of now) we’re talking about merging and making the getting started guide
15:52:49 <dneary> colindixon, I sent you an openstack.adoc file - for some reason pushing it to Gerrit wasn't working
15:52:52 <dneary> (maybe I'm doing it wrong)
15:53:04 <colindixon> dneary: I’ll look at it in a second
15:53:06 <dneary> I'm in a Real Life meeting here, couldn't attend today
15:53:11 <colindixon> #topic developer guide front matter
15:53:28 <dneary> It's a pure formatting swap, no new content
15:53:49 <colindixon> #info right now the front matter is really just about git and gerrit, which is more about contributing to opendaylight than developing on top of opendayligh
15:54:01 <colindixon> #info we might want to leave the part about downloading the code
15:54:25 <colindixon> #info Moi says we probably want to add sections about how to develop apps on top of OpenDaylight
15:54:51 <colindixon> #info one section is really about building an MD-SAL app for ODL in Java (there are wiki pages about this)
15:55:10 <colindixon> #action colindixon to find the Ed’s getting started archetype wiki pages so we can maybe just use that
15:55:33 <colindixon> #info the other major part would be developing using REST/RESTCONF and I’m not sure where to go steal that from
15:55:48 <colindixon> #action colindixon to e-mail manny to add those two sections to the task list doc
15:57:26 <colindixon> #topic next meeting
15:57:32 <colindixon> #info we should go over the task list next time
15:57:35 <colindixon> #endmeeting