#opendaylight-docs: docs

Meeting started by colindixon at 20:02:06 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 20:02:44)
    1. https://meetings.opendaylight.org/opendaylight-docs/2017/docs/opendaylight-docs-docs.2017-01-17-20.11.html last week's meeting minutes (colindixon, 20:03:16)
    2. ACTION: colindixon to help lisa caywood hunt people down and get the openstack docs updated (colindixon, 20:05:37)
    3. ACTION: CaseyODL, colindixon, Lisa and beau to compare notes on what tutorials we're looking for and what we have (colindixon, 20:05:38)
    4. ACTION: colindixon to work with anipbu to figure out how to provide new or updated information for new projects and/or new features (colindixon, 20:05:40)
    5. ACTION: colindixon to add a section to the release notes script to at least put in a TBD for security advisories (colindixon, 20:05:41)
    6. ACTION: colindixon to get notes on how to run the release notes generator and automate it (colindixon, 20:05:42)
    7. CaseyODL says that we need to include all publicly known security issues that are fixed in each release in the relase notes to get the core infrastructure LF security badge thing (colindixon, 20:07:48)

  2. OPNFV docs overview from ShuhamRathi (colindixon, 20:08:36)
    1. https://opnfv.readthedocs.io/en/latest/ first migration is done (colindixon, 20:09:24)
    2. there's a non-blocking bug where RTD shows a build failure when the build is actually updating (colindixon, 20:09:47)
    3. http://www.sphinx-doc.org/en/stable/markup/inline.html#ref-role how to handle hyperlinks (colindixon, 20:18:19)
    4. http://docs.opendaylight.org/en/latest/documentation.html#referencing-sections the ODL-specific stuff (colindixon, 20:19:05)
    5. ACTION: zxiiro and colindixon to look into breaking the build when we have broken :ref: links (colindixon, 20:21:02)
    6. https://git.opendaylight.org/gerrit/#/c/49783/ documentation on how to create submodules (colindixon, 20:25:28)
    7. zxiiro says that we now build right the batch on merge jobs by doing curl -X POST --data "version_slug=$RTD_BUILD_VERSION" https://readthedocs.org/build/opendaylight (colindixon, 20:28:54)
    8. in reality because master => latest and stable/boron to stable-boron, I think we just build them all on every merge (colindixon, 20:29:13)
    9. see other commentary from zxiiro in the full logs (colindixon, 20:38:18)
    10. ACTION: colindixon to migrate the common docs tasks off the wiki to documentation https://wiki.opendaylight.org/view/Documentation/Tools#Common_Doc_Tasks (colindixon, 20:43:06)
    11. http://wiki.c2.com/?LazinessImpatienceHubris (colindixon, 20:43:50)


Meeting ended at 20:44:57 UTC (full logs).

Action items

  1. colindixon to help lisa caywood hunt people down and get the openstack docs updated
  2. CaseyODL, colindixon, Lisa and beau to compare notes on what tutorials we're looking for and what we have
  3. colindixon to work with anipbu to figure out how to provide new or updated information for new projects and/or new features
  4. colindixon to add a section to the release notes script to at least put in a TBD for security advisories
  5. colindixon to get notes on how to run the release notes generator and automate it
  6. zxiiro and colindixon to look into breaking the build when we have broken :ref: links
  7. colindixon to migrate the common docs tasks off the wiki to documentation https://wiki.opendaylight.org/view/Documentation/Tools#Common_Doc_Tasks


Action items, by person

  1. colindixon
    1. colindixon to help lisa caywood hunt people down and get the openstack docs updated
    2. CaseyODL, colindixon, Lisa and beau to compare notes on what tutorials we're looking for and what we have
    3. colindixon to work with anipbu to figure out how to provide new or updated information for new projects and/or new features
    4. colindixon to add a section to the release notes script to at least put in a TBD for security advisories
    5. colindixon to get notes on how to run the release notes generator and automate it
    6. zxiiro and colindixon to look into breaking the build when we have broken :ref: links
    7. colindixon to migrate the common docs tasks off the wiki to documentation https://wiki.opendaylight.org/view/Documentation/Tools#Common_Doc_Tasks
  2. zxiiro
    1. zxiiro and colindixon to look into breaking the build when we have broken :ref: links


People present (lines said)

  1. colindixon (28)
  2. zxiiro (18)
  3. odl_meetbot (4)


Generated by MeetBot 0.1.4.