#opendaylight-genius: Genius Weekly 10/25/2018

Meeting started by faseelak at 14:01:23 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (faseelak, 14:01:45)
    1. https://jira.opendaylight.org/browse/GENIUS-217 (faseelak, 14:02:01)
    2. Vishal (vthapar, 14:04:11)

  2. Neon MRI Bump (faseelak, 14:06:30)
    1. vthapar has pushed patches for genius (faseelak, 14:06:59)
    2. multi patch for genius looks good (faseelak, 14:07:18)
    3. https://git.opendaylight.org/gerrit/76414 (vthapar, 14:07:22)

  3. ITM Direct Tunnels Bug (faseelak, 14:07:35)
    1. Tarun and Nishchaya debugging the issue and working on a fix (faseelak, 14:08:03)
    2. Tarun updates the CSIT randomly fails for netvirt, and in such cases default tzone is not created (faseelak, 14:08:57)
    3. Tarun says the recently merged patch on ITM auto tunnels causing this (faseelak, 14:09:26)
    4. faseelak asks for the patch link for the merged one (faseelak, 14:11:11)
    5. https://git.opendaylight.org/gerrit/#/c/76201/ (faseelak, 14:12:09)
    6. faseelak says it is better to revert the patch, so that others are unblocked (faseelak, 14:12:30)
    7. Edwin has a patch for the revert (faseelak, 14:12:38)
    8. https://git.opendaylight.org/gerrit/#/c/77162/ (faseelak, 14:12:49)

  4. Discussion on EntityOwnershipUtils (faseelak, 14:13:33)
    1. Tarun says there is an issue the current implementation of EntityOwnershipUtils (faseelak, 14:13:51)
    2. Tarun says in case of an InterruptedException, EntityOwnershipUtils won't proceed with isEntityOwner check (faseelak, 14:15:21)
    3. vthapar says such a chance is very unlikely and that cannot be the cause for the ITM Auto tunnels issue (faseelak, 14:15:47)
    4. more like, why is eos status not available. (vthapar, 14:17:09)
    5. vthapar gives inputs on how to handle entity ownership registration in a proper way, Tarun to try that out (faseelak, 14:23:20)
    6. ACTION: vthapar faseelak to review the initial patch to see what is wrong in the implementation (faseelak, 14:23:43)

  5. Updated Genius Dashboard (faseelak, 14:25:19)
    1. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10406 (faseelak, 14:25:25)
    2. faseelak has updated the dashboard to include Release checkpoints and Genius meetings (faseelak, 14:26:34)
    3. thanks to shague for the help :) (faseelak, 14:26:50)

  6. Genius HA Tests (faseelak, 14:27:21)
    1. Karthika working on HA Tests for Genius (faseelak, 14:27:28)
    2. needs help on triaging one issue seen, faseelak to help (faseelak, 14:27:39)

  7. cookies (vthapar, 14:33:27)


Meeting ended at 14:33:30 UTC (full logs).

Action items

  1. vthapar faseelak to review the initial patch to see what is wrong in the implementation


Action items, by person

  1. faseelak
    1. vthapar faseelak to review the initial patch to see what is wrong in the implementation
  2. vthapar
    1. vthapar faseelak to review the initial patch to see what is wrong in the implementation


People present (lines said)

  1. faseelak (30)
  2. vthapar (8)
  3. odl_meetbot (4)
  4. shague (2)


Generated by MeetBot 0.1.4.