#opendaylight-group-policy: gbp_status_arch

Meeting started by tbachman at 15:02:15 UTC (full logs).

Meeting summary

    1. committers please #info in (tbachman, 15:03:05)
    2. tbachman (tbachman, 15:03:07)
    3. alagalah (alagalah, 15:03:13)

  1. agenda (tbachman, 15:03:32)
    1. https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Team_Meeting (alagalah, 15:03:41)
    2. https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Team_Meeting Link to agenda (tbachman, 15:03:42)
    3. https://meetings.opendaylight.org/opendaylight-group-policy/2015/gbp_status_arch/opendaylight-group-policy-gbp_status_arch.2015-07-22-15.00.html Minutes from last week’s meeting (tbachman, 15:03:54)

  2. ODL Summit (tbachman, 15:04:01)
    1. alagalah says when the CFP came out for ODL summit, we were in the middle of heavy development for Lithium (SFC and neutron integration) — we weren’t sure what we’d be able to get done at the time (tbachman, 15:05:31)
    2. alagalah said that we did have OpenStack GBP integrated with ODL GBP, so we knew we could demonstrate that. (tbachman, 15:06:15)
    3. alagalah demonstrated the GBP neutron integration at the summit — went off great, with minor hitch of external connectivity, which he fixed by the end of the session (tbachman, 15:06:47)
    4. The summit has had some great sessions — including a panel with edwarnicke, ebrjohn, dfarrell07, colindixon, and ttkacik (tbachman, 15:15:34)
    5. There was also a session that alagalah was on with policy, including Tim Hinrichs, mlemay (tbachman, 15:16:12)
    6. alagalah says there were a lot of discussion on GBP and SFC collaboration — folks were referencing that as a great example of cross-project collaboration (tbachman, 15:16:46)

  3. IETF Prague (tbachman, 15:16:57)
    1. alagalah says it was his first time attending the IETF (tbachman, 15:17:15)
    2. alagalah says that one of the issues with the existing vagrant demo is the time it takes to stand up the VMs. He changed the setup at the summit to include a box file, which makes it quicker to stand up the VMs. (tbachman, 15:20:08)
    3. alagalah says this allows the 6 VMs to be stood up in 5 minutes — a huge improvement (tbachman, 15:20:34)
    4. alagalah is going to check with dfarrell07 about possible ways of improving the packaging (tbachman, 15:21:08)
    5. Dave Dolson from Sandvine helped improve the existing GBP+SFC demo as well (tbachman, 15:21:56)
    6. alagalah said folks from Qosmos were looking into L4-L7 classification for GBP (tbachman, 15:22:42)
    7. alagalah says the biggest feedback for the demo was that it gave a demo environment that people could use for development iteration (tbachman, 15:23:07)
    8. alagalah says he’s thinking of creating 3 levels of entry for hackfest — reflecting skill-set and knowledge of those getting involved (tbachman, 15:23:38)
    9. The idea is that each level has a different type/depth of instruction — those at the first level (entry-level) would require more background, those at the last level (expert) would require less (tbachman, 15:24:23)
    10. alagalah says there’s a tool in webex that alllows folks to break out into different “training rooms”. This may be helpful for hackfests as well (tbachman, 15:24:47)
    11. For level 2, alagalah would like to come up with a predefined set of coding tasks that are achievable in a 2-day period for the hackfests — also looking into tracking things like this with trello. (tbachman, 15:25:44)
    12. Level 3 would be pretty deep/involved development tasks (tbachman, 15:25:57)
    13. alagalah says that GBP is getting involved with the OPNFV SFC project. (tbachman, 15:26:28)
    14. alagalah says there are other things in OPNFV that are also of interest to GBP — he’s going to propose GBP as an OPNFV project, which provides a platform for policy and integration of GBP in OPNFV (tbachman, 15:27:32)
    15. alagalah believes the SFC project in OPNFV is going to be the marquee feature in the “B” release for OPNFV (tbachman, 15:27:57)
    16. alagalah says the [SFC] tag on the OPNFV has had a lot of discussion — folks interested should subscribe and follow (tbachman, 15:28:37)
    17. alagalah says he’d like to look into a vCPE use case in OPNFV, with GBP (tbachman, 15:29:13)
    18. A CPE at home has a lot of features, which don’t need to be in the CPE itself, and could be moved to the carrier equipment — simpler devices at the edge (tbachman, 15:30:11)
    19. You could then leverage GBP and SFC to create the behaviors that you want (tbachman, 15:30:32)
    20. alagalah encourages folks with thoughts on vCPE type use cases to email the groupbasedpolicy-dev or opnfv-tech mailing list (with [SFC] tag) (tbachman, 15:32:05)

  4. Beryllium Release Plan (tbachman, 15:34:21)
    1. alagalah is going to work out an unconference for tomorrow to discuss the Beryllium release plan for GBP (tbachman, 15:34:37)
    2. alagalah says if people are interested, he’d like to start the release plan tomorrow with suggestions from folks with interests/suggestions of what they’d like to see in Beryllium (tbachman, 15:35:21)
    3. alagalah says that it’s important to bring resources along with their idea, in order to commit the resources for the Beryllium release (tbachman, 15:35:55)
    4. alagalah says he’s going to look into two webex sessions to handle different time zones (tbachman, 15:36:29)

  5. Stable Lithium (tbachman, 15:37:50)
    1. tbachman has been talking with the LF folks on options for standing up ubuntu resources — we may be able to fix that, but LF is also moving to a private cloud which solves some of the problems (tbachman, 15:40:32)
    2. tbachman has stood up clustering setups and verified that it can work — need to bring up a single node first so that it’s the leader of all the shards (tbachman, 15:44:15)
    3. ACTION: tbachman to talk with moizer and/or pantellis to ask if we can configure co-location of shards (tbachman, 15:44:36)

  6. Trello (tbachman, 15:44:46)
    1. alagalah was hoping to keep things at a high-level “User Story” level for Trello tasks (tbachman, 15:45:21)
    2. alagalah says that for documentation, wonders if we can move the project’s documentation from the docs project to the groupbasedpolicy repo (tbachman, 15:46:26)
    3. alagalah says having the documentation in the local repo may help keep documentation from being an afterthought — would like to see iteration on docs on the same order as we do for code (tbachman, 15:47:11)
    4. alagalah says that if we submit code, we should think about submitting patches to docs explaining the code/feature, if relevant (tbachman, 15:47:33)
    5. alagalah was going to talk with colindixon about the possibility of the documentation project pulling from projects (tbachman, 15:49:42)
    6. martin_sunal says it allows us to track changes in groupbasedpolicy and not the docs project, and have editorial control (tbachman, 15:51:53)
    7. Dileep asks whether the time is fixed for the unconference — is interested in attending other sessions and wants to know if there are any scheduling conflicts (tbachman, 15:53:03)
    8. alagalah says that he thinks that folks get together at the start of the summit, and you can propose an unconference; topics are picked based on top interests (alagalah encourages folks to vote for GBP topic) (tbachman, 15:54:02)
    9. alagalah says that even if we don’t have an unconference room, we’ll find a place at the summit to hold our sessions (tbachman, 15:54:22)


Meeting ended at 15:56:09 UTC (full logs).

Action items

  1. tbachman to talk with moizer and/or pantellis to ask if we can configure co-location of shards


Action items, by person

  1. tbachman
    1. tbachman to talk with moizer and/or pantellis to ask if we can configure co-location of shards


People present (lines said)

  1. tbachman (72)
  2. odl_meetbot (4)
  3. alagalah (3)


Generated by MeetBot 0.1.4.