21:00:29 <dfarrell07> #startmeeting integration
21:00:29 <odl_meetbot> Meeting started Thu Oct 18 21:00:29 2018 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
21:00:29 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:29 <odl_meetbot> The meeting name has been set to 'integration'
21:00:54 <dfarrell07> #chair jamoluhrsen zxiiro anipbu abelur
21:00:54 <odl_meetbot> Current chairs: abelur anipbu dfarrell07 jamoluhrsen zxiiro
21:02:03 <jamoluhrsen> #topic packaging
21:02:25 <jamoluhrsen> #info wrapping up loose ends with some broken ansible jobs. more test coverage coming in for those
21:02:55 <jamoluhrsen> #info global-jjb patch came in to fix a packaging job, but we need a new release there to help.
21:03:22 <jamoluhrsen> #info global-jjb releases every two weeks. (actually all releng releases)
21:04:43 <zxiiro> #link lf-releng mailing list https://lists.linuxfoundation.org/mailman/listinfo/lf-releng
21:05:46 <jamoluhrsen> #info puppet jobs not yet done for Neon, but patch is broken. needs more work
21:06:19 <jamoluhrsen> #topic docs
21:06:44 <zxiiro> #link intersphinx linking docs https://docs.releng.linuxfoundation.org/en/latest/project-documentation.html?highlight=intersphinx#intersphinx-linking
21:07:03 <jamoluhrsen> #info dfarrell07 trying to find a way to document which projects are in the managed release
21:07:42 <jamoluhrsen> #info there is a cross community docs meeting (3rd wed of every month)
21:08:00 <zxiiro> #link cross project mailing list https://lists.linuxfoundation.org/mailman/listinfo/lf-docs
21:08:25 <zxiiro> #link cross project docs meeting https://lists.linuxfoundation.org/pipermail/lf-docs/2018-April/000011.html
21:09:33 <jamoluhrsen> #info still looking good to getting a docs person to share with ONAP. hopefully we'll get approval
21:09:50 <anipbu> https://git.opendaylight.org/gerrit/#/c/76359/
21:09:53 <anipbu> https://git.opendaylight.org/gerrit/#/c/76357/
21:09:57 <anipbu> https://git.opendaylight.org/gerrit/#/c/76286/
21:10:26 <jamoluhrsen> https://www.irccloud.com/pastebin/DbCuMx5G/
21:11:19 <jamoluhrsen> #info hoping to close the project proposals main page this month
21:12:28 <jamoluhrsen> #info sodium release is not until 2019, but we should start thinking about that and the dates
21:12:58 <dfarrell07> #info Add Na docs here https://docs.opendaylight.org/en/latest/release-process/release-schedule.html
21:14:40 <jamoluhrsen> #action jamoluhrsen to make a column for Sodium (and more?) in the release schedule RTD page
21:15:05 <jamoluhrsen> #action or dfarrell07 can make the sodium column
21:15:42 <jamoluhrsen> #info several docs patches looking for abandonment
21:16:02 <jamoluhrsen> #action anipbu to email list of possible patches to abandon in the docs project
21:16:21 <jamoluhrsen> #topic distribution
21:21:23 <jamoluhrsen> #action jamoluhrsen to send email to intergration list about what csit jobs are getting run from multipatch
21:24:02 <jamoluhrsen> #undo
21:24:02 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2dc97d0>
21:27:19 <jamoluhrsen> #topic builder
21:28:20 <jamoluhrsen> #info clm jobs are getting migrated to the shared nexus server. but needed new global-jjb code to make this happen. work will happen next week.
21:29:28 <jamoluhrsen> #info heat scripts being rewritten to make the more generic to be used in other projects. Need to transition odl heat "code" over.
21:30:29 <dfarrell07> https://gerrit.linuxfoundation.org/infra/#/c/12958/
21:31:13 <jamoluhrsen> #info we need to migrate away from using lftools-install
21:32:00 <jamoluhrsen> #info new macro in jjb to get the lftools loaded in to the build vm
21:33:30 <jamoluhrsen> #info new macro for lftools magic is called "lf-infra-pre-build"
21:36:19 <jamoluhrsen> #info all jenkins view related code will now use view templates coming from global-jjb
21:36:48 <jamoluhrsen> #topic misc
21:37:40 <anipbu> https://docs.opendaylight.org/en/latest/release-process/branch-cutting.html#manual-steps-to-version-bump-autorelease
21:37:47 <jamoluhrsen> #info in order for self managed projects to release on their own is 3 parts
21:37:48 <anipbu> https://docs.opendaylight.org/en/stable-fluorine/release-process/project-release.html
21:37:55 <jamoluhrsen> #info 1: https://docs.opendaylight.org/en/latest/release-process/branch-cutting.html#manual-steps-to-version-bump-autorelease
21:38:02 <jamoluhrsen> #info 2: https://docs.opendaylight.org/en/stable-fluorine/release-process/project-release.html
21:38:36 <jamoluhrsen> #info 3: produce rpms or debs, but we don't have an easy way to do that (at the moment)
21:39:03 <jamoluhrsen> #info dfarrell07 points out that it could be hard to get .rpm and .deb by themselves, but they can still release their own .zip
21:39:39 <anipbu> https://docs.opendaylight.org/en/latest/release-process/managed-release.html
21:40:47 <jamoluhrsen> #info we will need to update our release plan/process docs (https://docs.opendaylight.org/en/latest/release-process/managed-release.html) to help these self managed projects know all the steps.
21:41:08 <jamoluhrsen> #info each project can host their .zip on the downloads page and work with LF marketing to "advertise" their release
21:45:47 <jamoluhrsen> #info some new ideas around our checkpoints/dates in the release. a) we can fold the code freeze and final checkpoint in to one final "code freeze checkpoint".  b) version bump checkpoint can be changed to MSI checkpoint (name change).
21:46:58 <jamoluhrsen> #info also to reduce the number of "deadlines" we don't really need the release integrated deadline and another checkpoint one day later with the version bump date.
21:47:39 <jamoluhrsen> #info collapse release start and initial checkpoint in to the same thing
21:53:10 <jamoluhrsen> #endmeeting