#opendaylight-meeting: Helium Release Review

Meeting started by gzhao at 14:31:57 UTC (full logs).

Meeting summary

  1. TSC roll in (gzhao, 14:32:20)
    1. colindixon (colindixon, 14:32:47)
    2. Phil Robb (phrobb, 14:32:53)
    3. edwarnicke (edwarnicke, 14:33:00)
    4. LuisGomez (LuisGomez1, 14:33:25)
    5. Vijay for SNBI (vjanandr_, 14:33:34)
    6. regXboi (regXboi, 14:34:14)
    7. Dana (dkutenic) for bgpcep (dkutenic, 14:34:19)
    8. tbachman for groupbasedpolicy (tbachman, 14:34:20)
    9. oflibMichal for openflowjava (oflibMichal, 14:34:26)
    10. alagalah for groubasedpolicy (alagalah, 14:34:32)
    11. gzhao for release (gzhao, 14:34:36)

  2. BPGCEP Release Review (gzhao, 14:35:15)
    1. rovarga for tcpmd5 (rovarga, 14:35:25)
    2. ttkacik for yangtools (ttkacik, 14:35:28)
    3. https://wiki.opendaylight.org/view/BGP_LS_PCEP:Helium_Release_Review (dkutenic, 14:35:46)
    4. https://wiki.opendaylight.org/view/BGP_LS_PCEP:Helium_Release_Notes (dkutenic, 14:35:56)
    5. vina_ermagan for lispflowmapping (vina_ermagan, 14:36:10)
    6. phrobb asks should docs move from wiki to structured docs for Helium (gzhao, 14:42:58)
    7. regXboi asks for structured docs commit #s (regXboi, 14:43:36)
    8. thomas packetcable (xsited1, 14:44:08)
    9. colindixon says that for at least some projects getting their documention off the wiki into structure docs (asciidoc) may not happen by monday (colindixon, 14:44:50)
    10. at the very least, we shoudl probably add a hyperlink from the asciidoc section to the wiki though (colindixon, 14:45:08)
    11. ACTION: dkutenic will commit asciidoc into doc.git (gzhao, 14:49:04)

  3. Controller Release View (gzhao, 14:49:45)
    1. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Helium_Release_Review (edwarnicke, 14:50:04)
    2. ACTION: edwarnicke to add pointers to asciidoc when/if it is availble (colindixon, 14:59:41)
    3. ACTION: edwarnicke to put a quick note in under end-of-life noting that some features are not shipping in the release vehicles, but they are still present as controller artifacts (colindixon, 15:00:33)
    4. http://nexus.opendaylight.org/content/groups/staging/org/opendaylight/integration/distribution-karaf/0.2.0-Helium-RC2/ (gzhao, 15:03:57)

  4. Yangtools Release Review (gzhao, 15:05:42)
    1. https://wiki.opendaylight.org/view/YANG_Tools:Helium:Release_Review (ttkacik, 15:06:02)
    2. https://wiki.opendaylight.org/view/YANG_Tools:Helium:Release_Notes (ttkacik, 15:06:17)
    3. colindixon notes that for Helium the features marked as end-of-lifed here are actually present but deprecated (colindixon, 15:13:14)
    4. ACTION: ttkacik will add pointers to commits for asciidoc (even if it’s just a note with a hyperlink to wiki documentation) (colindixon, 15:13:51)
    5. phrobb notes we need an EOL-plans section in the release plans so we can project user impact at the start of a dev cycle (gzhao, 15:14:45)

  5. TCPMD5 Release Review (gzhao, 15:18:12)
    1. https://wiki.opendaylight.org/view/TCPMD5:Helium_Release_Review (rovarga, 15:18:14)
    2. https://wiki.opendaylight.org/view/TCPMD5:Helium_Release_Notes (rovarga, 15:18:23)
    3. https://wiki.opendaylight.org/view/TCPMD5:Helium_Developer_Guide (rovarga, 15:19:32)
    4. ACTION: rovarga will do migrate the wiki stuff to asciidoc in docs.git or at least put a hyperlink to the wiki docs (colindixon, 15:21:02)

  6. L2Swtich Release Review (gzhao, 15:24:12)
    1. https://wiki.opendaylight.org/view/L2_Switch:Helium:Release_Review (colindixon, 15:24:47)
    2. https://git.opendaylight.org/gerrit/#/c/11258/ commit for asciidoc (colindixon, 15:25:55)
    3. regXboi suggests to have the commit # for the asciidoc in the relase review document in the future (gzhao, 15:26:22)
    4. alefan notes when the l2switch feature is installed on karaf, it doesn't deploy any adsal components -- meaning no leagcy arphandler & hosttracker (gzhao, 15:32:34)
    5. ACTION: alefan will add a link to the gerrit for the asciidoc patch in the release review (colindixon, 15:33:44)

  7. OpenFlow Protocol Library (colindixon, 15:34:17)
    1. https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes (colindixon, 15:36:38)
    2. https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes:Helium_Release_Review (colindixon, 15:39:47)
    3. ACTION: oflibMichal to move openflowjava docs to asciidoc in the docs.git (or at least provide hyperlinks to the wiki docs) (colindixon, 15:39:54)
    4. https://git.opendaylight.org/gerrit/#/c/11533/ - added ascii doc for BGPCEP (dkutenic, 15:41:27)
    5. https://git.opendaylight.org/gerrit/#/c/11535/ - added ascii doc for TCP-MD5 (dkutenic, 15:41:35)

  8. Lisp Flow Mapping (colindixon, 15:44:24)
    1. https://wiki.opendaylight.org/view/OpenDaylight_Lisp_Flow_Mapping:Helium_Release_Review (vina_ermagan, 15:44:38)
    2. https://wiki.opendaylight.org/view/OpenDaylight_Lisp_Flow_Mapping:Helium_Release_Review (vina_ermagan, 15:44:47)
    3. regXboi asks about bug 2058, lori says the fix is merged and being tested (colindixon, 15:46:37)
    4. blbalaji for SNBI (blbalaji, 15:46:40)
    5. https://git.opendaylight.org/gerrit/11505 (lori, 15:47:30)
    6. we really need to add having asciidoc commit links to the release review template for lithium (regXboi, 15:49:06)
    7. https://git.opendaylight.org/gerrit/#/c/11534/ latest asciidoc commit (colindixon, 15:50:14)

  9. SNMP4SDN (gzhao, 15:54:18)
    1. ACTION: vina_ermagan will push more updates to the lispflowmapping asciidoc and post links to gerrits to the relase review page (regXboi, 15:54:19)
    2. ACTION: vina_ermagan to clean up release review for lisp flow mapping so that it’s clear what’s for hydrogen vs. helium (notably, is the developer guide for hydrogen or helium) (regXboi, 15:54:34)
    3. ChristineH_ for SNMP4SDN (ChristineH_, 15:54:45)
    4. ACTION: vina-ermagan to ensure asciidoc commits successfully pass jenkins (regXboi, 15:54:57)
    5. https://wiki.opendaylight.org/view/SNMP4SDN:Helium_Release_Review (colindixon, 15:55:08)
    6. ACTION: ChristineH to add a link and a summary showing that snmp4sdn has no bugs (colindixon, 15:56:31)
    7. ACTION: ChristineH to migrate wiki docs to the asciidoc in docs.git (or at least add a hyperlink to the wiki documentation) (colindixon, 15:57:03)
    8. ChristineH notes that the docs are currently for hydrogen and so use the old web GUI for images and need to be fixed where they talk about VLANs (colindixon, 15:57:40)
    9. ACTION: ChristineH will add snmp4sdn helium release notes something like this from Hydrogen https://wiki.opendaylight.org/view/SNMP4SDN:Hydrogen_Release_Note (colindixon, 16:00:01)

  10. SNBI (gzhao, 16:01:47)
    1. https://wiki.opendaylight.org/view/SecureNetworkBootstrapping:HeliumReleaseReview (vjanandr_, 16:02:02)
    2. ACTION: vjanandr_ will move the wiki docs for SNBI to the asciidoc in docs.git or at least provide a hyperlink to the wiki docs (colindixon, 16:03:37)
    3. https://git.opendaylight.org/gerrit/#/c/11513/ gerrit for asciidocs (but doesn’t build) (colindixon, 16:05:06)
    4. ACTION: vjanandr_ to add a short release notes page for SNBI basing it off this https://wiki.opendaylight.org/view/Sample_Release_Notes (colindixon, 16:06:36)
    5. https://git.opendaylight.org/gerrit/#/c/11477/ link to review of SNBi asciidoc (regXboi, 16:07:37)

  11. PacketCable PCMM (colindixon, 16:08:05)
    1.  https://wiki.opendaylight.org/view/PacketCablePCMM:ReleaseReview (xsited1, 16:08:32)
    2.  https://wiki.opendaylight.org/view/PacketCablePCMM:ReleaseNotes (xsited1, 16:08:32)

  12. OVSDB (colindixon, 16:14:14)
    1. ACTION: gzhao and phrobb to work with Madhu_offline to reschedule OVSDB to thursday (colindixon, 16:14:26)

  13. group-based policy (colindixon, 16:14:57)
    1. https://wiki.opendaylight.org/view/Group_Policy:Helium-Release-Review (alagalah, 16:15:49)
    2. ACTION: alagalah to add release notes for GBP (they should be short and sweet :-) ) (colindixon, 16:16:29)
    3. ACTION: alagalah to work on getting docs (including user, dev, and howto) for GBP into asciidoc (colindixon, 16:19:10)
    4. alagalah notes that bugs 2019 and 20151 are still unresolved at this time (colindixon, 16:19:28)
    5. abhijitkumbhare for OpenFlow plugin (abhijitkumbhare, 16:20:03)
    6. alagalah notes that their bugs may not be “blockers” because they are intermittent and they are only a PoC in Helium, so even if unresolved they would like to be shipped (colindixon, 16:21:47)
    7. ACTION: colindixon to figure out how to get aggregate release notes into the docs somewhere :-/ (colindixon, 16:22:36)

  14. OpenFlow Plugin (colindixon, 16:23:23)
    1. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Helium_Release_Review (abhijitkumbhare, 16:23:47)
    2. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Helium_Release_Notes (abhijitkumbhare, 16:24:06)
    3. ACTION: abhijitkumbhare to add a page for openflow plugin release notes (use this as inspiration: https://wiki.opendaylight.org/view/Sample_Release_Notes ) (colindixon, 16:26:51)
    4. ACTION: abhijitkumbhare to migrate openflow plugin docs to asciidoc or at least provide a hyperlink to the wiki docs (note, not just a hyper link but an english phrase like: “The current <kind-of-docs> documentation for the <project> can be found on the OpenDaylight wiki here: <url>”) (colindixon, 16:27:59)
    5. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Helium_Release_Notes (colindixon, 16:29:41)
    6. colindixon notes that the openflow plugin release notes seem good enough tohim (colindixon, 16:30:55)


Meeting ended at 16:30:59 UTC (full logs).

Action items

  1. dkutenic will commit asciidoc into doc.git
  2. edwarnicke to add pointers to asciidoc when/if it is availble
  3. edwarnicke to put a quick note in under end-of-life noting that some features are not shipping in the release vehicles, but they are still present as controller artifacts
  4. ttkacik will add pointers to commits for asciidoc (even if it’s just a note with a hyperlink to wiki documentation)
  5. rovarga will do migrate the wiki stuff to asciidoc in docs.git or at least put a hyperlink to the wiki docs
  6. alefan will add a link to the gerrit for the asciidoc patch in the release review
  7. oflibMichal to move openflowjava docs to asciidoc in the docs.git (or at least provide hyperlinks to the wiki docs)
  8. vina_ermagan will push more updates to the lispflowmapping asciidoc and post links to gerrits to the relase review page
  9. vina_ermagan to clean up release review for lisp flow mapping so that it’s clear what’s for hydrogen vs. helium (notably, is the developer guide for hydrogen or helium)
  10. vina-ermagan to ensure asciidoc commits successfully pass jenkins
  11. ChristineH to add a link and a summary showing that snmp4sdn has no bugs
  12. ChristineH to migrate wiki docs to the asciidoc in docs.git (or at least add a hyperlink to the wiki documentation)
  13. ChristineH will add snmp4sdn helium release notes something like this from Hydrogen https://wiki.opendaylight.org/view/SNMP4SDN:Hydrogen_Release_Note
  14. vjanandr_ will move the wiki docs for SNBI to the asciidoc in docs.git or at least provide a hyperlink to the wiki docs
  15. vjanandr_ to add a short release notes page for SNBI basing it off this https://wiki.opendaylight.org/view/Sample_Release_Notes
  16. gzhao and phrobb to work with Madhu_offline to reschedule OVSDB to thursday
  17. alagalah to add release notes for GBP (they should be short and sweet :-) )
  18. alagalah to work on getting docs (including user, dev, and howto) for GBP into asciidoc
  19. colindixon to figure out how to get aggregate release notes into the docs somewhere :-/
  20. abhijitkumbhare to add a page for openflow plugin release notes (use this as inspiration: https://wiki.opendaylight.org/view/Sample_Release_Notes )
  21. abhijitkumbhare to migrate openflow plugin docs to asciidoc or at least provide a hyperlink to the wiki docs (note, not just a hyper link but an english phrase like: “The current <kind-of-docs> documentation for the <project> can be found on the OpenDaylight wiki here: <url>”)


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare to add a page for openflow plugin release notes (use this as inspiration: https://wiki.opendaylight.org/view/Sample_Release_Notes )
    2. abhijitkumbhare to migrate openflow plugin docs to asciidoc or at least provide a hyperlink to the wiki docs (note, not just a hyper link but an english phrase like: “The current <kind-of-docs> documentation for the <project> can be found on the OpenDaylight wiki here: <url>”)
  2. alagalah
    1. alagalah to add release notes for GBP (they should be short and sweet :-) )
    2. alagalah to work on getting docs (including user, dev, and howto) for GBP into asciidoc
  3. alefan
    1. alefan will add a link to the gerrit for the asciidoc patch in the release review
  4. colindixon
    1. colindixon to figure out how to get aggregate release notes into the docs somewhere :-/
  5. dkutenic
    1. dkutenic will commit asciidoc into doc.git
  6. edwarnicke
    1. edwarnicke to add pointers to asciidoc when/if it is availble
    2. edwarnicke to put a quick note in under end-of-life noting that some features are not shipping in the release vehicles, but they are still present as controller artifacts
  7. gzhao
    1. gzhao and phrobb to work with Madhu_offline to reschedule OVSDB to thursday
  8. oflibMichal
    1. oflibMichal to move openflowjava docs to asciidoc in the docs.git (or at least provide hyperlinks to the wiki docs)
  9. phrobb
    1. gzhao and phrobb to work with Madhu_offline to reschedule OVSDB to thursday
  10. rovarga
    1. rovarga will do migrate the wiki stuff to asciidoc in docs.git or at least put a hyperlink to the wiki docs
  11. ttkacik
    1. ttkacik will add pointers to commits for asciidoc (even if it’s just a note with a hyperlink to wiki documentation)
  12. vina_ermagan
    1. vina_ermagan will push more updates to the lispflowmapping asciidoc and post links to gerrits to the relase review page
    2. vina_ermagan to clean up release review for lisp flow mapping so that it’s clear what’s for hydrogen vs. helium (notably, is the developer guide for hydrogen or helium)
  13. vjanandr_
    1. vjanandr_ will move the wiki docs for SNBI to the asciidoc in docs.git or at least provide a hyperlink to the wiki docs
    2. vjanandr_ to add a short release notes page for SNBI basing it off this https://wiki.opendaylight.org/view/Sample_Release_Notes
  14. UNASSIGNED
    1. vina-ermagan to ensure asciidoc commits successfully pass jenkins
    2. ChristineH to add a link and a summary showing that snmp4sdn has no bugs
    3. ChristineH to migrate wiki docs to the asciidoc in docs.git (or at least add a hyperlink to the wiki documentation)
    4. ChristineH will add snmp4sdn helium release notes something like this from Hydrogen https://wiki.opendaylight.org/view/SNMP4SDN:Hydrogen_Release_Note


People present (lines said)

  1. colindixon (179)
  2. regXboi (82)
  3. gzhao (71)
  4. phrobb (41)
  5. edwarnicke (22)
  6. alagalah (21)
  7. odl_meetbot (17)
  8. dkutenic (13)
  9. vina_ermagan (11)
  10. vjanandr_ (10)
  11. rovarga (9)
  12. alefan (9)
  13. ttkacik (7)
  14. ChristineH_ (7)
  15. oflibMichal (7)
  16. abhijitkumbhare (7)
  17. xsited1 (5)
  18. lori (4)
  19. tbachman (3)
  20. dave_tucker (3)
  21. LuisGomez1 (3)
  22. moizer (1)
  23. blbalaji (1)
  24. ypahuja (1)


Generated by MeetBot 0.1.4.