15:08:06 <alagalah> #startmeeting MD-SAL Hackers meeting
15:08:06 <odl_meetbot> Meeting started Mon Oct 13 15:08:06 2014 UTC.  The chair is alagalah. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:08:06 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:08:06 <odl_meetbot> The meeting name has been set to 'md_sal_hackers_meeting'
15:08:13 <alagalah> #chair jmedved
15:08:13 <odl_meetbot> Current chairs: alagalah jmedved
15:09:59 <alagalah> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:Architecture:Clustering#Clustering_Hackers_Meeting
15:11:58 <alagalah> #topic MD-SAL usability/consumability
15:13:00 <alagalah> #info alagalah to discuss Consumability/Usability findings
15:13:03 <alagalah> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review
15:14:08 <jmedved> #info alagalah went through links documented in the irc
15:14:24 <jmedved> #info alagalah put the link to the webex in the document
15:15:11 <jmedved> #info links as posted - in good order, but you can’t follow these links as is, lot of stuff is missing
15:15:26 <jmedved> #info you can’t just follow step-by-step
15:15:54 <jmedved> #info 1st step: create a single summary page (getting started with ODL?)
15:16:15 <jmedved> #info need to publish for each tutorial a list of assumptions (knowledge, environment)
15:17:07 <jmedved> #info for example, if oyu need to know maven, you need to have links to maven; need to go through the examples and clean them up - stuff missing, code examples don’t work, port to karaf environment
15:17:23 <jmedved> #info alagalah is willing to work with anyone to clean up the pages
15:18:33 <jmedved> #info davery: started originally with the toaster and did it with the old way of md-sal interactions, new stuff came down 2 weeks after finishing
15:18:45 <jmedved> #info needs to be re-done to the new way of doing things
15:19:11 <jmedved> #info davery: toaster sample is in the source - re-gurgitate on the wiki or just explain?
15:19:35 <jmedved> #info davery: step-by-step a good idea, but then source code in the wiki needs to be maintained
15:20:58 <jmedved> #info alagalah: screen shots or command outputs clearly shown, if showing semi-complete code fragments, provide links to the source code in the repo
15:23:06 <jmedved> #info devin will help alagalah with the wiki/examples; tony and robert will be called upon; john burns will help alagalh as well
15:25:02 <jmedved> #info maros marsalek with help with the config subsystem
15:26:17 <jmedved> #info 2nd pass at the documentation - organize it; how do we make sure that is stays up-to-date?
15:27:00 <jmedved> #info alagalah: each project has tutorials and how-tos; does this fall under the controller tutorials and how-tos?
15:27:54 <jmedved> #info ttkacik suggest to show examples for controller and yang tools and embarras other projects into action
15:28:38 <jmedved> #info alagalah: documentation & examples should be part of the release review
15:29:13 <jmedved> #info alagalah: who is the contact for the controller?
15:30:11 <jmedved> #info ttkacik; it should be ewarnicke; he should come back with a way to organize the project - designated subprojects *e.g. md-sal, clustering, with a point of contact for each sub-project) and then follow the regualr release process
15:31:02 <jmedved> #info davery: may not break out the doc by project, but it may be worth to build tutorials from user’s perspective
15:32:08 <jmedved> #info davery: maybe braisntorm offline; alagalah: discuss how to structure the info and who is responsible
15:32:46 <jmedved> #info davery: need to structure the process to create the natural tie-ins
15:33:17 <jmedved> #info roavarga: since no good template, info can not be properly consumed
15:36:08 <jmedved> #info davery: provide the example for the very first thing that needs to be done; bring all links to the getting started for developers page; also point out the aspects of the projects that are being used in each step
15:36:30 <devinavery> #link https://wiki.opendaylight.org/view/GettingStarted:Developer_Main Getting started link
15:36:39 <jmedved> #info create the focal point for developers, where everything is a couple of steps away from there
15:36:46 <devinavery> #info Try and keep all content within 6 clicks of the main page if we can
15:37:14 <jmedved> #info create the focasl point so that everything is less than 6 clicks from there
15:37:54 <jmedved> #info alagalah: start with the sample project
15:39:11 <alagalah> #action alagalah to set up meeting with Devin, Tom, John Burns, Maros, and whoever wants to join, to walk through the links in the "how tos", with a consistent template style structure, incorporating alagalah's recommendations + other's input
15:40:03 <alagalah> apologies to all ... forgot to mute when typing :(
15:43:02 <jmedved> #info davery: no loud cries from the community; before going into bindings2.0, discuss the proposal more, continue getting more usability feedback around the current bindings
15:43:24 <jmedved> #info uchau: what’s the plans for the upcoming release of md-sal? is hte new bindings a part of that?
15:45:28 <jmedved> #info rovarga: on the md-sal side data broker apis needs to be finalized, some apis missing, most notably some of the dom broker apis (notification and rpc broker), for binding the requirments document still being built up, which is going slow so it will impact the adoption
15:45:51 <jmedved> #info needs to implement all the apis within the next 2-3 months to get lithium adoption
15:46:23 <jmedved> #info rovarga: finish binding 2.0 implementation by lithium so that it can be picked by in the next release cycle
15:47:52 <devinavery> #info Major concerns still on java bindings - InstanceIdentifiers take a lot of code to build them. Can we do anything smart here to reduce the amount of code to build.
15:48:20 <jmedved> #info davery also has concerns about making class names more unique
15:48:52 <devinavery> #info (Personal, not necessary from community) Can we do anything to make class names more unique. Test case is: pick any IDE, import the controller, then go in and search by class name to find a class. And ideally there should only ever be one class that matches a given name
15:50:53 <jmedved> #info rovarga: package names in class names - probably not workable within lithium time frame; but maybe have a code-completion plugin that would understand the structure of the package names
15:51:20 <jmedved> #info davery: there are other aspects, such as duplicate class names in a package
15:53:09 <jmedved> #info davery: searching the md-sal: xpath query work by davery, colindixon and rgXboi sitting there - could be a nice enhancement and usability enhancement
15:54:14 <devinavery> #info Xpath - https://git.opendaylight.org/gerrit/#/c/10490/
15:55:56 <devinavery> #info Another enhancement is to make searching the MD-SAL more usable?
16:00:03 <alagalah> #endmeeting