17:46:40 <colindixon> #startmeeting
17:46:40 <odl_meetbot> Meeting started Mon Jan 13 17:46:40 2014 UTC.  The chair is colindixon. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:46:40 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:46:57 <colindixon> ok, so let's get this meeting started
17:46:59 <phrobb> The Project leads can be found in a blue-tinted box at column K on the "Activities" tab
17:47:23 <colindixon> #info the google doc of release tasks can be found here: https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1
17:47:44 <colindixon> thanks phrobb, that's really useful
17:47:51 <dmm> nice work colin
17:48:38 <abhijitkumbhare> So how does this #stuff work? does it do anything special?
17:48:49 <dmm> phil, nice spreadsheet
17:48:57 <colindixon> so, I just want to make sure we have Madhu, cdub, RobDolin, shague_, luis, and anees
17:49:14 <dmm> abhijitkumbhare: in what sense (#stuff)?
17:49:15 <LuisGomez> i am here
17:49:17 <Madhu> colindixon: am here
17:49:17 <RobDolin> Present
17:49:17 <shague_> present
17:49:28 <colindixon> cool
17:49:43 <abhijitkumbhare> dmm: All the #info, #agreed, etc.
17:49:52 <colindixon> and do we want to just do roll call through assigned tasks or try to get "volunteers" for other tasks as well
17:50:11 <colindixon> we could really use somebody to take ownership of things like log levels and println() stuff
17:50:14 <abhijitkumbhare> there was a mention that these are useful commands
17:50:30 <colindixon> abhijitkumbhare: http://wiki.debian.org/MeetBot has the best stuff
17:50:38 <abhijitkumbhare> OK - thanks!
17:50:53 <Madhu> colindixon: log level related stuff is in each project
17:50:56 <dmm> what he said :-)
17:51:22 <Madhu> you mean removing the system.out.println yes.
17:51:36 <colindixon> Madhu: and do we need a global wrangler? at the very least we need somebody to write up guidelines for log levels
17:51:55 <colindixon> anyway, let this serve as generic call that we really need more volunteers for unassigned tasks
17:52:21 <colindixon> so, cdub and Madhu how goes the versioning stuff
17:52:47 <colindixon> I know that there was a plan to push a new target to integration, to build the daily list, but I didn't see that
17:52:54 <Madhu> colindixon: that is coming today
17:53:27 <Madhu> I just have to add a new target and will push that in.
17:53:31 <colindixon> ok, and by that, we mean the patch for integration or the patches for each project?
17:53:50 <Madhu> I am working on another 1/14 deadline (for the best practice to cut the release bundle)
17:54:08 <Madhu> the target is only for the integration
17:54:16 <colindixon> ok
17:54:28 <colindixon> do you know how cdub's work on the patches for each project are coming?
17:54:30 <Madhu> the each project stuff is to copy the jenkins job did by GiovanniMeo on the contorller
17:54:36 <Madhu> and add it to each proejct
17:54:47 <Madhu> GiovanniMeo: thinks it is better and easy to handle them in the same gerrit
17:54:57 <Madhu> that jenkins auto generates via the versions plugin
17:55:02 <colindixon> ok
17:55:07 <Madhu> instead of we generating individual patches for each pom file.
17:55:08 <colindixon> and who's doing that?
17:55:16 <Madhu> GiovanniMeo:  can u confirm ur view here ?
17:55:25 <GiovanniMeo> Madhu yes
17:55:28 <GiovanniMeo> and i have done that
17:55:28 <tykeal> abhijitkumbhare: all that #stuff is used by the chair to mark the meeting minutes that the bot is doing
17:55:31 <GiovanniMeo> on controller
17:55:32 <Madhu> colindixon: that needs admin privilege for each project
17:55:39 <GiovanniMeo> but that need to be copied to otehr projects too
17:55:44 <colindixon> #action Madhu will push a patch to integration which generates a new target to build the list of version skew so that we can track daily skew in the release
17:55:44 <Madhu> yep.
17:55:50 <abhijitkumbhare> tykeal: understood
17:56:04 <Madhu> colindixon: yes.
17:56:19 <Madhu> also shud i follow up with tykeal on copying the jenkins to each project ?
17:56:35 <Madhu> or get volunteer from each project to do that work of copying the jenkins ?
17:56:37 <GiovanniMeo> Madhu the job need also to be adapted
17:56:40 <colindixon> so, is cdub taking responsibility for talking with tykeal to move that job?
17:56:48 <colindixon> or is that Madhu or GiovanniMeo ?
17:56:51 <Madhu> colindixon: not move ... but to copy :)
17:57:03 <Madhu> if GiovanniMeo can do it... that would be awesome :)
17:57:14 <GiovanniMeo> GiovanniMeo can't
17:57:15 <Madhu> he is the original author of controller project's jenkins work
17:57:16 <GiovanniMeo> :(
17:57:20 <Madhu> :)
17:57:22 <Madhu> okay i will take that
17:57:34 <GiovanniMeo> else i would have done it :)
17:57:42 <Madhu> GiovanniMeo: of course sir.
17:57:43 <tykeal> there was some minor discussion of it last week. I made note of the CLI interface to Jenkins. It should allow folks to pull the configs now since we've got anonymous read of the configs working
17:57:55 <colindixon> #info in order to build per project version out-of-sync messages we will need to great jenkins jobs per project
17:58:00 <Madhu> tykeal: i don't have admin privilege for all the projects :(
17:58:15 <goldavberg> So how can we copy the jenkins build?
17:58:27 <Konstantin> What's the job name ?
17:58:27 <goldavberg> We need it for lispflowmapping
17:58:37 <Madhu> goldavberg: we need it for all the projects
17:58:47 <colindixon> #action Madhu will work with cdub and tykeal to migrate the *purely information* versions job to all projects participating with in the simultaneous release
17:58:53 <colindixon> right?
17:59:01 <tykeal> all of the Jenkins systems have a rest API. For instance here's the info page from the controller: https://jenkins.opendaylight.org/controller/api/
17:59:02 <Madhu> fyi : https://jenkins.opendaylight.org/controller/job/controller-version-changes/
17:59:22 <Madhu> ok. i will take this offline with tykeal, GiovanniMeo and cdub
17:59:25 <colindixon> Madhu: if you want to use #info to highlight useful things in the minutes, please feel free
17:59:31 <colindixon> perfect!
17:59:32 <colindixon> thanks!
17:59:58 <colindixon> phrobb: how goes the copyright hunting/addition?
18:00:35 <phrobb> I'm building the list of files for  each project that don't have copyrights today.. mails will go out to all the leads today or tomorrow at the latest
18:00:46 <edwarnicke> Madhu: I would say for the Jenkin's job we need to wrangle a committer from each project
18:00:54 <edwarnicke> And that same commiter could then do the fixes to get the commit in
18:01:03 <Madhu> edwarnicke: yes.
18:01:17 <phrobb> also, we have a suggested header that's been on the wiki for a while located here: https://wiki.opendaylight.org/view/Project_Proposals:Code_Prep_Suggestions#Copyright_and_license_headers_in_source_code_files
18:01:42 <colindixon> #info great phrobb, that means we can get started with the actual insertion on it's 1/15 start date
18:01:51 <Madhu> colindixon: edwarnicke shall we add a per-project action for the jenkins job work ?
18:01:57 <Madhu> and I can be the global wrangler ?
18:02:05 <goldavberg> Maybe we should create another mailing group for this
18:02:10 <edwarnicke> Guys, could we capture who is doing what in the spreadsheet?  For example, it sounds like goldavberg and Konstantin  are signing up for their projects to do the Jenkins Job
18:02:17 <colindixon> #info suggested copyright headers can be found here https://wiki.opendaylight.org/view/Project_Proposals:Code_Prep_Suggestions#Copyright_and_license_headers_in_source_code_files
18:02:18 <phrobb> colindixon: yes
18:02:27 <edwarnicke> Madhu: That would be my suggestion, and get names in there
18:02:30 <edwarnicke> And dates on it
18:02:46 <colindixon> edwarnicke: that's a good idea
18:02:47 <Madhu> edwarnicke: sure. i will take care of that.
18:03:06 <colindixon> just put it in the notes section
18:03:19 <colindixon> for now, or maybe team
18:03:25 <edwarnicke> Can we agree to use the template  https://wiki.opendaylight.org/view/Project_Proposals:Code_Prep_Suggestions#Copyright_and_license_headers_in_source_code_files
18:03:27 <edwarnicke> ?
18:03:40 <edwarnicke> Or does it need some enhancement?
18:04:01 <phrobb> Madhu, ColinDixon:  Shall we get names and dates in the SS for the new global activites as well?
18:04:29 <colindixon> edwarnicke: others had talked about enhancing it to mention that you could add yourself or your company to <copyright holder> when making significant contributions
18:04:41 <colindixon> phrobb: yes, that would be good
18:04:47 <edwarnicke> Madhu: For the per project Jenkins item... best to put the link to the controllers job in the notes so folks know what to copy (use the link that takes folks directly to the view)
18:04:53 <phrobb> Edwarnicke:  Works will go up if we need to change it.  Most of the files that have EPL license headers are using that template already… those would need to be changed too if we change the header
18:04:55 <Madhu> edwarnicke: sure.
18:05:14 <Madhu> regarding copyright header
18:05:18 <edwarnicke> Can I pound agree on using that template for copyright/license headers then?
18:05:33 <colindixon> edwarnicke, not just yet
18:05:39 <edwarnicke> That's fine :)
18:05:50 <Madhu> i have heard some comments on author to be added there (optional)
18:05:55 <Madhu> not on the java doc sources
18:06:00 <Madhu> but on the copyright headers
18:06:10 <Madhu> (where the copyright belongs to individuals)_
18:06:52 <edwarnicke> #topic Changing the meeting times for the morning meeting to 9am PST to accomodate India (see prasanna's email requesting such a change)
18:07:52 <RobDolin> @EdWarnicke - No objection from me to the 9am (Pacific) time change.
18:07:57 <edwarnicke> Madhu: I have no objection to folks when they change a file adding themselves there.  But for the purposes of getting this done can we go with the template and the original committer (or their corporate entity as appropriate)
18:08:00 <tykeal> we might want to consider fixing that copyright header to also include an SPDX line of the following form: @License EPL-1.0 <http://spdx.org/licenses/EPL-1.0>
18:08:11 <tykeal> it helps license scanners
18:08:14 <edwarnicke> tykeal: Lets not get into the SPDX weeds just yet
18:08:18 <tykeal> haha
18:08:26 <edwarnicke> Seriously... I know to much about it
18:08:34 <colindixon> edwarnicke: so, I think the copyright comes down to phrobb making sure our legal issues are OK with having changing copyright holder lines
18:08:40 <Madhu> agreed on copyright.
18:09:07 <phrobb> I agree to defer SPDX discscussion to a later date/venue
18:09:13 <edwarnicke> phrobb: Is there a potential issue there?  I've seen multiple copyright holders listed in Open Source source files going back a long long time... its not an uncommon practice
18:09:13 <Madhu> #info ovsdb project uses author tag as well
18:09:33 <edwarnicke> Madhu: I strongly support projects having their own local convention there :)
18:09:40 <tykeal> :-/ why didn't the bot change the topic? it should have been able to
18:09:44 <colindixon> ok, so I think with a note about adding yourself and/or your company on the copyright thing, we're good
18:09:56 <edwarnicke> tykeal: I think because its mostly keeping notes
18:10:07 <phrobb> IANAL - will need to ask one
18:10:14 <colindixon> ok
18:10:37 <colindixon> or do we just want to say that the copyright blurb stays fixed in each file?
18:10:40 <colindixon> I don't think we do
18:11:12 <Madhu> shall we agree on having the same copyright header with optional #author tag ?
18:11:51 <phrobb> I agree with Ed that multiple copyright holders should not be a problem.  But if we are deciding this as a practice, it would be good to get an opinion from legal counsel
18:12:00 <colindixon> ok
18:12:05 <edwarnicke> Just modified: https://wiki.opendaylight.org/view/Project_Proposals:Code_Prep_Suggestions#Copyright_and_license_headers_in_source_code_files
18:12:11 <edwarnicke> With the note and an example
18:12:21 <edwarnicke> Let me know what you think
18:12:29 <colindixon> #action phrobb to consult legal counsel to make sure that we can adopt https://wiki.opendaylight.org/view/Project_Proposals:Code_Prep_Suggestions#Copyright_and_license_headers_in_source_code_files as formal practice for copyright notices
18:12:50 <colindixon> oh, the topic change didn't work because only I can do it
18:12:53 <Madhu> edwarnicke: agreed.
18:12:56 <colindixon> because I'm the chair
18:13:17 <Madhu> colindixon: shall we change the #topic to release bundle versioning ?
18:13:30 <edwarnicke> Anyone object to be pound agreeing on the copyright thing?
18:13:42 <colindixon> Madhu: sure, after we do this
18:13:44 <edwarnicke> Pending phrobb checking with legal counsel
18:13:52 <Madhu> i have no objections
18:13:53 <colindixon> Madhu: is that OK with you?
18:13:55 <colindixon> ok
18:14:08 <edwarnicke> #agreed to use the template for copyright headers at https://wiki.opendaylight.org/view/Project_Proposals:Code_Prep_Suggestions#Copyright_and_license_headers_in_source_code_files pending phrobb checking with legal counsel
18:14:09 <colindixon> as the only person that spoke up other than me, that's agreement to me
18:14:18 <colindixon> #agreed to use the template for copyright headers at https://wiki.opendaylight.org/view/Project_Proposals:Code_Prep_Suggestions#Copyright_and_license_headers_in_source_code_files pending phrobb checking with legal counsel
18:14:32 <colindixon> edwarnicke: I think I'm also the only person who can do pound agreed :p
18:14:49 <edwarnicke> That's fine :)
18:14:50 <colindixon> #topic bundle versions for release
18:14:58 <Madhu> thanks :)
18:14:59 <tykeal> chair == power ;)
18:15:11 * Madhu bows the chair
18:15:14 <edwarnicke> chair == sitting == tight psoas (trust me on this)
18:15:23 <abhijitkumbhare> :-)
18:15:31 <Madhu> on the release bundle thing
18:15:44 <edwarnicke> Which spreadsheet line are we speaking to here?
18:15:48 <Madhu> GiovanniMeo had sent a detailed info on the release plugin long back
18:15:54 <Madhu> 1 sec
18:16:04 <Madhu> 39
18:16:13 <Madhu> "Write recommendation for cutting Release Branches and laying Release labels"
18:16:23 <colindixon> ok
18:16:36 <Madhu> baséd on the discussion we had over the weekend,
18:16:54 <Madhu> it is clear that the release bundle versions must be done in a sequence
18:16:55 <edwarnicke> That's due tomorrow (1/14) correct?
18:16:55 <colindixon> #info we're talking about line 39 for now, we'll go back to the top of the spreadsheet later
18:17:08 <Madhu> yes. due tomorrow
18:17:13 <Madhu> &  hence the urgency :)
18:17:15 <edwarnicke> On track? :)
18:17:27 <Madhu> edwarnicke: trying :)
18:17:35 * edwarnicke so sad to be the date monger... but someone has to :(
18:17:53 * Madhu thinks this is the best way to get work done.
18:18:02 <Madhu> so ... sequencing is important
18:18:07 * edwarnicke hopes folks will poke him gently if he gets annoying
18:18:16 <colindixon> Madhu: what do you mean by sequencing?
18:18:23 <Madhu> project sequencing
18:18:38 <Madhu> meaning . Controller release versioning cannot be done before Yangtools is complete
18:18:47 <Madhu> because Controller project is dependent on Yangtools
18:19:00 <edwarnicke> #question: Do we want to take this opportunity to come onto a common version for ODL artifacts, since we are looking at doing weekly releases in the future, and thus could stay together?
18:19:12 <edwarnicke> (might make life way way simpler for consumers)
18:19:35 <Madhu> edwarnicke: we discussed that topic at the beginning of this meeting.
18:20:07 <Madhu> and am not too familiar with the # tags yet :)
18:20:33 <Madhu> so the deadline for the release bundling is the recommended approach (not the work itself)
18:20:40 <edwarnicke> Madhu: I don't see a discussion of that question... but I do see a discussion of things like the latest version stuff
18:20:57 <colindixon> um, so, do we at least have the dependency DAG so that we can figure out who has to fix versions first?
18:21:06 <Madhu> colindixon: yes
18:21:12 <Madhu> I will be sending that out
18:21:19 <edwarnicke> I can sketch at least part of it that's known
18:21:30 <Madhu> along with the steps needed for releasing bundles
18:21:38 <edwarnicke> yangtools <- controller <- (most other things)
18:21:45 <Madhu> edwarnicke: correct
18:21:53 <Madhu> but this is a tree :) and not a list
18:21:55 <edwarnicke> There may be some subtly in there
18:22:18 <Madhu> edwarnicke: hopefully there is no bidirectional or circular dependency (i haven't seen any yet)
18:22:32 <edwarnicke> I know... (most other things) is mostly a collection of siblings in the tree :)
18:22:43 <colindixon> um, so edwarnicke, what was your suggestion, that we basically agree on a version number for hydrogen and everyone bumps to that?
18:22:52 <Madhu> colindixon: no
18:23:11 <Madhu> sorry for talking for edwarnicke :) but there cannot be common version for bundles
18:23:18 <Madhu> each bundle can have a release version
18:23:24 <RobDolin> (Aside: I need to drop-off, but I've kicked email threads with the User Manual Template and Developers Guide Template teams.  We'll be iterating in email today.  If anyone would like to join either, please email RobDolin@microsoft.com.  Thanks; and kudos to Colin Dixon on the draft release notes: https://wiki.opendaylight.org/view/Sample_Release_Notes)
18:24:10 <Madhu> the only requirement for bundle version is that for the hydrogen release
18:24:13 <edwarnicke> Madhu: there can be a common version for bundles
18:24:19 <Madhu> every other bundle must have common depedency
18:24:22 <edwarnicke> If we are doing a weekly release in the future
18:24:30 <colindixon> #help anyone wanting to help with the user manual template and/or developers' guide template should e-mail RobDolin at RobDolin@microsoft.com
18:24:31 <edwarnicke> And its got a large number of advantages if we can get there
18:24:48 <ashaikh> robdolin: i do want to hit you up for some input on qualification testing for windows variants
18:25:00 <Madhu> edwarnicke is this for hydrogen. hopefully not
18:25:04 <edwarnicke> Madhu: I don't think we are going to settle the bundle version matching debate here though
18:25:17 <edwarnicke> Lets just settle for getting folks onto a consistent set of versions for now
18:25:23 <edwarnicke> Other things are a rabbit hole at this time
18:25:28 <Madhu> edwarnicke: yes. for hydrogen. the only requirement is consistent version dependency
18:25:33 <Madhu> agreed.
18:25:42 <colindixon> #info tabling the discussion of synchronized versions for a later date
18:25:42 <Madhu> and the release bundles will be cut in sequence
18:26:12 <Madhu> I will send out the recommendation by tomorrow (hopefully)
18:26:34 <colindixon> Madhu, I'm going to pound action that you will send out a sequence in which projects can fix their hydrogen release versions and will coordinate with team leads to do that starting on 1/15
18:26:38 <colindixon> is that right?
18:27:14 <Madhu> colindixon: yes. also the actual work involved in moving from SNAPSHOT -> RELEASE version
18:27:32 <edwarnicke> colindixon: Keep in mind, we aren't cutting final artifacts till the conclave on Jan 27
18:27:43 <Madhu> colindixon: and the project RELEASE cannot happen on 1/15
18:27:48 <Madhu> it is actually after 1/27
18:28:01 * Madhu in agreement with edwarnicke
18:28:12 <edwarnicke> I do think we need to figure out what a dry run looks like though
18:28:22 <edwarnicke> To be done about a week before
18:28:22 <colindixon> #action Madhu will send out a sequence in which projects can fix their hydrogen release version numbers and will coordinate with team leads to do that starting on 1/15, moving from SNAPSHOT -> RELEASE will happen later and artifacts won't be cut until 1/27
18:28:34 <colindixon> ok
18:28:35 <tykeal> GiovanniMeo: had done some minor dry run testing of the controller projects ages ago
18:28:43 <edwarnicke> tykeal: Yep :)
18:28:49 <colindixon> I'm going to move on to release notes unless there's objections
18:28:58 <colindixon> tykeal: edwarnicke: yeah, we need to plan that out
18:29:00 <colindixon> so many moving parts
18:29:11 <colindixon> #topic release notes
18:29:22 <tykeal> wee... it actually did it's job
18:29:32 <tykeal> you must have had a space in front of the # the other times?
18:29:48 <colindixon> #info I have written up sample release notes, put them here: https://wiki.opendaylight.org/view/Sample_Release_Notes#Known_Issues_and_Limitations and asked for feedback on the mailing list.
18:30:07 <colindixon> tykeal: no, it was just that edwarnicke tried it
18:30:12 <colindixon> and he's not chair
18:30:15 <tykeal> ah, that's why
18:30:16 <colindixon> mwhahahaha
18:31:23 <colindixon> ok, if there's no other feedback on that
18:31:37 <phrobb> #question Where shall we have the projects put their filled in Release Notes?  Are we creating a section on the wiki for them?  Do we need a new "Hydrogen Release" section?
18:31:42 <edwarnicke> colindixon: On the release notes, its not a matter of the list of languages, but the needed runtime.  Even scala just requires the JVM and jars we are bundling
18:31:53 <colindixon> yes
18:32:29 <colindixon> well, I think there's some concern from people about that, in particular cdub implied that supporting scala wasn't just a matter of the right jvm in his mind
18:32:39 <colindixon> but I was just trying to list the possible requirements we had
18:32:56 <colindixon> I would *love* help in trying to whittle that down to a more specific list
18:33:19 <colindixon> phrobb: that's a good question
18:33:24 <colindixon> does anyone have any suggestions
18:33:47 <colindixon> I would guess that Hydrogen Release should be it's own section
18:33:51 <edwarnicke> colindixon: scala runs anywhere its jar is
18:34:12 <edwarnicke> It compiles to JVM bytecode
18:34:34 <edwarnicke> His concern for support wasn't the technical 'running' kind of support, but the corporate kind of support
18:34:41 <colindixon> edwarnicke: with very little knowledge there, I'll take your word for it, but note that cdub has expressed tentativeness in agreeing with that from the point of view of supporting the release
18:35:05 <edwarnicke> #info I have made some effort to root out scala
18:35:06 <colindixon> ok
18:35:09 <colindixon> fair enough
18:35:36 <colindixon> #action colindixon will look into creating a section for project and edition release notes for hydrogen
18:35:44 <edwarnicke> Not because I believe its an issue, but because I'd like to make cdub life easier if I can
18:36:11 <colindixon> #action edwarnicke will help colindixon to produce a list of required tools for running based on the used languages in the release for the release notes
18:36:24 <colindixon> does that cover what people wanted?
18:36:27 <colindixon> also
18:36:52 <colindixon> #help anyone who wants to shape the release notes should provide feedback to my e-mail to discuss or reach out to me, or maybe even just edit the wiki page
18:37:23 <colindixon> ok
18:37:29 <ashaikh> colindixon: is that last action also related to the qualification testing item (i.e., which platforms are known to successfully run the controller) ?
18:37:56 <colindixon> ashaikh: is doing part of that
18:38:05 <colindixon> do we want to change topic to that now to chat about it quickly?
18:38:08 <edwarnicke> Madhu: This script line gives you a pretty decent notion of who depends on what other project in ODL:
18:38:16 <edwarnicke> grep -r --include="pom.xml" "<groupId>" . | sed 's;[^.]/.*/pom.xml:;;' | sed 's/<groupId>//' | sed 's;</groupId>;;' | grep opendaylight | awk '{print $1,$2}' | sort -u
18:38:25 <colindixon> actually, let's do that
18:38:43 <edwarnicke> colindixon: I'm supportive
18:38:47 <edwarnicke> Do we have ashaikh ?
18:38:55 <ashaikh> yes, i'm here
18:38:58 <colindixon> #topic testing for JVM and OS platforms (line 36)
18:39:11 <ashaikh> i started to put up a matrix here: https://wiki.opendaylight.org/view/Simultaneous_Release:Simultaneous_Release_Plan_2013/plaform_matrix
18:39:28 <ashaikh> but would like feedback on if this is too many (or too few) platforms to target
18:39:39 <colindixon> can we safely assume 64-bit?
18:39:41 <ashaikh> and also will seek some volunteers to do the basic tests
18:39:52 <ashaikh> i mentioned 64-bit explicitly in most cases
18:39:57 * tykeal notes that CentOS 6.5 == RHEL 6.5 in all intents and purposes
18:40:14 <colindixon> probably, we should add an assignee to each row
18:40:27 <ashaikh> understood, but i wasn't sure if we wanted to also use the freely available version of that distro
18:40:32 <ashaikh> colindixon: yes, good idea
18:41:08 <ashaikh> pls note i am suggesting to essentially reuse the process that the integration team uses for testing -- it's well documented, focuses on mininet, etc.
18:41:28 <ashaikh> and also focus on base edition initially
18:41:45 <edwarnicke> Is someone interested in doing a Fedora release there?
18:41:48 <colindixon> yes, the one thing I think we talked about was doing a "canary in the coal mine" test on each
18:42:29 <ashaikh> colindixon: right, it's essentially downloading and running the build from integration project against a mininet network -- that's the extent
18:42:42 <michal_rehak> colindixon: if the canary is green at the end, it is a safe mine?
18:42:43 <colindixon> fair enough
18:42:46 <shague_> yes, please Add Fedora to the list.
18:43:13 <ashaikh> shague_: am looking to you guys for helping with RHEL, Fedora, and maybe now CentOS :-)
18:43:17 <colindixon> michal_rehak: green canaries sound like they might have been exposed blue dye
18:43:34 <shague_> OK
18:43:35 <colindixon> ok
18:43:55 <colindixon> and are we testing different JVMs
18:43:59 <ashaikh> shague_: pls let me know which fedora release  you want to focus on (or go ahead and add it)
18:44:01 <colindixon> ?
18:44:19 <ashaikh> colindixon: yes, i was so focused on platform -- i meant to list JVM also
18:44:30 <colindixon> ok
18:45:00 <colindixon> #action anees and/or shague_ to add fedora to the list of OSes, also to add JVM columns and decide which JVMs we're testing
18:45:06 <tykeal> FYI testing on LF infra is all on OpenJDK 1.7
18:45:12 <ashaikh> which do you think we should target?   openjdk and Oracle (IBM JVM has some known issues)?
18:45:31 <ashaikh> tykeal:  thanks, so do we want to just do the tests on that ?
18:45:32 <colindixon> #info on the mailing list, somebody was saying that they had out of memory errors with the Oracle JVM on Ubuntu
18:45:48 <colindixon> I think that was just fro building though
18:46:00 <ashaikh> colindixon: was it ryan?  he said he was having issues building with a 4GB VM
18:46:03 <tykeal> ashaikh: LF infra is at present all RHEL 6
18:46:23 <colindixon> ok, this sounds like it's on track to start on 1/14 without much trouble
18:46:24 <edwarnicke> #info I have used openjdk successfully on ubuntu, and Oracle JDK successfully on MacOS X Maverick (and Mountain Lion before that... but its been a while)
18:46:45 <tykeal> colindixon: the integration / test environment isn't really doing "builds" per se it was setup specifically to do the automation testing
18:46:53 <colindixon> #info I'm going to try to focus the topics on things due tomorrow for a while
18:46:57 <colindixon> tykeal: understood
18:47:14 <colindixon> which is a valid question of what we should test for building
18:47:46 <ashaikh> ok, so please suggest any other changes for platforms / JVMs to the basic qual tests (running, not building) via mailing list or pinging me
18:47:58 <colindixon> GiovanniMeo: are you willing to take responsibility for line 38 "Document how to cut release artifacts for a project"?
18:48:13 <colindixon> since I think you had written that up before
18:48:52 <colindixon> or anyone else?
18:49:24 <colindixon> *silence*
18:49:34 <colindixon> #topic documenting how to cut release artifacts
18:49:46 <colindixon> #help we need somebody to volunteer to write up documentation about how to do this
18:50:09 <colindixon> I am pretty sure that GiovanniMeo sent out an e-mail a long time ago documenting some of this, so anyone wanting to do it should reach out to him
18:50:31 <colindixon> #topic investigate signing of release docs
18:50:41 <colindixon> Madhu: how is that going?
18:50:52 <Madhu> colindixon: not started on that yet
18:50:59 <colindixon> ok
18:51:02 <tykeal> I'm assuming we're talking GPG signing here?
18:51:08 <colindixon> deadline isn't until 1/20, so that's fine
18:51:20 <colindixon> tykeal: I think that's up to Madhu and the project
18:51:42 <colindixon> tykeal: does LF have standard ways they do that that we could borrow?
18:52:06 <tykeal> I can talk to kernel.org ;)
18:52:13 <edwarnicke> tykeal: I suspect we'd want to have .sign files in nexus for the artifacts, so yes, GPG
18:52:15 <tykeal> that being said, we don't have a GPG web of trust in place currently
18:52:26 <colindixon> that would be useful
18:52:27 <edwarnicke> Or we could sign  with a cert
18:52:35 <edwarnicke> Which may also be appropriate
18:52:44 * tykeal has been pondering setting up a GPG key signing party for the summit
18:52:50 <edwarnicke> As long as there's a .sign file that can be used to verify the files we should be good
18:52:57 <Madhu> sorry guys, i haven't even started on this. but if u guys know this better, carry on with the discussion and i will catch up :)
18:53:01 * edwarnicke likes GPG key signing parties
18:53:05 <colindixon> #action tykeal to talk to kernel.org about their code signing process to see if we could use it, sounds not totally promising
18:53:36 <tykeal> it really probably is not promising at present, they're very tied to a GPG setup
18:53:44 <colindixon> worst case, listing the secure hashes of the release artifacts outside the wiki would be a good start
18:53:57 <tykeal> yes, that's definitely a good start
18:54:34 <colindixon> ok, well, barring tykeal, edwarnicke or colindixon wanting to take responsibility for this (which I think we don't as of right now), we'll table this for later
18:55:09 <colindixon> #topic download page
18:55:18 <colindixon> phrobb: how is the download page work going?
18:55:30 <Madhu> is it common this meeting will be 70 mins+ ?
18:55:44 <colindixon> I really hope not
18:55:47 <edwarnicke> Madhu: That was not the intention... 15 minutes was the intention
18:55:49 <Madhu> I cannot
18:55:55 <Madhu> we have so much stuffs to do.
18:56:22 <Madhu> edwarnicke: any suggestions on making it 15 mins ?
18:56:24 <colindixon> do we have suggestions to make it go faster?
18:56:29 <edwarnicke> But as its an IRC meeting you can do some things in the background (for example, I did that command line for you, am doing some code reviews, and working on the NodeType issue as well right now)
18:56:36 <colindixon> I'd love them
18:56:36 <Madhu> LOL :)
18:56:41 <phrobb> I meet with the mkting/creative-web folks later today.  Also, Chris Price and Shague have started a thread with me on the topic as well.  So status ==  being worked and on track
18:56:42 <Madhu> that is not the question
18:57:10 <Madhu> edwarnicke: this might not work after 5.45pm for me
18:57:25 <colindixon> #info phrobb and others are meeting today about the download page
18:57:39 <Madhu> so we need a robust way to make this meeting shorter.
18:57:51 <colindixon> ok, I think we've covered the things which have a deadline before 1/20
18:58:00 <colindixon> so, let's adjourn before 1p
18:58:09 <colindixon> sorry 11a pacific time
18:58:13 <colindixon> any last comments?
18:58:27 <edwarnicke> tykeal: Where are meeting minutes posted by odl_meetbot?
18:58:35 <tykeal> when the meeting ends the bot will tell you
18:58:36 <phrobb> Let's work offline to figure out how to make the meetings shorter/more efficient
18:58:47 * edwarnicke hugs odl_meetbot
18:59:10 <tykeal> we just have to wait for colindixon to do the pound endmeeting ;)
18:59:21 <edwarnicke> Did we agree on switching to 9am PST to accomodate India?
18:59:29 <colindixon> there were no objections
18:59:40 <edwarnicke> Could you #agree it
18:59:42 <colindixon> #topic switching meeting to 9a PST for india
18:59:42 <edwarnicke> ?
18:59:45 <phrobb> colindixon should pound agree that :-)
19:00:00 <colindixon> #agree on moving the morning meeting to 9a for india since there were no objections
19:00:04 <colindixon> #endmeeting