01:56:19 <edwarnicke> #startmeeting
01:56:19 <odl_meetbot> Meeting started Tue Jan 14 01:56:19 2014 UTC.  The chair is edwarnicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:56:19 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
01:56:37 <edwarnicke> I think I just did :)
01:56:43 <tykeal> heh, yes, yes you did
01:57:04 <edwarnicke> hide yuk have you had a chance to loom at the spreadsheet?
01:57:21 <edwarnicke> Sorry, hideyuki... Autocorrect got me
01:57:46 <hideyuki> I read the spreadsheet.
01:58:04 <Christine_> I did, too. :)  (snmp4sdn)
01:58:07 <edwarnicke> #info https://docs.google.com/spreadsheet/lv?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE&f=true&noheader=false&gid=1
01:58:17 <tykeal> should do that as a #link instead ;)
01:58:22 <edwarnicke> Welcome Christine! :)
01:58:28 <tykeal> that way it hyperlinks in the minutes
01:58:33 <edwarnicke> Thank you tykeal :)
01:58:43 <edwarnicke> #link https://docs.google.com/spreadsheet/lv?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE&f=true&noheader=false&gid=1
01:58:44 <Christine_> ^_^
01:59:44 <Madhu_> sorry guys. late to the meeting.
01:59:55 <tykeal> seems like the story of it today...
01:59:56 <Madhu_> is it on ?
02:00:03 <edwarnicke> Who else is here for the meeting?
02:00:09 <tykeal> yes, edwarnicke just hasn't given a #topic yet ;)
02:00:28 <edwarnicke> So far it's me  tykeal, hideyuki, and Christine_
02:00:38 <Madhu_> me ? :)
02:00:47 <tykeal> sure, you can be included ;)
02:00:49 <edwarnicke> You count too :)
02:01:47 <Madhu_> just to cover the AI from today's morning.
02:02:07 <Madhu_> the dependency convergence patch in integration is in & jenkins is up and running in integration to catch the errors.
02:02:25 <edwarnicke> Madhu, would you like to take the opportunity to recruit hideyuki and Christine_ to do the per project part of that?
02:02:27 <Madhu_> I sent the email out to all the project owners (& the dev lists) to copy the versions jenkins job
02:02:36 <Madhu_> yes. would love to :)
02:02:37 <edwarnicke> #topic dependency convergence
02:02:49 <Madhu_> hideyuki Christine_ hope u got my email ?
02:03:04 <hideyuki> Yes, I've got the mail.
02:03:35 <Madhu_> the requirement for each of the project owner is to copy the jenkins job similar to : https://jenkins.opendaylight.org/controller/job/controller-version-changes/configure
02:03:49 <Christine_> yes.
02:03:52 <Madhu_> and execute the version upgrade process to generate the Gerrit
02:04:02 <Madhu_> and review the gerrit / test it out and merge it
02:04:36 <hideyuki> Ok. I will copy the jenkins job for VTN Project.
02:04:42 <Madhu_> once every project is done with this work, the errors seen in https://jenkins.opendaylight.org/integration/job/integration-dependencyConvergence/ will be gone.
02:04:49 <Madhu_> and that brings us to the covergence.
02:04:52 <Madhu_> hideyuki thanks.
02:05:06 <Christine_> OK!
02:05:06 <edwarnicke> hideyuki, could you sign up in the spreadsheet.
02:05:08 <edwarnicke> ?
02:05:22 <Madhu_> under each of your projects
02:05:28 <edwarnicke> And Christine_ would you sign up in the spreadsheet?
02:05:36 <hideyuki> Sorry, I cannnot sing up in the google doc in my office, edwarnicke .
02:05:39 <Madhu_> for the " Update dependency versions in all pom.xml files to current SNAPSHOT version for all ODL Dependencies" row
02:05:52 <Christine_> yes, I just did.
02:05:53 <edwarnicke> So we know we have folks working on it and can follow up on progress :)
02:06:32 <hideyuki> So I converted the spreadsheet to a PDF file. And now I'm reading the pdf file.
02:07:36 <edwarnicke> Ok :)
02:07:58 <edwarnicke> We still need some volunteers as well for some of the global items
02:08:08 <Madhu_> edwarnicke since the deadline for "identify" piece is tomorrow
02:08:19 <Madhu_> and we have "identified" it by running it in the integration branch.
02:08:24 <Madhu_> is it deamed DONE ?
02:08:42 <Madhu_> and the "update" dependency is on its way ?
02:10:03 <edwarnicke> I would say so.  Probably also counts for the item to check to make sure wee stay in sync
02:10:39 <Madhu_> ok will mark it as DONE and update a comment pointing to this email thread.
02:10:48 <Madhu_> hashpound Agreed ?
02:11:14 <edwarnicke> hideyuki, what difficulty are you having editing the google doc, is it something we could fix on our end?
02:12:29 <edwarnicke> Madhu_ one moment! putting a good hash pound agree line together
02:12:44 <Madhu_> :) sure
02:13:15 <hideyuki> Due to the firewall in my company, I cannot access Google doc service in my office.
02:13:36 <tykeal> yay for corporate firewalls! ;)
02:13:46 <hideyuki> Yes!
02:15:49 <edwarnicke> #agreed that "Identify all places dependency versions in project pom.xml files are not current for all ODL Dependencies" is satisfied by #link https://git.opendaylight.org/gerrit/#/q/status:merged,n,z and #link https://jenkins.opendaylight.org/integration/job/integration-dependencyConvergence/
02:16:29 <edwarnicke> hideyuki, May Madhu_ mark you down for those items in the spreadsheet then?
02:17:07 <hideyuki> edwarnicke: OK!
02:17:25 <edwarnicke> Madhu_ got that?
02:17:31 <Madhu_> hideyuki thanks. i will mark you as the owner in VTN project.
02:17:49 <hideyuki> Madhu_: Thank you!
02:18:32 <Madhu_> done
02:18:32 <edwarnicke> Christine_ have you been able to enter yourself on the spreadsheet?
02:18:56 <Christine_> Yes, I did.
02:19:40 <edwarnicke> :)
02:19:58 <edwarnicke> Did you both see the templates for Release Notes?
02:20:16 <hideyuki> Yes, I did.
02:20:34 <edwarnicke> Do you have any comments or feedback?
02:20:56 <hideyuki> No comments at the moment.
02:21:20 <edwarnicke> Ok... Let us know if you have any :)
02:21:26 <hideyuki> Ok!
02:22:39 <edwarnicke> Did you guys see the per file copyright/license header template, and are you comfortable with it?
02:23:25 <hideyuki> I've not checked it yet.
02:24:16 <hideyuki> Ok, I'm fine with this template!
02:24:49 <Christine_> I'm fine with this template, too.
02:25:10 <Madhu_> have to go now guys. tty tomorrow. bye
02:25:34 <hideyuki> I think all source code files in VTN Project follows this suggestions.
02:25:43 <Christine_> the templates for Release Notes --> is it this?  https://wiki.opendaylight.org/view/Sample_Release_Notes
02:26:01 <tykeal> Christine_: I believe so
02:26:08 <tykeal> it's the one that was pointed out this morning
02:26:18 <edwarnicke> hideyuki: probably :)
02:27:58 <Christine_> the templates for Release Notes is also fine with me. :)
02:28:13 <edwarnicke> Christine_: that's it :)
02:31:09 <tykeal> so... anything else for this evening?
02:32:11 <hideyuki> What does it mean "<Madhu_> and execute the version upgrade process to generate the Gerrit"?
02:33:39 <hideyuki> Does It mean that just upgrade versions in pom.xml? Or we have to submit new file for the process?
02:34:33 <tykeal> hideyuki: if you look over the job that Madhu_ had linked I think it's referring to the following on the Goals & options line:  -B versions:use-latest-versions
02:34:37 <tykeal> I could be wrong though
02:34:59 <edwarnicke> hideyuki, the Jenkins job will submit a Gerrit upgrading all the dependencies in Pom.xml to the latest versions
02:35:17 <edwarnicke> If there are breakages you old need to fix them before merging
02:35:22 <tykeal> yes, it posts to gerrit in the 'Post steps' section
02:35:26 <edwarnicke> And testing is probably also a good idea
02:35:32 <hideyuki> Thank you for your clarification!
02:35:48 <edwarnicke> It's supposed to be easy :)
02:36:07 <Christine_> I have another question~~  "Update SNMP4SDN maven pom.xml to only use the nexus 'group' rather than multiple repos." --> we use a third-party utility: Expect4j, and it uses plugins stored in repo other than ODL's nexus :(
02:36:20 <edwarnicke> Do either of you have opinions about operating system/JVM support?
02:36:57 <tykeal> Christine_: if I can get a link to the third-party repo I can include it in our public repo proxy which the group uses
02:37:25 <tykeal> that being said, if you aren't passing through our nexus for one of the repositories you don't need to update that particular linkage
02:38:15 <tykeal> The reason for that activity is stated in column I (Reason) as: Pointing to multiple repos in our nexus repo is both less stable build wise, and also massively overloads our nexus server
02:38:56 <edwarnicke> Chritstine_: we can set up our nexus as a caching repo for other repos.  That way we can guarantee ODL can always build, even if things disappear from other repos.
02:39:43 <edwarnicke> (Or to put it differently, you can totally still have your dependencies... We just want to cache them for you :) )
02:39:52 <tykeal> hehe
02:40:29 <Christine_> ok, I see. ^_^
02:41:16 <Christine_> perfect!
02:41:54 <edwarnicke> Could you tell tykeal the URL for the repo?
02:42:05 <tykeal> the "groups" repo?
02:42:21 <tykeal> #link https://nexus.opendaylight.org/content/groups/public/
02:42:32 <tykeal> or should that be
02:42:35 <tykeal> #info https://nexus.opendaylight.org/content/groups/public/
02:42:45 <tykeal> not certain since I'm not chairing ;)
02:42:46 <edwarnicke> No, Christine_ telling tykeal the URL for her repo :)
02:43:02 <tykeal> hehe
02:43:12 <tykeal> totally misread the request ;)
02:43:24 <edwarnicke> #link https://nexus.opendaylight.org/content/groups/public/
02:44:44 <Christine_> you mean this? the expect4j uses repo:  http://repository.springsource.com/maven/bundles/release  and   http://repository.springsource.com/maven/bundles/external
02:45:15 <tykeal> ok. I'll have them added to our nexus in a moment
02:45:54 <edwarnicke> Anything else guys?
02:46:01 <edwarnicke> Before we close?
02:46:01 <Christine_> thank you, tykeal
02:46:36 <hideyuki> No questions now.
02:46:43 <hideyuki> Thank you, all!
02:46:44 <Christine_> Me either
02:46:53 <edwarnicke> #stopmeeting
02:46:58 <Christine_> Thank you
02:47:23 <edwarnicke> #endmeeting