#opendaylight-meeting Meeting

Meeting started by colindixon at 17:00:20 UTC (full logs).

Meeting summary

  1. roll call and agenda (colindixon, 17:00:28)
    1. Andrew Grimberg for infrastructure support (tykeal, 17:00:44)
    2. regXboi for opendove (regXboi, 17:00:44)
    3. phrobb is here (phrobb, 17:00:54)
    4. dkutenic for bgpcep (dkutenic, 17:01:03)
    5. GiovanniMeo too here for release questions (GiovanniMeo, 17:01:17)
    6. dbainbri (dbainbri, 17:01:17)
    7. oflibMichal for openflowjava (oflibMichal, 17:01:17)
    8. Konsta for defense4all (Konstantin, 17:01:23)
    9. Prasanna for openflowplugin (prasanna, 17:01:28)
    10. goldavberg for lispflowmapping (goldavberg, 17:01:29)
    11. shague for downloadable artifacts (shague_, 17:01:30)
    12. https://wiki.opendaylight.org/view/File:Odl-release-sync-agenda-9a-01-20-2014.pdf I posted an agenda by scraping the spreadsheet for dates that were coming up and looking at per-project status (colindixon, 17:01:31)
    13. Anees here (ashaikh, 17:01:44)
    14. https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1 and this is the spreadsheet we're using as always (colindixon, 17:01:50)
    15. Abhijit Kumbhare for openflowplugin here (abhijitkumbhare, 17:02:11)
    16. rovarga for yangtools and bgpcep (rovarga, 17:02:49)
    17. Ed Warnicke for controller (edwarnicke, 17:03:05)
    18. michal_rehak / openflowplugin (michal_rehak, 17:03:43)
    19. Luis for Integration (LuisGomez, 17:03:53)

  2. dry run for cutting release artifacts (colindixon, 17:04:18)
    1. Madhu here. late (Madhu, 17:06:26)
    2. GiovanniMeo goes over how to do release artifact cutting with jenkins jobs at least for OSGi bundles (colindixon, 17:07:08)
    3. regXboi want's to know how to cut things that aren't OSGi bundles (colindixon, 17:07:23)
    4. https://jenkins.opendaylight.org/controller/job/controller-bulk-release-prepare-only/configure (GiovanniMeo, 17:10:12)
    5. https://jenkins.opendaylight.org/controller/job/controller-bulk-release-prepare-only/configure (regXboi, 17:10:27)
    6. note well this one if for maven artifacts (GiovanniMeo, 17:10:35)
    7. edwarnicke points out "nobody should be pushing release artifacts to nexus as part of the dry run (colindixon, 17:12:00)
    8. it appears as though we will need to have some offline discussion about how to cut non-OSGi-bundle artifacts as part of the release (colindixon, 17:17:01)

  3. scheduling time for artifact cutting on monday (colindixon, 17:21:26)
    1. trying to find a time and a plan to start cutting artifacts with people on IRC so that we can find who we need when things go wrong (colindixon, 17:29:57)
    2. we'll start at 9a PST and will reach out to others to make sure that we can get people on hand. there are some worries about tokyo (where it will be 2a) and taipei (where it will be 1a) (colindixon, 17:31:24)
    3. edwarnicke thinks it should take ~4 hours from then (colindixon, 17:32:47)
    4. https://jenkins.opendaylight.org/controller/job/controller-bulk-release-prepare-only/configure (GiovanniMeo, 17:33:15)
    5. ACTION: somebody needs to reach out to all projects and make sure that they will have a representative there during that time and if not, when they will and how will will make that work (colindixon, 17:33:17)
    6. ACTION: phrobb will reach out to all projects to get somebody to be online for the release cutting event (colindixon, 17:35:50)
    7. Madhu is worried that by still working on code and having versions in flux until 1/27 we may have trouble when it comes to doing integration then more than we expect. colindixon agrees, but there's a lot of discussion about what can be done to try to make this better. (colindixon, 17:39:30)
    8. GiovanniMeo and Madhu suggest doing some real releases before 1/27 to try to reduce some of this pain (colindixon, 17:40:11)
    9. rovarga seems to be willing to see what can be done for yang tools (colindixon, 17:40:23)
    10. Madhu points out (and some others agree) that cutting release artifacts twice (once before 1/27 and once on 1/27) could be dangerous and so if we cut before, we'll need to (carefully) decide whether we allow bug fixes and another release on 1/27 (colindixon, 17:41:42)

  4. documentation (colindixon, 17:46:13)
    1. ACTION: colindixon to hunt down somebody to help him get the templates on the wiki and send an e-mail saying where they are and how to make those docs real (colindixon, 17:48:57)

  5. external versions (colindixon, 17:49:11)
    1. in the last meeting we largely agreed that we would try to avoid syncing external versions unless they were actively causing problems (colindixon, 17:50:34)
    2. ACTION: Madhu will mark this as done until test failures on the spreadsheet (colindixon, 17:51:03)

  6. download page (colindixon, 17:51:20)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Simultaneous_Release_Plan_2014:DownloadableReleaseArtifacts shague_'s summary of what we're actually releasing (colindixon, 17:52:29)
    2. shague_ is still following up with projects, Defense4All, OpenDOVE and VTN among them, but will ask for help if he's nog getting the responses he needs (colindixon, 17:53:23)
    3. phrobb is working with marketing people to get a mockup of the download page up, will give results when he has them (colindixon, 17:53:47)
    4. ACTION: shague_ to chat with chris price and see when a reasonable deadline is and mark it in the spreadsheet (colindixon, 17:56:07)

  7. testing with -of13 (both integration and project) (colindixon, 17:56:20)
    1. https://wiki.opendaylight.org/images/5/55/Odl-release-sync-agenda-9a-01-20-2014.pdf agenda showing the per-project status for testing with -of13 at the bottom (colindixon, 17:57:33)
    2. LuisGomez says that the continuous IT for -of13 are set up, but they are continuing to add more tests (colindixon, 17:59:06)
    3. https://jenkins.opendaylight.org/integration/job/integration-csit-base-of13/ (LuisGomez, 17:59:57)
    4. we are testing the controller with -of13 and all current tests though (see link above) (colindixon, 18:00:54)
    5. ovsdb (Madhu) is trying to integrate with -of13 and running into some issues (colindixon, 18:01:58)
    6. Ed Warnicke is on it (edwarnicke, 18:02:13)
    7. LuisGomez plans to test -of13 with VTN, OVSDB and Affinity before the end of the week (colindixon, 18:02:26)
    8. it would be good if projects like VTN, OVSDB and Affinity test with -of13 (LuisGomez, 18:03:26)
    9. ACTION: LuisGomez to update the spreadsheet with an appropriate status for tracking this progress, but it sounds like it's good progress (colindixon, 18:03:57)

  8. signing release artifacts (colindixon, 18:04:21)
    1. this has been on the back burner because of other issues we're looking into (colindixon, 18:05:27)
    2. it seems like we might start investigating the easiest possible way to do this which is just publishing hashes of artifacts on a non-editable webpage (colindixon, 18:06:00)
    3. some good discussion (mostly from tykeal) about possibilities and challenges (colindixon, 18:09:28)
    4. GiovanniMeo and colindixon both suggest skipping signing for this release and relying on just published secure hashes if anything (colindixon, 18:09:53)


Meeting ended at 18:10:29 UTC (full logs).

Action items

  1. somebody needs to reach out to all projects and make sure that they will have a representative there during that time and if not, when they will and how will will make that work
  2. phrobb will reach out to all projects to get somebody to be online for the release cutting event
  3. colindixon to hunt down somebody to help him get the templates on the wiki and send an e-mail saying where they are and how to make those docs real
  4. Madhu will mark this as done until test failures on the spreadsheet
  5. shague_ to chat with chris price and see when a reasonable deadline is and mark it in the spreadsheet
  6. LuisGomez to update the spreadsheet with an appropriate status for tracking this progress, but it sounds like it's good progress


Action items, by person

  1. colindixon
    1. colindixon to hunt down somebody to help him get the templates on the wiki and send an e-mail saying where they are and how to make those docs real
  2. LuisGomez
    1. LuisGomez to update the spreadsheet with an appropriate status for tracking this progress, but it sounds like it's good progress
  3. Madhu
    1. Madhu will mark this as done until test failures on the spreadsheet
  4. phrobb
    1. phrobb will reach out to all projects to get somebody to be online for the release cutting event
  5. shague_
    1. shague_ to chat with chris price and see when a reasonable deadline is and mark it in the spreadsheet


People present (lines said)

  1. GiovanniMeo (168)
  2. colindixon (150)
  3. edwarnicke (81)
  4. Madhu (73)
  5. regXboi (17)
  6. rovarga (15)
  7. LuisGomez (14)
  8. tykeal (12)
  9. ashaikh (7)
  10. shague_ (6)
  11. Konstantin (5)
  12. phrobb (4)
  13. abhijitkumbhare (3)
  14. prasanna (2)
  15. odl_meetbot (2)
  16. michal_rehak (1)
  17. goldavberg (1)
  18. oflibMichal (1)
  19. dbainbri (1)
  20. dkutenic (1)


Generated by MeetBot 0.1.4.