17:00:13 <colindixon> #startmeeting
17:00:13 <odl_meetbot> Meeting started Tue Jan 21 17:00:13 2014 UTC.  The chair is colindixon. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:13 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:00:18 <colindixon> #topic roll call and agenda
17:00:33 <Madhu> #info Madhu here
17:00:57 <phrobb> #info Phil Robb here
17:00:59 <rovarga> #info rovarga for bgpcep and yangtools
17:01:00 <colindixon> if people who are attending can #info their being here that would be great
17:01:10 <ashaikh> #info Anees / opendove
17:01:18 <Konstantin_> #info Konstantin for defense4all
17:01:26 <colindixon> my plan is to go over the stuff that is past due which you can see a brief summary of in yesterday's meeting
17:01:40 <colindixon> and then to ask people about what's going on with stuff that's due by the end of the week
17:01:50 <dkutenic> #info dkutenic for bgpcep
17:01:56 <colindixon> anyone else around
17:02:09 <oflibMichal1> #info oflibMichal for the openflowjava
17:02:09 <colindixon> also if anyone has specific topics they want to go over, let me know
17:02:12 <goldavberg> # info goldavberg for lispflowmapping
17:02:28 <colindixon> goldavberg: try again with fewer spaces :p
17:02:44 <tykeal> #info Andrew Grimberg for infrastructure support
17:02:56 <colindixon> #link https://wiki.opendaylight.org/images/5/55/Odl-release-sync-agenda-9a-01-20-2014.pdf that was the agenda for last time and includes the things that were due yesterday or earlier
17:02:59 <goldavberg> #info goldavberg for lispflowmapping
17:03:27 <colindixon> ok
17:03:42 <colindixon> #topic external dependencies
17:03:54 <colindixon> Madhu: we got suchi and affinit
17:03:58 <colindixon> affinity last night
17:04:03 <colindixon> is that the last thing we need to deal with
17:04:08 <colindixon> I guess this is really internal dependences
17:04:15 <Madhu> yes
17:04:22 <colindixon> #info actually internal and external dependencies
17:04:47 <colindixon> #info Madhu managed to connect with such about affinity which was the last project to start synching on internal dependences
17:04:52 <colindixon> ok
17:05:19 <colindixon> #topic testing with the new openflowplugin (the -of13 option)
17:05:30 <colindixon> so, there's two parts to this:
17:05:51 <colindixon> first, if you're planning to use any features of the new open flow plugin, you obviously need to start testing against it like *now*
17:05:56 <michal_rehak> #info michal_rehak / openflowplugin
17:06:13 <abhijitkumbhare> #info Abhijit Kumbhare / openflowplugin
17:06:32 <colindixon> second, if you use the old openflow plugin, and want to test if you also work with the new one, you also should start testing to see if there's any hiccups
17:06:42 <colindixon> Luis sent out some mails to discuss about how to do that
17:06:46 <Madhu> not trying to finger-point or anything. just giving the reality here.
17:07:11 <Madhu> OF13 testing needs MDSAL. I am having trouble with a stabler version for the past 2 days
17:07:46 <Madhu> but am testing OF13 right now with a bit older version of integration branch image
17:07:52 <colindixon> #info projects that want to use OF1.3 features from the new openflow plugin should start testing with it immediately, I think that's just controller and OVSDB
17:08:14 <colindixon> #info projects that use the old openflow plugin and want to see if they also work via the adaptor bundles on the new one should also test
17:08:15 <Madhu> facing a few issues and am debuggin
17:08:30 <colindixon> #info Madhu and OVSDB are experiences some issues and are debugging
17:08:33 <colindixon> so, the question is
17:09:04 <abhijitkumbhare> prasanna - are these the issues you were talking about in the openflowplugin meeting
17:09:15 <colindixon> is anyone here doing the testing
17:09:28 <colindixon> or planning to
17:09:30 <colindixon> and do they need help?
17:10:08 <colindixon> #link https://lists.opendaylight.org/pipermail/discuss/2014-January/001096.html this e-mail from Luis explains how to do the testing if you want
17:10:09 <abhijitkumbhare> and asking tony?
17:10:17 <Madhu> colindixon: i can take some quick help from someone in open flow plugin team
17:10:43 <Madhu> abhijitkumbhare: prasanna michal_rehak anyone willing to help ?
17:10:46 <abhijitkumbhare> Madhu: can you discuss with prasanna ?
17:10:55 <Madhu> yep
17:11:02 <abhijitkumbhare> he was discussing in the morning with tony
17:11:09 <colindixon> #info Madhu to connect with prasanna about issues with OVSDB
17:11:10 <colindixon> ok
17:11:20 <colindixon> I think that lisp mapping isn't doing anything
17:11:26 <colindixon> here
17:11:31 <colindixon> and they're the last project I needed to talk to
17:11:39 <colindixon> is that right goldavberg
17:11:43 <colindixon> ?
17:11:51 <edwarnicke> #info Ed Warnicke for controller
17:12:07 <goldavberg> We didnt test openflow
17:12:13 <colindixon> edwarnicke: can you fill in the fact that controller is already testing with -of13
17:12:24 <colindixon> goldavberg: so, you don't use open flow, and so won't be testing
17:12:25 <edwarnicke> Madhu: Have you tried my suggestion of simply building from integration/distributions/virtualization
17:12:31 <edwarnicke> As that has been quite stable in the integration tests
17:12:35 <Madhu> edwarnicke: that is failing today as well
17:12:40 <edwarnicke> And functions stabily on both Mac and Ubuntu for me
17:12:41 <Madhu> mastery just tried it
17:12:45 <Madhu> and we are facing the same problem
17:13:00 <edwarnicke> Madhu: Are you still pulling out of date versions, stomping config.ini files, etc, etc
17:13:08 <colindixon> goldavberg: if you aren't, then can you please put an n/a in that row (I think it's 27) on the spreadsheet in your tab
17:13:13 <edwarnicke> And munging around out of sync bundles
17:13:13 <colindixon> https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1
17:13:15 <Madhu> edwarnicke: nope
17:13:22 <edwarnicke> Or are you building from a proper distribution directory as I recommended?
17:13:32 <colindixon> edwarnicke and Madhu, this is hugely important, but probably not for this meeting
17:13:35 <colindixon> hey Konstantin_
17:13:40 <Madhu> i agree.
17:13:43 <colindixon> goldavberg: you hear?
17:13:45 <colindixon> here?
17:13:53 <edwarnicke> Madhu: Please adopt a stable and reasonable strategy for assembling a distribution.  If you follow the instructions, everything shoudl work
17:13:54 <Konstantin__> Hey, Dropped for few secs
17:14:06 <goldavberg> Colidixon sure
17:14:12 <colindixon> thanks
17:14:22 <edwarnicke> colindixon: Will fill in that controller testing is happening with -of13 (and passing reliably! ;) )
17:14:30 <colindixon> thanks
17:14:44 <colindixon> #action goldavberg will update the spreadsheet to say they aren't' testing with -of13 because they don't use openflow
17:14:54 <colindixon> #action edwarnicke to update the spreadsheet to say that controller is already doing this
17:15:03 <colindixon> #topic dry run cutting of releases
17:15:25 <colindixon> we went over this yesterday, so, I really just want to check in and see if people have questions, need help, etc.
17:15:36 <Konstantin__> Yes, i have.
17:15:41 <colindixon> it's just trying to go through as much of the mechanics of cutting artifacts before 1/27 as possible
17:15:46 <colindixon> Konstantin__: go for it
17:15:53 <Konstantin__> We have already 'RELEASE' in our poms.
17:16:04 <Konstantin__> And can't use release plugin ....
17:16:14 <rovarga> yangtools job is there, we had a misconfiguration, so there's one more spin
17:16:18 <Konstantin__> Should we go back to SNAPSHOT ?
17:16:20 <edwarnicke> #info: I am told that the correct job to copy is: https://jenkins.opendaylight.org/controller/job/controller-bulk-release-prepare-only/
17:16:31 <edwarnicke> #info there is a easy to miss option in Git Advanced Checkout/merge to local branch (optional)
17:16:35 <rovarga> essentially we are at a place where prepare succeeds localy with -Dpush=false
17:16:35 <edwarnicke> which is important
17:16:42 <colindixon> #link https://jenkins.opendaylight.org/controller/job/controller-bulk-release-prepare-only/ providing a clickable link to the job
17:16:58 <colindixon> edwarnicke or GiovanniMeo, do you know what Konstantin__ needs to do?
17:17:10 <edwarnicke> Konstantin__: I would recommend the following
17:17:20 <Madhu> rovarga: great. thanks.
17:17:44 <Konstantin__> ?
17:17:51 <edwarnicke> Konstantin__: Keep testing.  If you discover you need to fix things, you will need to go to a new SNAPSHOT, and then can cut release artifacts  on Monday
17:18:20 <colindixon> #info rovarga states that yangtools is up and working with -Dpush=fals
17:18:20 <Konstantin__> Problem is that we don't use SNAPSHOT ....
17:18:39 <Konstantin__> So, Jenkins job is failing for us.
17:18:53 <Madhu> Konstantin__: u r using RELEASE versions of the controller ?
17:18:59 <Madhu> and you have no other dependencies ?
17:19:00 <edwarnicke> Konstantin__: Which Jenkins job?
17:19:11 <colindixon> #info Konstantin__ says that Defense4All is already on RELEASE pom files and wants to know how to proceed
17:19:18 <Konstantin__> We don't use controller for compilation, so ...
17:19:23 <edwarnicke> Konstantin__: Correct me if I'm wrong... you are all REST
17:19:36 <edwarnicke> Konstantin__: And thus do not have pom level dependencies on anything else, right?
17:19:38 <Konstantin__> Yes, REST to controller only ...
17:19:41 <GiovanniMeo> Konstantin_ if that is the case
17:19:42 <Konstantin__> Yes
17:19:53 <GiovanniMeo> then you can simply release at your own pace
17:20:11 <GiovanniMeo> you don't have artifact dependencies
17:20:20 <Konstantin__> Some git labeling ? Something else ?
17:20:22 <Madhu> Konstantin__: but your own project will be a SNAPSHOT
17:20:25 <Madhu> isn't it ?
17:20:28 <colindixon> ok, did that actually answer your question Konstantin__?
17:20:34 <edwarnicke> Konstantin__: GiovanniMeo is correct, that's why I suggested, keep testing, if you need to fix anything, then do a new SNAPSHOT
17:20:38 <colindixon> Madhu: no, I think they're saying they're at RELEASE
17:20:46 <Madhu> okay.
17:21:08 <colindixon> can we connect Konstantin__ with Madhu and GiovanniMeo to work resolve this offline?
17:21:29 <colindixon> it seems like something best resolved by looking at real jenkins jobs and pom files for 10 minutes
17:21:32 <edwarnicke> Konstantin__: a git label would definitely be good :)
17:21:38 <Konstantin__> Yes, i sent mail to Giovanni. Will wait for answer. Thanks
17:21:48 <colindixon> or you can get on the main IRC channel
17:21:49 <edwarnicke> Konstantin__: Please also remember that I believe you can only push a release version of artifacts for a given version once
17:22:12 <tykeal> that's correct
17:22:23 <colindixon> #action Konstantin__ to connect with GiovanniMeo, Madhu and/or edwarnicke over IRC or e-mail to resolve issues of RELEASE vs. SNAPSHOT for Defense4All
17:22:43 <Konstantin__> Yes. we have 1.0.5 release because of that ...
17:23:12 <edwarnicke> Konstantin__: I think your solution is simple.  Keep testing.  If nothing requires fixing, you don't need to change from your RELEASE version, because you have no artifact dependencies.
17:23:12 <colindixon> so, are others planning on doing a dry run/have they done it
17:23:15 <colindixon> I know controller has done it
17:23:23 <colindixon> I'm assuming OVSDB has done it
17:23:30 <edwarnicke> rovarga: How is yangtools doing with dryrun?
17:23:33 <colindixon> yang tools has done it
17:23:36 <colindixon> they said above
17:23:50 <colindixon> abhijitkumbhare and michal_rehak, what about openflowplugin?
17:23:56 <rovarga> almost there
17:24:04 <rovarga> found out we have a reference to controller.git
17:24:07 <Madhu> GiovanniMeo: without the yang tools release version, will controller's dry-run succeed ?
17:24:12 <colindixon> goldavberg: for lispflowmapping?
17:24:16 <Madhu> because of the RELEASE dependency on yangtools
17:24:18 <goldavberg> Lispflowmapping cant run the jenkins job because we are dependent on controller
17:24:24 <ashaikh> colindixon: regXboi has done the dry-run for opendove bundle artifacts (we also have non-bundle artifacts)
17:24:33 <colindixon> rovarga: and bgppcep?
17:25:03 <michal_rehak> colindixon: haven't tried yet
17:25:09 <GiovanniMeo> Madhu
17:25:09 <rovarga> colindixon: have not tried that one, yet, but given the yangtools experience I don't expect problems
17:25:12 <GiovanniMeo> no it will not
17:25:13 <colindixon> #info regXboi has done the dry run for opendove for java bundles but not fore the other stuff
17:25:27 <rovarga> e.g. once I get yangtools working it should be smooth
17:25:28 <GiovanniMeo> any other project indeed will fail dryrun
17:25:30 <Madhu> GiovanniMeo: thanks.
17:25:34 <GiovanniMeo> but there is an important test
17:25:37 <GiovanniMeo> to be done anyway
17:25:43 <GiovanniMeo> because we can check the git permission
17:25:57 <GiovanniMeo> to start with
17:26:08 <Madhu> yep. so just to be clear to everyone here
17:26:21 <GiovanniMeo> anyway the dryrun is to help spot issues for everyone
17:26:25 <Madhu> dry-run will start to succeed end to end only after the dependent projects are done completely
17:26:41 <Madhu> but it is good to try anyways
17:26:45 <goldavberg> So what can we do in the meantime?
17:26:46 <Madhu> to catch issues earlier
17:26:59 <colindixon> #info Madhu says "dry-run will start to succeed end to end only after the dependent projects are done completely, but it is good to try anyways"
17:27:06 <edwarnicke> Madhu: Agree, good to try, the git permissions are an important bit to check
17:27:30 <Madhu> yes.
17:27:30 <abhijitkumbhare> colindixon: will discuss dry run with michal_rehak and prasanna in tomorrow's OFplugin meeting & we can get back tomorrow's this meeting
17:27:35 <edwarnicke> I think we should also look at getting the release jobs setup
17:27:50 <colindixon> ashaikh: edwarnicke said that regXboi should connect with the VTN people about non-java bundles
17:28:26 <colindixon> #action abhijitkumbhare to discss dry runs with michal_rehak and prasanna about openflowplugin and openflowjava
17:28:32 <edwarnicke> ashaikh: I remember seeing the VTN guys doing something that looked very smart in their mvn pom.xml files around the non-java bits
17:28:54 <edwarnicke> But sadly it was months ago, so I don't remember the specifics
17:28:55 <ashaikh> colindixon: edwarnicke: ok, we will reach out to them and take a look
17:28:59 <colindixon> #Info edwarnicke "ashaikh: I remember seeing the VTN guys doing something that looked very smart in their mvn pom.xml files around the non-java bits" regarding open dove and regXboi
17:29:00 <ashaikh> thanks
17:29:08 <colindixon> ok
17:29:18 <abhijitkumbhare> the action is only about openflowplugin (not openflowjava)
17:29:22 <edwarnicke> ashaikh: hideyuki from VTN usually attends the 5:45pm PST meetings on IRC... you could sync up with him there
17:29:35 <colindixon> well, I think this was the critical things I wanted to push on this call
17:29:41 <ashaikh> edwarnicke: yes, will send him a note also -- thanks
17:30:06 * edwarnicke hopes there is an easy known solution for ashaikh :)
17:30:20 <edwarnicke> colindixon: Do we have pointers to where to do the docs?
17:30:28 <colindixon> edwarnicke: not yet
17:30:29 <colindixon> today
17:30:35 <edwarnicke> colindixon: cool
17:30:40 <edwarnicke> I appreciate your work there
17:30:56 <colindixon> #topic documentation
17:31:05 <colindixon> #action colindixon to push this stuff to the wiki *today*
17:31:14 <colindixon> ok, any other topics we need to cover today
17:31:18 <colindixon> otherwise, I could use lunch :p
17:31:34 <edwarnicke> colindixon: I am in favor of lunch :)
17:31:38 <colindixon> goldavberg: you should copy and run the jenkins job for prepare only
17:31:52 <colindixon> and reach out over IRC or mailing list for help if you need it
17:32:10 <colindixon> #endmeeting