01:45:44 <colindixon> #startmeeting
01:45:44 <odl_meetbot> Meeting started Wed Jan 22 01:45:44 2014 UTC.  The chair is colindixon. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:45:44 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
01:45:50 <colindixon> #topic roll call and agenda
01:45:56 <edwarnicke> #info Ed Warnicke for controller
01:46:02 <colindixon> feel free to #info yourself and who you're representing
01:46:20 <hideyuki> #info Hideyuki Tai for VTN Project
01:46:21 <colindixon> hideyuki I see you're here, thank you
01:46:44 <dbainbri1> #info dbainbri for docker and chicken
01:46:58 <colindixon> dbainbri1: always good to see you representing the fowl
01:46:59 <edwarnicke> chicken?... I am so behind...  ;)
01:47:14 <colindixon> we seem to be missing suchi and christine
01:47:40 <colindixon> ChristineHsieh: welcome
01:47:45 <ChristineHsieh> hi!
01:47:50 <colindixon> if you can #info your name, that would be great
01:47:52 <Madhu_> #info Madhu here. but not for long :(
01:48:07 <ChristineHsieh> #info ChristineHsieh for SNMP4SDN
01:48:16 <colindixon> perfect
01:48:21 <colindixon> Madhu_: good to see you
01:48:38 <colindixon> ok, my plan was to basically go over what we had talked about last night
01:48:42 <colindixon> point out some documentation stuff
01:48:49 <colindixon> and then ask if you guys have issues or questions
01:49:17 <colindixon> just for posterity, here are some links
01:49:30 <colindixon> #link https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1 the big spreadsheet
01:49:34 <suchiraman> affinity present
01:49:38 <colindixon> welcome suchiraman
01:49:43 <colindixon> go ahead and #info in
01:49:53 <colindixon> hey LuisGomez, you can go ahead and #info in too
01:49:56 <suchiraman> #info suchiraman affinity
01:50:15 <ashaikh> #info Anees , opendove
01:50:20 <LuisGomez> #info LuisGomez for Integration
01:50:33 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:Hydrogen_Release_Work this is the main wiki page we're working from for release stuff
01:50:39 <colindixon> welcome ashaikh
01:51:27 <colindixon> #link https://wiki.opendaylight.org/images/5/55/Odl-release-sync-agenda-9a-01-20-2014.pdf this is the agenda we used yesterday and I'll update it with real information for the per-project issues at the bottom later
01:51:57 <colindixon> just for good measure two more links
01:52:09 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/opendaylight-meeting.2014-01-21-17.00.html meeting minutes from the earlier meeting today
01:52:27 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/opendaylight-meeting.2014-01-21-01.49.html meeting minutes from yesterday, where I'm going to go over a few action items
01:52:31 <colindixon> sorry for all of that
01:52:42 <edwarnicke> colindixon: links are good :)
01:52:45 <colindixon> before I get started, is there anything anyone absolutely wants to go over first
01:53:22 <ChristineHsieh> no :)
01:53:27 <colindixon> ok, I'll take that as a no :p
01:53:32 <ashaikh> colindixon: i'd like to get some info on non-bundle artifact handling from hideyuki  and others (soon if possible)
01:53:45 <colindixon> ashaikh: yes good point
01:54:07 <hideyuki> ashaikh: Ok.
01:54:08 <edwarnicke> hideyuki: I had mentioned to ashaikh that I recall seeing you guys do something clever in vtn with your non-bundle artifacts using maven
01:54:12 <colindixon> hideyuki: ashaikh and regXboi from OpenDOVE wanted to know how you were getting the non-java, non-OSGI things to build and turn into artifacts
01:54:25 <edwarnicke> I don't remember the details as its been a while since I've been in the vtn code base
01:54:27 <ashaikh> hideyuki: i sent you a mail on this earlier -- you may not have seen it yet
01:54:36 <colindixon> I'm not sure if this is the right, venue for that, but I do want to at least connect you two
01:54:49 <hideyuki> ashaikh: I saw your mail 10 minutes ago.
01:54:51 <ashaikh> colindixon: that's fine too
01:55:04 <ashaikh> hideyuki:  ok, when you get a chance, pls share your thoughts on that -- doesn't have to be now
01:55:07 <hideyuki> colindixon: ok
01:55:11 <colindixon> the next topic I want to hit is talking with suchiraman and Madhu_ to see if affinity has gotten there version skew job up and running yet
01:55:19 <colindixon> #topic non-java/non-OSGi bundles
01:55:23 <suchiraman> Not yet.
01:55:27 <hideyuki> ashaikh: after this meeting, I will reply your mail!
01:55:37 <ashaikh> hideyuki: thanks :-)
01:55:43 <suchiraman> Got stuck on dryrun release job today. Looking for some help from edwarnicke or others.
01:55:50 <colindixon> #action hideyuki to help ashaikh and regXboi figure out how to go about packaging, cutting and releasing non-java/non-OSGi artifacts
01:56:04 <colindixon> #topic action items from yesterday
01:56:40 <colindixon> #info suchiraman has been working on dry runs for releases today (good!), but hasn't gotten to doing version skew jobs for affinity yet
01:57:02 <colindixon> suchiraman: I'm mostly quoting Madhu_, edwarnicke and others here, but getting that done sooner rather than later is going to make life easier
01:57:18 <Madhu_> +1
01:57:32 <colindixon> it might be more important than the dry run
01:57:39 <colindixon> just trying to keep things moving forward
01:57:46 <edwarnicke> colindixon: I suspect its more important than the dry run
01:58:16 <edwarnicke> more potential for breakage
01:58:27 <Madhu_> both build and runtime :(
01:58:30 <colindixon> hideyuki: did you figure out whether or not somebody from VTN can make the (awful) slot for the 1/27 release at 9a PST on 1/27
01:58:39 <suchiraman> Job appears to have completed, but shows up as failure. Curious if others have dry-run release job working (other than controller).
01:58:45 <hideyuki> colindixon: yes.
01:58:56 <colindixon> suchiraman: it *should* fail, but fail in a particular way
01:59:11 <colindixon> can you provide a link to Madhu_ for him to scan
01:59:24 <colindixon> hideyuki: so, you can have somebody there for ~4 hours starting at 2a Tokyo time?
01:59:26 <hideyuki> colindixon: we are discussing about it now. and I think three people including me from VTN Project will be online for cutting artifacts.
01:59:34 <colindixon> wow
01:59:39 <colindixon> that's commitment
01:59:41 <edwarnicke> I am hoping that 4 hours turns out to be overkill
02:00:15 <edwarnicke> hideyuki: Its actually good if you have more than one committer if your project has the local tradition of people not reviewing their own patches.  So one person can fix if there's a problem and the other review
02:00:22 <colindixon> #info hideyuki says that they should be able to have 3 people from VTN present for the 9a PST release cutting on 1/27 for up to 4 hours
02:00:29 <edwarnicke> hideyuki: Kudo's to you guys on your commitment
02:00:38 <edwarnicke> hideyuki: I am sorry its such an unreasonable hour for you guys
02:00:40 <hideyuki> colindixon: ok.
02:00:54 <colindixon> both suchiraman and hideyuki: did you talk about testing with the new openflowplugin?
02:01:12 <colindixon> ChristineHsieh: I'm also curious if there's any progress on doing a dry run for SNMP4SDN
02:01:36 <hideyuki> colindixon: We start to test the new OF plugin with VTN Manager.
02:01:50 <ChristineHsieh> colindixon: we just start doing the dry urn
02:01:53 <colindixon> hideyuki: good, are things working? or not yet?
02:02:00 <hideyuki> colindixon: however, we've seen some issues on this, and are analyzing the issues now.
02:02:09 <colindixon> good to know
02:02:12 <hideyuki> colindixon: not working.
02:02:22 <suchiraman> colindixon: not started, up next is of1.3 testing. I expect it to be no different than of1.0 -- not using any new features.
02:02:27 <hideyuki> colindixon: so we'll report the issues to the community later.
02:02:34 <edwarnicke> hideyuki: If you can let us know a bit more, the openflowplugin team is highly motivated to fix any bugs found
02:02:57 <edwarnicke> hideyuki: Thank you :)
02:03:07 <colindixon> #info The VTN project is testing with the new openflowplugin and says that they are running into issues, but they're looking into them. They will follow up with the openflowplugin team to help resolve them.
02:03:08 <colindixon> perfect
02:03:41 <colindixon> suchiraman: yes, in theory the same thing is true for VTN too
02:03:47 <colindixon> but they're running into some issues
02:04:05 <colindixon> we're just hoping to iron those out sooner rather than later
02:04:27 <colindixon> ChristineHsieh: do you have the jenkins job for the dry run up? could you provide a link to it's run or something?
02:04:27 <suchiraman> Will report on affinity/of1.3 when we have completed testing.
02:04:51 <colindixon> suchiraman: yes, thanks, it's mostly to find bugs to hand off to the openflowplugin team
02:05:02 <suchiraman> ok
02:05:05 <colindixon> suchiraman: do you have a link to the results of your dry run test?
02:05:22 <colindixon> that way Madhu_ or others could look and make sure it's failing in the expected way?
02:05:29 <suchiraman> https://jenkins.opendaylight.org/affinity/job/affinity-bulk-release-dryrun/lastBuild/console
02:05:36 <ChristineHsieh> colindixon: we havn't created the jenkin job
02:05:38 <suchiraman> Madhu is taking a look.
02:05:47 <colindixon> perfect
02:05:47 <Madhu_> not yet.
02:05:53 <Madhu_> wrestling with my little one :)
02:06:02 <suchiraman> btw I had to create this from scratch -- should let this job be copied from controller.
02:06:04 <colindixon> Madhu_: that sounds like a much better use of time
02:06:18 <colindixon> suchiraman: I think you can copy it from the controller, can't you?
02:06:26 <hideyuki> And, we are working on the Jenkins job for a dry run for VTN Project.
02:06:28 <edwarnicke> suchiraman: If anyone can point us to how... would *love* it :)
02:06:30 <ChristineHsieh> colindixon: there will be progress today :)
02:06:47 <colindixon> ChristineHsieh: glad to hear it
02:07:25 <LuisGomez> integration is currently testing controller NSF with -of13, some issues have already been reported to ofplugin project. We will be testing -of13 option till the end of the week, I will need to change the finish date for this task in the spread sheet
02:07:38 <colindixon> is there anything anyone else needs help with or would like to discuss w.r.t. dry runs, of13, or other issues here?
02:07:59 <LuisGomez> just sent my comment
02:08:01 <colindixon> #info LuisGomez "integration is currently testing controller NSF with -of13, some issues have already been reported to ofplugin project. We will be testing -of13 option till the end of the week, I will need to change the finish date for this task in the spread sheet"
02:08:04 <colindixon> thanks
02:08:24 <hideyuki> colindixon:  about "Downloadable Release Artifacts".
02:08:36 <colindixon> yes
02:08:46 <colindixon> do we have shague__ or phrobb here?
02:08:58 <colindixon> #topic downloadable release artifacts
02:09:00 <hideyuki> I've reading this page: https://wiki.opendaylight.org/view/Simultaneous_Release:Simultaneous_Release_Plan_2014:DownloadableReleaseArtifacts
02:09:18 <colindixon> hideyuki: I should probably also be reading that :p
02:10:00 <hideyuki> We would like to add VTN artifacts to vm images (vmdk).
02:10:17 <hideyuki> Who should I contact on this?
02:10:21 <colindixon> #info VTN would like to add VTN artifacts to the vm images (vmdk)
02:10:27 <colindixon> that would be shague__
02:10:30 <colindixon> sam hague
02:10:38 <edwarnicke> One note reading it
02:10:47 <edwarnicke> I don't think defense4all is linux only (though I could be wrong)
02:10:54 <edwarnicke> I think they are written in Java... but are packaging as rpms
02:10:57 <edwarnicke> (again, could be wrong)
02:11:00 <ashaikh> we'd probably want to do that for all the downloadable artifacts in virt edition
02:11:16 <edwarnicke> hideyuki: Would you also like to add vtn artifacts to the docker images?
02:11:43 <colindixon> ashaikh: you mean the non-java artifacts?
02:11:49 <hideyuki> edwarnicke: I'm interested in it. but, to be honest, i'm not similar with docker.
02:11:56 <ashaikh> colindixon: yes
02:12:13 <colindixon> #info ashaikh points out that it might make sense to do the same (provide VMs) for all the non-java artifacts, in particular for the virtualization edition which has more of those
02:12:32 <edwarnicke> One other side request guys... I have this ambition I may not get to to do vagrants (another way to launch vms thats ultra light)... could you document somewhere which vtn and opendove rpms need to be installed?
02:12:38 <colindixon> #info hideyuki says that VTN would also be interested in docker, but that they aren't familiar with it
02:12:44 <colindixon> dbainbri1: is the guy for docker sfuff
02:13:00 <colindixon> or so I am lead to believe by his emails
02:13:02 <colindixon> hey networkstatic
02:13:02 <edwarnicke> dbainbri1: What would you need from vtn to include them in the dockers?
02:13:03 <ashaikh> we don't necessarily need a separate VM for each component, but it makes sense for at least one
02:13:20 <colindixon> ashaikh: you can #info things if you want them to go into the notes
02:13:22 <dbainbri1> if they have a dist in a ZIP file it should be real easy
02:13:23 <colindixon> I'm not the only one :p
02:14:01 <edwarnicke> hideyuki: Do you guys have rpms for your non-java artifacts?
02:14:03 <dbainbri1> really i need to understand what commands they need to run from a stock ubuntu 12.04 image to get vtn up and running.
02:14:20 <colindixon> #action hideyuki (and likely others) will reach out to shague__ about how to provide non-java artifacts as VMs to be downloaded on the download page
02:14:24 <hideyuki> edwarnicke: not yet.
02:15:09 <colindixon> so, maybe hideyuki, ashaikh, regXboi, and dbainbri1 can get together and see if we can also package stuff up as docker if there's time and interest as well
02:15:19 <networkstatic> hi colindixon
02:15:59 <colindixon> is there anything else people wanted to cover here?
02:16:00 <hideyuki> dbainbri1: Should I send a link to you for the installation of VTN artifacts?
02:16:13 <dbainbri1> sure. thx.
02:16:32 <hideyuki> dbainbri1: Ok.
02:16:55 <colindixon> so, the next topic I wanted to move onto is documentation, release notes, etc.
02:17:03 <colindixon> are people ready?
02:17:42 * networkstatic ducks out the back door
02:17:58 <colindixon> #topic documentation: user guide, developer guide, release notes, etc.
02:18:33 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:Hydrogen_Release_Work from the release wiki page, there are links to drafts for the user guide, developer guide, release notes, and release review
02:18:54 <edwarnicke> colindixon: Have we figured out where folks should start writing their docs?
02:19:00 <edwarnicke> mechanically speaking?
02:19:07 <colindixon> #link https://wiki.opendaylight.org/view/HydrogenRelease:Documentation_Scope_and_Location I will link this page into that one, but I was trying to establish a scope and an a place for the documents to live here
02:19:26 <hideyuki> #info Sarath and Venkat are working on documents for VTN Project.
02:19:34 <colindixon> I believe, we had already agreed that the documents were going to live on the wiki
02:19:44 <edwarnicke> colindixon: Do those pages (with the templates copied in) exist for Hydrogen yet?
02:19:53 <colindixon> edwarnicke: no
02:19:58 <networkstatic> did we ever get a standard set of icons by chance for pretty pictures?
02:20:04 <edwarnicke> Could we get someone to take an action item on that?
02:20:13 <colindixon> there are two controversial things I wanted to point out on this page before I do that
02:20:16 <colindixon> but I'll take the action
02:20:17 * edwarnicke cannot draw well :(
02:20:32 <edwarnicke> colindixon: Let the controversy begin
02:20:32 <colindixon> I'll take the action on creating pages with templates, not drawing icons :p
02:20:40 <networkstatic> lol
02:20:48 <colindixon> first, do we want to have a single global developer's guide
02:20:51 <colindixon> my feeling was yes
02:20:52 * edwarnicke takes a note to ask around about how to recruit graphic artists
02:20:59 <colindixon> but I'm open to other opinions
02:21:21 <edwarnicke> I would tend to agree with you, because I cannot think of a good division
02:21:30 <edwarnicke> Though I observer it will likely be a bohemoth
02:21:39 <colindixon> I'd love to get feedback from hideyuki, ashaikh, ChristineHsieh, suchiraman, and others
02:21:47 <colindixon> but I think that developers will care less about editions
02:22:02 <edwarnicke> I tend to agree with you on developers caring less about editions
02:22:18 <ChristineHsieh> agree +1
02:22:21 <ashaikh> colindixon: i think so too
02:22:36 <hideyuki> +1
02:22:38 <colindixon> the second point I wanted to make was do we want to have per-project release notes, or just aggregate at the edition level?
02:22:40 <edwarnicke> I would love to be able to find some reasonable way to divide it... but can't think of one
02:23:11 <colindixon> I'm going to #agreed the having one developer guide for hydrogen here
02:23:12 <ashaikh> even aggregated would have sections for each project, right?  is it that different?
02:23:13 <edwarnicke> I think we should have per edition release notes, as those are the vehicles
02:23:21 <edwarnicke> But they should incorporate release notes from the projects they contain
02:23:24 <edwarnicke> Just my two cents
02:24:13 <colindixon> #agreed we will have one, global developer guide which can contain information about editions and projects, but, as developers will care less about editions, it will be for all of the hydrogen release
02:24:24 <colindixon> edwarnicke, ashaikh I would tend to agree
02:24:28 <colindixon> do others have issues?
02:24:45 <colindixon> otherwise I'll update the page to take out the "?" after global for the dev guide
02:24:55 <colindixon> and take out the project scope for release notes
02:25:14 <edwarnicke> colindixon: I still think we need to incorporate the per project release notes into the per edition release notes
02:25:21 <edwarnicke> Or at least get input from the projects
02:25:23 <ashaikh> but we will still have sections for each project, right?
02:25:25 <colindixon> also, do people generally approve of the naming strategy for where things shoudl be located
02:25:55 <colindixon> edwarnicke: yes, but I figure that we can have the projects ensure that they're particular release notes get incorporated into the edition release notes
02:26:04 <colindixon> and tagged as project-specific, if need be
02:26:08 <edwarnicke> colindixon: I'm fine with that :)
02:26:10 <colindixon> right?
02:26:32 <ashaikh> colindixon: yes, in virt edition, for example, they will be very project-specific
02:26:55 <colindixon> #agreed we will not have per-project release notes, but this information will be incorporated into per-edition release notes and tagged as project specific if need be (this will be particularly necessary in the virtualization edition)
02:27:35 <colindixon> ok, I made those changes
02:28:02 <colindixon> are people happy with the naming scheme of "HydrogenRelease:<edition-name>_*"
02:28:30 <colindixon> if so, I'll go ahead and make those pages
02:28:36 <edwarnicke> I aam
02:28:44 <colindixon> #info networkstatic would like to know if we have standard iconography for the documentation
02:29:18 <networkstatic> i think Omar was going to poke around on that fwiw.
02:29:30 <colindixon> #action colindixon will create the actual template pages for each edition and/or global document for user/developer guides and release notes
02:29:32 * edwarnicke did not know Omar could draw :)
02:29:37 <ashaikh> colindixon: is this naming just for wiki pages ?
02:29:41 <colindixon> yes
02:29:42 <networkstatic> hehe
02:30:15 <colindixon> oh, the last point, the release review documents should be created in project's own namespaces as per the proposals
02:30:17 <colindixon> right?
02:30:23 <colindixon> keep all the project lifecycle stuff together
02:30:30 <edwarnicke> colindixon: I would say so
02:30:57 <ashaikh> so not something like release/hydrogen/base  (i.e., subpages) ?
02:31:00 <colindixon> ok
02:31:20 <colindixon> ashaikh: I'd be happy to do subpages
02:31:24 <colindixon> that might make more sense
02:31:27 <colindixon> I can look into that
02:31:34 <colindixon> it makes a lot of sense
02:32:05 <colindixon> #info ashaikh suggests using subpages for the documentation like release/hydrogen/base/User_Manual
02:32:15 <colindixon> that makes *a lot* of sense
02:32:27 <ashaikh> cool
02:32:30 <edwarnicke> ashaikh: That sounds good to me too
02:32:43 <colindixon> edwarnicke: are there release review documents for each release?
02:32:50 <colindixon> if so, those should probably also be under subpages
02:32:59 <colindixon> unlike for proposals where there's only one
02:33:02 <edwarnicke> edwarnicke (in a rare self use of the third person) would also like to speak up for TOC thus making things in the pages easily linkable
02:33:21 * edwarnicke likes appropriate use of subpages
02:34:27 <colindixon> #info it seems like the release review documents should live in their projects namespaces to keep them with the other project lifecycle documents, however since these will be recurring, using subpages seems to make sense so pages something like <LongProjectName>:Release_Review/<ReleaseName>
02:34:31 <colindixon> ok
02:34:44 <colindixon> I *think* that's what I wanted to get through tonight
02:34:52 <colindixon> are there other things people wanted to go over
02:34:57 * edwarnicke and the peasants rejoiced!
02:35:02 <networkstatic> Good ref for us http://docs.openstack.org
02:35:05 <networkstatic> :)
02:35:25 <edwarnicke> networkstatic: I look forward to tbachmanOVSDB taking us to that promised land in Helium :)
02:35:28 <colindixon> #link http://docs.openstack.org is a good reference to look at as we start documenting like crazy
02:35:55 <colindixon> networkstatic: or at least to the clouds in a less explosive manner :p
02:36:02 <networkstatic> LOL
02:36:14 * colindixon is mildly embarrassed of that joke
02:36:20 <colindixon> ok
02:36:52 * edwarnicke intends to ask for hot air ballon rides at the summit following Helium
02:37:02 <networkstatic> +1
02:37:12 <colindixon> ChristineHsieh, hideyuki, ashaikh, networkstatic, suchiraman, LuisGomez, edwarnicke any last topics?
02:37:32 <ashaikh> i'm good
02:37:37 <networkstatic> #info networkstatic for ovsdb
02:37:39 <LuisGomez> not really
02:37:40 <hideyuki> colindixon: no topics from me.
02:37:40 <networkstatic> good here sir
02:37:45 <colindixon> ok
02:37:49 <colindixon> I'll let you get back to real work
02:37:52 <colindixon> thanks for coming
02:37:52 <suchiraman> all set.
02:38:00 <suchiraman> thank you colindixon. good meeting.
02:38:03 <networkstatic> thanks colindixon
02:38:05 <colindixon> #endmeeting